Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Remove Google permanently. Keeps coming back as default.

  • 4 fhreagra
  • 1 leis an bhfadhb seo
  • 9 views
  • Freagra is déanaí ó jscher2000

more options

I switch my default search to Duck duck go, remove all others and when I restart Firefox; Google is back and set as my default search engine. If I wanted anything to do with Google I'd use Chrome.

All Replies (4)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Google “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

more options

No Google extensions.

more options

It sounds like the site your using isn't the problem but the settings sounds like it is messed up in firefox. Did you look there at your "Options" to see what is set at.

more options

Hi kulajon, instead of removing other search engine plugins, try just "un-checking" them so they don't appear on the one-click search engines list. Any difference?

Your search engine preferences are saved in a file named search.json.mozlz4 in your currently active profile folder (Profiles - Where Firefox stores your bookmarks, passwords and other user data).

Are those the only settings you lose between Firefox sessions?