Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Disable specific address bar auto-fill suggestions.

more options

The last two updated have killed the functionality of the address/search bar. It's now supposed to be an "awesome bar" but it's quite the opposite. Instead of my normal bookmarks, like "https://www.youtube.com/feed/subscriptions" when I start typing youtube I get "youtube.com." I have tried the shift+delete to remove this suggestion but I guess the update doesn't let us do that anymore. I really want to be able to have the bar work like it used to, autofilling your most used favorite, not random garbage.

All Replies (7)

more options

No plans to fix this? Think about how many tabs are opened a day, and this updates makes every single one more tedious because now we have to scroll down through a list.

more options

If an item in the drop-down list has a star next to it then this is a bookmark and you can't use Shift+Delete to remove this item permanently, but you need to remove this bookmark in the Bookmarks Manager (Library). Otherwise you can try to remove this item from the history (if necessary do a search in the sidebar or Library).

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page
    in case errors are reported close and restart Firefox and retry

See also:

more options

No errors from verify integrity, and the other two links didn't seem to apply to my problem, unless I'm missing something. Thanks for the help so far! Guess this isn't a high priority for mozilla, sadly.

more options

Can you clarify whether those suggestions are bookmarks (i.e. have the star) or are history items?

more options

They are neither bookmarks nor history. My history auto-clears upon exit, and the problem exists even after clearing history manually. There is no star next to them. I don't know how to remove them from my non-existent history. Searching for them by name in history doesn't bring anything up either.

more options

If "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page cannot repair places.sqlite then remove all places.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

That did not do the trick either. I guess Mozilla really wants to push these specific websites.