Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

some sites do not display

  • 8 bhfreagra
  • 1 leis an bhfadhb seo
  • 252 views
  • Freagra is déanaí ó FredMcD

more options

Some sites like Garmin Connect and Curiosity Stream do not display. I simply get a blank page. I can display them through Chrome with no problems

Réiteach roghnaithe

Hello JimCarter,

The DuckDuckGo extension is known to cause these kind of problems - your system details show that you have that extension installed .....

Would you disable it and see if that will make a difference  ?

Read this answer in context 👍 1

All Replies (8)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

FredMcD said

Make sure you are not blocking content. Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

In safe mode it does display the page but there is no shield when I open Curiosity stream when opening FireFox normally. So if opening in safe mode fixes the problem how to I fix the issue?

more options

Réiteach Roghnaithe

Hello JimCarter,

The DuckDuckGo extension is known to cause these kind of problems - your system details show that you have that extension installed .....

Would you disable it and see if that will make a difference  ?

more options

JimCarter said

Some sites like Garmin Connect and Curiosity Stream do not display. I simply get a blank page. I can display them through Chrome with no problems

It was not DuckDuckGo this time it was Mcaffee Web Advisor

more options

JimCarter said

It was not DuckDuckGo this time it was Mcaffee Web Advisor

Good for you to have found the culprit  !

Would you be so kind as to remove the Chosen Solution mark from my post (after all : I was wrong ... ) and mark FredMcD's post as Chosen Solution (he suggested you'd try Safe Mode).

Thank you in advance  !

more options

But it was your response that led me to check all of the extensions present. I did not do that until I read yours. The safe mode just told you all that it was some sort of extension. I did not take the action of removing all cookies, etc.

Athraithe ag JimCarter ar

more options

Good work both of you.