Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Why only in FireFox my Twitter Safty settings are changed automatically 7 prevent me from changing them as I desire?

  • 20 freagra
  • 1 leis an bhfadhb seo
  • Freagra is déanaí ó McCoy

more options

Only in FIREFOX, my TITTER safety settings are changed & locked automatically. If I try to change the settings as I desire, I may not be able to do it as it can NOT be changed. I am using FIREFOX for years. I am only encountering this problem recently after I installed a fresh version of FIREFOX.

I have just been forced to use Google Chrome instead of FIREFOX just for this problem. I can NOT change * uncheck either: -Hide sensitive content -Remove blocked and muted accounts Please see the photo & inform me if I could correct this problem so I can use FIREFOX back again. In previous version or via CHROME, I can change these 2 setting as I want, but not the most current version of FIREFOX

All Replies (20)

more options

When you mean "fresh version of Firefox" what exactly does that mean?

1. installed over previous FF 2. uninstalled FF and deleted Mozilla folder

So which is it?

more options

Hi SaifBitar, I'm concerned that your Firefox is exhibiting this strange behavior, which I don't think it normal for Firefox 62.

If a site is generally known to work in Firefox, these are general suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components.

Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Thank you for your reply.

Yesterday, I cleared the Cache & the problem was resolved then. This morning, My FIREFOX crashed & was shut down by itself as has been happening frequently, when i started FireFix again, the same problem happened again. I check my Twitter safety settings & found it automatically changed (Boxes checked) & dimmed (Can NOT be changed, while it is OK using Chrome. How could I solve the problem completely? & how could I solve the problem of FIREFOX crashing very often & automatically

more options

Hi SaifBitar, when Firefox crashes, what happens?

  • Firefox disappears and a Windows crash dialog appears. Usually that's a short dialog with options like Restart the program, Search for a Solution.
  • Firefox just closes as though you did it yourself.
more options

When it crashes, I get the "Report the problem" window, it asks me as well to restart FireFox or Quit FireFox, I always select "reporting the problem" & relaod FireFox, then I get "Restore session".

This is NOT my major problem with FIREFOX, my main problem is why my Twitter Safety options are pre-selected & locked (Can NOT be deselected")?

I have Kaspersky internet security installed. Does that matter? If YES, why I don't have this same problem when opening twitter via other browsers such as Chrome or Edge?

I can not watch any video in Twitter because of this problem, Here are screenshots of the safety options that are selected against my will & a screenshot of how videos appear in twitter

more options

Does clearing the cache, or cache and cookies, work this time?

Do you have any security or family safety add-ons or external software that could be modifying your browsing?

more options

Clearing Cache does not solve the problem. It did one time only, then, the problem became constant & permenant.

I have Kaspersky internet security installed

more options

One thing you could try while you wait for any authoritative explanation is to try a fresh Firefox profile.

New Profile Test

This takes about 3 minutes, plus the time to test the site.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Sept2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Does Twitter work any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

more options

Thank you for your time,

I did exactly what you suggested, regrettably, the problem persists, Twitter Safety settings are pre defined & not available for my selection or change. Videos could not be watched via Twitter UNDER FireFox.

This problem does NOT occur in CHROME or EDGE, ONLY FIREFOX

THe second file of Twitter setting with yellow highlighter is in CHROME, you can see that I can change my settings freely. The first one without highlighter is in FireFox were my settings are pre selected & locked


more options

Hello SaifBitar,

Stab in the dark, but would you take a look at this, and scroll down to the section :

Do you have any third-party connections to your Twitter account?

Another "stab":

Would you disable Kaspersky and see if that will make a
difference  ?

One more question : Are you sure that you haven't turned on Tracking Protection, as suggested by jscher2000 in his first post  ?

more options

When I scroll down to the section : Do you have any third-party connections to your Twitter account

I get a message saying: Sorry, we were unable to load this page completely. Please retry.

As for Kaspersky, neither mode "active' nor "deactive" resolve the problem

For Tracking protection, wither it is turned on or off, the problem remains unsolved

more options

SaifBitar said

When I scroll down to the section : Do you have any third-party connections to your Twitter account I get a message saying: Sorry, we were unable to load this page completely. Please retry.

This is what it says :

"Do you have any third-party connections to your Twitter account?

Sometimes issues can arise through third-party connections to your Twitter account. Visit your Apps settings to review third-party connections and try revoking access for any unnecessary apps. You can read about how to revoke third-party access to your account. "

In this blog it says :

"Twitter App settings and advertisements

Over the years, you may have used Twitter to login to various apps and forgotten about it. Just like you did for Facebook, check your Twitter App settings to review what apps have access to your Twitter account. Revoke access for apps that you no longer use or prefer not to have access to your account information and data."

However, the above may have nothing to do with this issue ......

Athraithe ag McCoy ar

more options

Twitter Safe Search settings are available on my Firefox, so I think it's something on your computer:

But if it's not caused by an extension, what is doing it? Hmm.

Regarding videos not playing, do you have at least 5 blue boxes on this test page:

And while on Twitter, can you rule out Tracking Protection as a potential culprit? See: What happened to Tracking Protection?.

more options

1) Here is the screenshot of the "Twitter App settings and advertisements". NO Aps are running or authorized

2) No matter wither tracking protection is OFF or ON, No matter wither Kaspersky is ACTIVE or INACTIVE, The problem persists ONLY with FIREFOX.

With CHROME, I do NOT have this problem at all

more options

Attached, please find a screenshot of the page

By the way, Youtube plays well in my FireFox, only videos in Twitter do NOT play

more options

So far, there's no explanation for the Twitter problems. The New Profile test should rule out Firefox settings, add-ons, and accumulated data in your regular profile. Here are two other things:

Connection Settings

You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

Clean Reinstall

This takes about 5 minutes. It's not about your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. It's not essential to uninstall Firefox, but you can if you like, saying No to any request about removing personal data.

It only takes a few minutes.

(A) Download a fresh installer for Firefox to a convenient location:

(B) Exit out of Firefox (if applicable).

If you use Microsoft Office, please change your default browser to Internet Explorer temporarily before the next step.

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both):

C:\Program Files (x86)\Mozilla Firefox =to=> C:\Program Files (x86)\OldFirefox

C:\Program Files\Mozilla Firefox =to=> C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

more options

1) The "Connection Settings" alternative accomplished but did not solve the problem 2)The Clean Reinstall, I have a problem following your instructions:

(C) Using Windows Explorer/My Computer (hold down the Windows key and press E to launch it), right-click > rename the program folder as follows (you might have one or both)

I could not do it as I did not understand how

more options

You can open Windows Explorer from the Start menu, or maybe from a desktop icon. If you can't find it, then you can hold down the "Windows" key on the keyboard and tap and release E -- that will pop up a Windows Explorer window.

Then, click the C drive, which might be listed as

- Some name (C:)

On the right side, double-click

Program Files

If you see Mozilla Firefox listed on the right side, right-click it and choose Rename, then edit the name to OldFirefox and then click away from the edit to finish.

If you don't find that under Program Files, look under

C:\Program Files (x86)

instead. Same process.

more options

Thanks a lot for your valuable help. It finally worked. All is fine now.

You have been a great help

more options

SaifBitar said

It finally worked. All is fine now.

Phew - that must be a huge relief  !

Would you be so kind as to mark jscher2000's post as "Chosen Solution" ("Solved the problem" button to the right of ths post)  ?

Thank you in advance  !