Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How do I disable the default browser check?

  • 3 fhreagra
  • 1 leis an bhfadhb seo
  • 1578 views
  • Freagra is déanaí ó jscher2000

more options

Simple as that. I'm running version 61.0.2. There's a checkbox in Options/General/Startup, but changing its state appears to be 100% disabled.

Réiteach roghnaithe

There is a preference for this that you can adjust behind the scenes:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste shell and pause while the list is filtered

(3) Double-click the browser.shell.checkDefaultBrowser preference to switch the value from true to false

Read this answer in context 👍 1

All Replies (3)

more options

Would you please take a look at this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1189038

When you scroll down, you'll see :

"Bug 1041516 made it so that when you set Firefox as the default browser, checking for default status on startup also gets set. That's good but we didn't prevent the check on startup setting from being unchecked. So a user can sabotage themselves by opening the options tab and unchecking "Always check if Firefox is your default browser." This will put them in a state where another browser can be set as default without Firefox noticing. We should make this setting unable to be changed when Firefox is the default browser."

more options

Réiteach Roghnaithe

There is a preference for this that you can adjust behind the scenes:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste shell and pause while the list is filtered

(3) Double-click the browser.shell.checkDefaultBrowser preference to switch the value from true to false

more options

By the way, your Firefox reported you have Flash 28, and the current version is Flash 30. This article has the steps for updating the plugin, if Adobe's auto-updater is not working: Flash Plugin - Keep it up to date and troubleshoot problems.