Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

WebGL doesn't work in Firefox 61 with intel drivers

  • 6 fhreagra
  • 1 leis an bhfadhb seo
  • 557 views
  • Freagra is déanaí ó gcpascutto

more options

OS: Linux paul-pc 4.18.3-1-MANJARO #1 SMP PREEMPT Sat Aug 18 12:18:05 UTC 2018 x86_64 GNU/Linux

Firefox 61

WebGL doesn't work on intel driver, but if I run firefox with optirun — it works. Also WebGL in Chrome works on Intel too.

Athraithe ag asm0dey ar

Réiteach roghnaithe

This is caused by a change in the lastest Mesa's that Manjaro ships. Mesa tries to access parts of the filesystem it should have no business with and the Firefox sandbox blocks it.

Mesa Bug: https://bugs.freedesktop.org/show_bug.cgi?id=107516

Firefox Bug (with workaround): https://bugzilla.mozilla.org/show_bug.cgi?id=1480755

Updating Firefox to 62 solves this, as does updating Mesa (libdrm) to an even more recent version - the issue has been fixed on both sides. If you can't update Mesa or Firefox, apply the workaround in the bug, but don't forget to remove it when Firefox 62 is released.

Read this answer in context 👍 0

All Replies (6)

more options

Are there any messages in the Graphics section on the "Help -> Troubleshooting Information" (about:support) page related to WebGL ?

more options

cor-el said

Are there any messages in the Graphics section on the "Help -> Troubleshooting Information" (about:support) page related to WebGL ?

Yes, there are. Sorry for my initial wrong answer, I dudn't understand your question and thought you're talking about error messages. I can't see error messages, but can see lots of information about Web GL.

Athraithe ag asm0dey ar

more options

The screenshot you posted seems to indicate that WebGL should be working properly as I'm not seeing any errors reported.

more options

cor-el said

The screenshot you posted seems to indicate that WebGL should be working properly as I'm not seeing any errors reported.

I think so too, but please see attached screenshot

more options

Réiteach Roghnaithe

This is caused by a change in the lastest Mesa's that Manjaro ships. Mesa tries to access parts of the filesystem it should have no business with and the Firefox sandbox blocks it.

Mesa Bug: https://bugs.freedesktop.org/show_bug.cgi?id=107516

Firefox Bug (with workaround): https://bugzilla.mozilla.org/show_bug.cgi?id=1480755

Updating Firefox to 62 solves this, as does updating Mesa (libdrm) to an even more recent version - the issue has been fixed on both sides. If you can't update Mesa or Firefox, apply the workaround in the bug, but don't forget to remove it when Firefox 62 is released.