Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox crashing on startup despite restore and reinstall

  • 18 freagra
  • 1 leis an bhfadhb seo
  • 20 views
  • Freagra is déanaí ó Clouseau

more options

Yosemite 10.10.5. Firefox Quantum 61.0.1. MacBook Pro new January 2010. I've used Firefox for years. In the last month or two Firefox has started crashing on startup. Not every startup, just the first one after the MAC starts. Usually it crashes before it gets as far as showing a web page. Now and again it takes longer, and once in a while I get as far as trying to do something on the web page and then it abruptly vanishes. When it crashes, I don't get a crash reporter or an error message, it just all vanishes and starts starting up again. It always makes it on the second try. If I close it and then open it again, it will carry on working after that until I shut the MAC down. The next time I use it, it's the same story again - crashes and restarts the first time, then OK after that.

I've tried several refreshes. I've looked for add-ons that might be upsetting it. I've used AppCleaner to strip it right off and put it back on again. I have a virus checker running that isn't finding anything. Chrome and Safari are both working fine. I'm wondering if 61.0.1 might just be incompatible with Yosemite? or is this just what 61.0.1 does??

All Replies (18)

more options

We're sorry to hear that Firefox is crashing when you open it. Please do the following to give us crash IDs that will help us understand more about the crash.

  1. (OS X 10.6 or previous) Click the Finder icon in the dock. Your home folder will be selected. In the right side of the window, click the Library folder to open it. Then open the "Application Support" folder, the "Firefox" folder, the "Crash Reports" folder and finally the "submitted" folder.
    (OS X 10.7 or above) Click the Finder icon in the dock. On the menu bar, click the Go menu, hold down the option or alt key and select Library. A window will open containing your Library folder. Then open the "Application Support" folder, the "Firefox" folder, the "Crash Reports" folder and finally the "submitted" folder.
  2. Open the 5 most recent files with a text editor and copy the IDs.
  3. Paste each ID with bp- into the reply window on the forums.

Thanks in advance!

You can find more information and troubleshooting steps in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

more options

Also, I strongly suggest you update to MacOS High Sierra. https://www.apple.com/macos/high-sierra/

It's a free update with security, performance and stability improvements. It may not fix this issue, but should be done

more options

Apparently no crash records. In Crash Reports I see an Events folder (which is empty), and a separate file with a name starting InstallTime. If I start Firefox, of course it fails to start and then tries again, but this still doesn't appear to generate a crash report. It would appear that whatever is happening, Firefox doesn't believe it has crashed.

I regret I am unable to upgrade to High Sierra as my machine is too old. It was originally Snow Leopard and has already been upgraded once. There seems to be some suggestion one program that worked with no problems before that upgrade sometimes struggles a bit after it, so I certainly can't upgrade again. MACTRACKER says the last operating system that this machine will run is 10.11.6.

more options

You said your Mac was from 2010, it should be able to upgrade: https://www.apple.com/macos/how-to-upgrade/#hardware-requirements

more options

I said it was new in 2010 - that is, it was bought in January 2010. According to Mac Tracker, it was actually manufactured in 2009. I gather there were other machines of a later vintage sold in 2010, but mine wasn't one of them. I'm afraid I propose to take Mac Tracker's word for it i.e. El Capitan is the last build my machine will run. I cannot afford another degradation of performance to the program I mainly use on it and bought it for, so in my case with regret no another upgrade isn't really an option.

Are you saying either that (1) this issue cannot be fixed at Yosemite, or (2) it isn't worth investing any time in investigating it since anyone with Yosemite should be upgrading?

more options

Well, you should update to El capitan at least then. yosemite is not support by apple any longer, and you should have the latest version your computer can run.

Because you have such an old OS, and apparently there are no crash ID's, it's best to try upgrading to see if this is an OS issue.

You should have no problems updating, it'll probably make your machine a bit faster, plus safer

more options

Unfortunately that's not really an option. In the end I can live without Firefox, there are other browsers. But I bought the machine to run one specific software program, and it appeared not to like the last upgrade. If it liked the next one even less, as I understand it there would be no way back. If Firefox isn't fixable at Yosemite I may have to live without it. I'd feel I'd made a really stupid mistake if I upgraded, couldn't use the other program and couldn't go back. Sorry.

more options

Not upgrading is also a VERY bad idea. You're at risk for a multitude of security issues.

Have you tried to refresh Firefox? Refresh Firefox - reset add-ons and settings

more options

As I explained at the beginning, I've refreshed several times. I've also completely uninstalled Firefox and reinstalled it. I also tried to explain that my hardware cannot accommodate upgrades beyond a certain point. I cannot go on upgrading, the machine can't take it. At some point I have to rely on virus protection, firewalls etc. I'm not sure it's helping either of us to keep going over and over this.

Is there any way of enabling more detailed logging on Firefox? I can't find it at the moment.

PS. Don't look now but this time when I started firefox expecting it to crash, it didn't......... shhhhh......

more options

It's subsequently done it again. Apparently still no crash data. As there doesn't seem to be any obvious way of enabling additional logging, it would appear that we've reached the end of the road here and that I will have to wind down use of Firefox, maybe double check that I have any passwords somewhere else and then uninstall it and settle for Chrome or Safari. I have to admit to being surprised.... I honestly thought I'd get more assistance than this. Maybe Firefox just isn't the sort of application that's easily fixable - maybe there are times when for no obvious reason it just doesn't work and that's it. Thanks at least for taking the time to post something in response, and better luck with the next issue.

more options

One thing you can also try is this:

https://support.apple.com/en-us/HT201560

more options

The link appears to give instructions for a file permissions repair. I did this, and ran the periodic scripts, and did a cleanup with CCleaner. I then rebooted and tried again, but I'm afraid it made no difference. Firefox tried to start, didn't make it and had to try again.

Any other suggestions or any way of finding out exactly what it did when it started?

more options

The only other thing I can suggest is to uninstall Firefox, then re-install it. Uninstall Firefox from your computer

Download Firefox again from www.getfirefox.com

Other than that, we're back to updating MacOS

more options

Check previous postings in this thread - I've already tried that. I have to admit to being surprised that it didn't work. I could only think of three reasons why it might not have:

  1. There was something in the imported configuration, present in the old installation that was copied back into the new one, that was causing it
  2. there is some software on my Mac that Firefox doesn't like
  3. This build of Firefox (61) isn't compatible with this build of OS X (Yosemite).

To go over this again, this machine is now more than eight years old. I simply cannot keep installing the very latest operating system build however much that might ideally be desirable. If software people like Mozilla decide that program X requires minimum build Y and that they aren't going to support earlier versions that run on earlier builds, that I understand, but it might be good to say that if that's the position.

It looks to me as if I'm going to have to bail out from Firefox. I'm typing this on Chrome 67 (which funnily enough is updating at this very moment) and it's doing fine. I don't really need Firefox and I don't need the hassle from it if it can't be persuaded to work. Fair enough?

more options

Hi, have you gone into ccleaner and made sure it is not cleaning too much of Firefox out ?

Also there has been 2 viruses attached to ccleaner in last 6mos. Maybe a scan would be useful : https://www.malwarebytes.com/mac/

more options

Hello.

I only very rarely use CCleaner on the Mac. It's currently at version 1.03.131. Avast is up to date and running continually. Now and again I do a scan with it, and it's scanning as I type this (14% nothing found). I've been a bit reluctant to use CCleaner because it can delete things that then have to be laboriously set up again. I only did it this time in case there was some clutter or corruption that it might have found and removed.

The word on the CCleaner virus appears to be here: https://thehackernews.com/2018/04/ccleaner-malware-attack.html

and it would appear co-incidentally that it was Avast who discovered the problem. Quote from a linked page: "Avast and Piriform have both confirmed that the Windows 32-bit version of CCleaner v5.33.6162 and CCleaner Cloud v1.07.3191 were affected by the malware." That is, it appears to have affected Windows, not Mac.

The official report on this appears to be the link below, and again there doesn't seem to be any suggestion that OS X was affected: https://www.ccleaner.com/news/blog/2017/9/18/security-notification-for-ccleaner-v5336162-and-ccleaner-cloud-v1073191-for-32-bit-windows-users

I've seen an email which appears to say (though I can't find it on this page) that someone has posted on this thread that my battery is leaking and my motherboard is damaged. My battery was replaced at the same time that the operating system was upgraded. Neither OS X nor Coconut appear to have any problem with it. Coconut reports that it was manufactured in March last year and has a cycle count of 123. It also still has higher than design specification maximum capacity. I'm really not sure what I can usefully say about the motherboard, except to say that only this one program is affected, and even then only once per startup. Other than that and some ageing on the previous battery the machine as a whole appears to have behaved itself immaculately for more than eight years. I'm afraid I can't justify taking it to pieces to test the motherboard on that basis.

I think we need to be careful not to make suggestions with no obvious supporting evidence here. If someone can tell me, you enable the log* with this menu option and if it says this or that then it means.... whatever.... that's different, because then it's evidence based. Or if someone says, I had this exact problem last month and it turned out that it was..... and I fixed it by..... again that's different. But I would suggest that we need to be careful that we avoid starting with an assumption that there can't be anything amiss that has anything to do with Firefox and therefore it must be a fault with my machine.


  • I did try googling this, and if I'm understanding this correctly Firefox doesn't actually have a log. There might be files that it writes in, such as crash logs, and now and again it might write in a system event log (such as Windows event viewer), but it doesn't actually run an internal event log itself. I've also seen comments that issues can sometimes be identified by having the console open while the issue occurs, but if the whole program exits at that point then presumably it's going to take any console output with it. It would seem that it didn't occur to the developers that there could be a disruptive issue that didn't generate a crash log.
more options

Hi, know we would not be saying your battery is leaking and your motherboard is damaged. Idiot thing to suggest. Take battery out for 10mins but that is a OS/bios issue and not Firefox fix.

Correct it does not have logs unless it crashes. Which in this case as we know it is not generating one. If Mac has anything like the Windows Event Viewer it would be useful to see what it says.

So come to the end of this at this time until a new version is released Sept 8th I think it is, unless you want to move to the Extended Release Version and see if that fixes the issue.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

more options

EUREKA. I have found a crash report! It wasn't where it was supposed to be though. It was in the Mac equivalent of Windows event viewer: Applications / Utilities / Console. Unfortunately your website will not permit it to be pasted in, or attached. I've had to edit it repeatedly, cutting more and more stuff out, so apologies if these are the wrong bits.


Process: plugin-container [1338] Path: /Applications/Firefox.app/Contents/MacOS/plugin-container.app/Contents/MacOS/plugin-container Identifier: org.mozilla.plugincontainer Version: 1.0 Code Type: X86-64 (Native) Parent Process:  ??? [1] Responsible: plugin-container [1338] User ID: 501

Date/Time: 2018-08-07 22:28:49.836 +0100 OS Version: Mac OS X 10.10.5 (14F2511) Report Version: 11 Anonymous UUID: 79F267F7-36F1-40B1-7F71-68ACEA72A151


Time Awake Since Boot: 1300 seconds

Crashed Thread: 6 Chrome_~dThread

Exception Type: EXC_BAD_ACCESS (SIGSEGV) Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

VM Regions Near 0: -->

   __TEXT                 00000001058b0000-00000001058b1000 [    4K] r-x/rwx SM=COW  /Applications/Firefox.app/Contents/MacOS/plugin-container.app/Contents/MacOS/plugin-container

Application Specific Information: libcoreservices: _dirhelper: 454: mkdir: path=/var/folders/zz/zyxvpxvq6csfxvn_n00001ym0000gn/C/ modes[2]=0700: No such file or directory

Thread 0:: Dispatch queue: com.apple.main-thread 0 com.apple.QuartzCore 0x00007fff976b457b CA::Transaction::push() + 1 1 com.apple.QuartzCore 0x00007fff976cf998 CA::Transaction::ensure_implicit() + 276 2 com.apple.AppKit 0x00007fff8f70d924 -[NSApplication sendEvent:] + 218 3 XUL 0x0000000107be372a thread-local wrapper routine for mozilla::dom::FlushRejections::sDispatched + 2236202 4 com.apple.AppKit 0x00007fff8f637b68 -[NSApplication run] + 711

Thread 1:: Dispatch queue: com.apple.libdispatch-manager 0 [edited out here] 1 [edited out here]

Thread 2: 0 [edited out here] 1 [edited out here]

Thread 3: 0 [edited out here] 1 [edited out here]

Thread 4: [edited out here]

Thread 5: [edited out here]

Thread 6 Crashed:: Chrome_~dThread 0 XUL 0x0000000106085e89 nsXPTCStubBase::Stub249() + 4616873 [1-7 very similar, edited out here] 8 libsystem_pthread.dylib 0x00007fff97d9805a _pthread_body + 131 9 libsystem_pthread.dylib 0x00007fff97d97fd7 _pthread_start + 176 10 libsystem_pthread.dylib 0x00007fff97d953ed thread_start + 13

Thread 7:: JS Watchdog 0 libsystem_kernel.dylib 0x00007fff91e02136 __psynch_cvwait + 10 1 libnss3.dylib 0x0000000105a16ecd PR_WaitCondVar + 253 2 XUL 0x0000000106318024 nsXPTCStubBase::Stub249() + 7312452 3 libnss3.dylib 0x0000000105a1904a 0x1058c2000 + 1405002 4 libsystem_pthread.dylib 0x00007fff97d9805a _pthread_body + 131 5 libsystem_pthread.dylib 0x00007fff97d97fd7 _pthread_start + 176 6 libsystem_pthread.dylib 0x00007fff97d953ed thread_start + 13

Thread 8:: JS Helper [edited out here]

Thread 9:: JS Helper [edited out here]

Thread 10: [edited out here]

Thread 11:: Socket Thread 0 libsystem_kernel.dylib 0x00007fff91e023fa __select + 10

Thread 12:: Hang Monitor 0 libsystem_kernel.dylib 0x00007fff91e02136 __psynch_cvwait + 10

Thread 13:: Timer 0 libsystem_kernel.dylib 0x00007fff91e02136 __psynch_cvwait + 10 1 libmozglue.dylib 0x000000010b8358d9 mozilla::detail::ConditionVariableImpl::wait_for(mozilla::detail::MutexImpl&, mozilla::BaseTimeDuration<mozilla::TimeDurationValueCalculator> const&) + 297 2 XUL 0x0000000105c0b1d0 thread-local wrapper routine for mozilla::SchedulerGroup::sTlsValidatingAccess + 24400 3 XUL 0x0000000105c0fc34 thread-local wrapper routine for mozilla::SchedulerGroup::sTlsValidatingAccess + 43444 4 XUL 0x0000000105c17e0f thread-local wrapper routine for mozilla::SchedulerGroup::sTlsValidatingAccess + 76687 5 XUL 0x0000000106087f7b nsXPTCStubBase::Stub249() + 4625307 6 XUL 0x0000000106051279 nsXPTCStubBase::Stub249() + 4400793 7 XUL 0x0000000105c0deb1 thread-local wrapper routine for mozilla::SchedulerGroup::sTlsValidatingAccess + 35889 8 libnss3.dylib 0x0000000105a1904a 0x1058c2000 + 1405002 9 libsystem_pthread.dylib 0x00007fff97d9805a _pthread_body + 131 10 libsystem_pthread.dylib 0x00007fff97d97fd7 _pthread_start + 176 11 libsystem_pthread.dylib 0x00007fff97d953ed thread_start + 13

Thread 14:: PaintThread [edited out here]

Thread 15:: ImgDecoder #1 0 libsystem_kernel.dylib 0x00007fff91e02136 __psynch_cvwait + 10

Thread 16:: ImageIO [edited out here]

Thread 17:: StreamTrans #1 [edited out here]

Thread 18:: ImageBr~geChild [edited out here]

Thread 19:: VideoChild [edited out here]

Thread 20:: ProcessHangMon [edited out here]

Thread 21:: ProfilerChild [edited out here]

Thread 22: [edited out here]

Thread 6 crashed with X86 Thread State (64-bit):

 rax: 0x0000000109d0a93b  rbx: 0x000000010bb74100  rcx: 0x000000010b84d4a8  rdx: 0x0000000000000000
 rdi: 0x000000010b636d20  rsi: 0x000000010bb45040  rbp: 0x000000010bb73400  rsp: 0x000000010f386b60
  r8: 0x000000011a100858   r9: 0x000000010b311700  r10: 0x00000000ffffffff  r11: 0x0000000000000212
 r12: 0x0000000000000082  r13: 0x000000010bb05380  r14: 0x000000010bb74120  r15: 0x0000000000000001
 rip: 0x0000000106085e89  rfl: 0x0000000000010202  cr2: 0x0000000000000000
 

Logical CPU: 1 Error Code: 0x00000006 Trap Number: 14


Binary Images: [edited out here]

External Modification Summary:

 Calls made by other processes targeting this process:
   task_for_pid: 2
   thread_create: 0
   thread_set_state: 0
 Calls made by this process:
   task_for_pid: 0
   thread_create: 0
   thread_set_state: 0
 Calls made by all processes on this machine:
   task_for_pid: 592
   thread_create: 0
   thread_set_state: 0

VM Region Summary: ReadOnly portion of Libraries: Total=299.0M resident=141.0M(47%) swapped_out_or_unallocated=158.0M(53%) Writable regions: Total=60.0M written=12.4M(21%) resident=15.2M(25%) swapped_out=0K(0%) unallocated=44.8M(75%)

REGION TYPE VIRTUAL

===== =

CG shared images 144K Dispatch continuations 4096K Kernel Alloc Once 8K MALLOC 18.4M MALLOC (admin) 32K Mach message 64K Memory Tag 242 12K STACK GUARD 56.1M Stack 21.5M VM_ALLOCATE 1.0G __DATA 37.2M __IMAGE 528K __LINKEDIT 72.3M __TEXT 226.7M __UNICODE 552K mapped file 207.4M shared memory 132K

===== =

TOTAL 1.6G