X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Homepage not activated in new version

Postáilte

Annoying new development in the newest Firefox. 1) I cannot enter a search term in the URL field anymore. 2) When I open a new tab, then it does not go to my homepage (which is my default browser)

I now have to Open a new tab, then once open, I have to (like an idiot) press the home page icon to get my default search engine to display.

Firefox used to open my homepage on every new empty tab created. Not anymore...

Firefox worked well. I cannot understand the reason for this silly development. It is truly counterproductive.

Is there anyway in the about:config that I can switch of this cat and mouse that the new version plays with my ability to get to my default search engine.



Version 60.0.1 (64-bit) PRETTY_NAME="Debian GNU/Linux 9 (stretch)" NAME="Debian GNU/Linux" VERSION_ID="9" VERSION="9 (stretch)" ID=debian Linux version 4.9.0-6-amd64 (debian-kernel@lists.debian.org) (gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1) ) #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07)

Annoying new development in the newest Firefox. 1) I cannot enter a search term in the URL field anymore. 2) When I open a new tab, then it does not go to my homepage (which is my default browser) I now have to Open a new tab, then once open, I have to (like an idiot) press the home page icon to get my default search engine to display. Firefox used to open my homepage on every new empty tab created. Not anymore... Firefox worked well. I cannot understand the reason for this silly development. It is truly counterproductive. Is there anyway in the about:config that I can switch of this cat and mouse that the new version plays with my ability to get to my default search engine. Version 60.0.1 (64-bit) PRETTY_NAME="Debian GNU/Linux 9 (stretch)" NAME="Debian GNU/Linux" VERSION_ID="9" VERSION="9 (stretch)" ID=debian Linux version 4.9.0-6-amd64 (debian-kernel@lists.debian.org) (gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1) ) #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07)

Athraithe ag Tyler Downer ar

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 30.0 r0

Feidhmchlár

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Tuilleadh Eolais

WestEnd
  • Top 25 Contributor
60 réiteach 5379 freagra

What is the home page set at? Screenshot of the error?

What is the home page set at? Screenshot of the error?

Úinéir na ceiste

https://Startpage.com

1) If I open a totally new private window, then Startpage is loaded in the new window 2) If I open a new Tab, then all I get is as attached. The "Search The Web Field" does not work if you type something in there. I must fir press the Home Icon .. Only THEN do I get my search engine page.... really annoying and wastes literally hours of my time as I use a lot of Tabs.

https://Startpage.com 1) If I open a totally new private window, then Startpage is loaded in the new window 2) If I open a new Tab, then all I get is as attached. The "Search The Web Field" does not work if you type something in there. I must fir press the Home Icon .. Only THEN do I get my search engine page.... really annoying and wastes literally hours of my time as I use a lot of Tabs.
Corey 'linuxmodder' Sheldon 21 réiteach 223 freagra

What are the two extensions immediately to the right or Ublock Origin? not familiar with those.

Also do you have any antivirus or ISP based traffic/virus checking playing with FF perhaps?

What are the two extensions immediately to the right or Ublock Origin? not familiar with those. Also do you have any antivirus or ISP based traffic/virus checking playing with FF perhaps?

Úinéir na ceiste

I disabled all extensions, it still happens. I dont use any antivirus addos or software running.

As I mentioned when I start firefox the default tab goes correctly to the homepage. the problem arises when I create any new tab.

I read something that the developers did this to stop malicious sites creating new tabs. Well it breaks the usability of Firefox to such an extent that I will have to use a different browser if it is not sorted out or if there is no place in about:config to switch the bad idea off.

I disabled all extensions, it still happens. I dont use any antivirus addos or software running. As I mentioned when I start firefox the default tab goes correctly to the homepage. the problem arises when I create any new tab. I read something that the developers did this to stop malicious sites creating new tabs. Well it breaks the usability of Firefox to such an extent that I will have to use a different browser if it is not sorted out or if there is no place in about:config to switch the bad idea off.

Athraithe ag zimbodel ar

cor-el
  • Top 10 Contributor
  • Moderator
17467 réiteach 157849 freagra

The screenshot shows the new tab page with all content hidden.

Can you open the Settings page when you click the cogwheel button in the top right corner to set what to show on the new tab page?

The screenshot shows the new tab page with all content hidden. Can you open the Settings page when you click the cogwheel button in the top right corner to set what to show on the new tab page?

Úinéir na ceiste

Yes, but that is where the rubber hits the road and the developers messed up afaic.

The only options for new tab is blank page and Firefox default. No way to select home page, which in my case is my search engine. They seemingly now interjected their firefox homepage as the ONLY option. Looks Nefarious.

It is easy to see Open browser, then ^T, press the cogwheel, choose the drop-down for "New Tab". Only options are blank page and Firefox home.

The solution should be that "Home Page" should be the option and not "Firefox Home".

Yes, but that is where the rubber hits the road and the developers messed up afaic. The only options for new tab is blank page and Firefox default. No way to select home page, which in my case is my search engine. They seemingly now interjected their firefox homepage as the ONLY option. Looks Nefarious. It is easy to see Open browser, then ^T, press the cogwheel, choose the drop-down for "New Tab". Only options are blank page and Firefox home. The solution should be that "Home Page" should be the option and not "Firefox Home".

Athraithe ag zimbodel ar

Corey 'linuxmodder' Sheldon 21 réiteach 223 freagra

Your install of Firefox seems to be corrupt. See below my screenshot of New Windows/Tabs and the option for Custom URLs and that I have a few (the ones that you see in the above tabs in fact) as my new tabs|windows)

Your install of Firefox seems to be corrupt. See below my screenshot of New Windows/Tabs and the option for Custom URLs and that I have a few (the ones that you see in the above tabs in fact) as my new tabs|windows)

Úinéir na ceiste

I upgraded to the absolute latest. Problem still the same for me. I start without any addons. ^t for new tab doesnt show my homepage. Tried it on another machine still the same.

I upgraded to the absolute latest. Problem still the same for me. I start without any addons. ^t for new tab doesnt show my homepage. Tried it on another machine still the same.

Athraithe ag zimbodel ar

Shadow110 1072 réiteach 14836 freagra

Hi, please Copy/Paste about:preferences#home to the Address Bar and Enter.

Make sure only 1 URL in : Homepage and new windows

Remove the Check Mark from : Web Search

That should fix your issue.

Hi, please Copy/Paste about:preferences#home to the Address Bar and Enter. Make sure only 1 URL in : Homepage and new windows Remove the Check Mark from : Web Search That should fix your issue.

Úinéir na ceiste

Thanks I did that but then I just get a completely white blank page when opening a new tab. See attached for my preferences page with about:preferences#home

Firefox 61.0.1 (64-bit)

Thanks I did that but then I just get a completely white blank page when opening a new tab. See attached for my preferences page with about:preferences#home Firefox 61.0.1 (64-bit)

Athraithe ag zimbodel ar

Shadow110 1072 réiteach 14836 freagra

Hi, change the New Tabs from Blank to Default and that should do it.

Would suggest typing into the Address Bar startpage,com then use the full proper URL. Or use Home to get to proper URL. You can then Click : Use Current Page.

Hi, change the New Tabs from Blank to Default and that should do it. Would suggest typing into the Address Bar startpage,com then use the full proper URL. Or use Home to get to proper URL. You can then Click : Use Current Page.

Athraithe ag Shadow110 ar

Úinéir na ceiste

"Hi, change the New Tabs from Blank to Default and that should do it. "

Gee things must have been changing a lot with Firefox recently. Have been using it since inception. There is no "Gear" on the new tab as there used to be. Where would I set the Tabs to Default ? Its not in my preferences.

From the web "The browser.newtab.url pref is no longer supported in Firefox (41+), so it is no longer possible to set the new tab page via a pref. " 41 is way back, and I only got this problem with the last two newest versions, but that seems to be the reason as quoted?.

I seemingly have ti use an extension to have my homepage displaying in every new tab...which is seriously nefarious and questionable.

From web "You can look at this extension if you use the home page as the new tab page.

   New Tab Homepage: https://addons.mozilla.org/firefox/addon/new-tab-homepage/

" So this seems to be an issue intentionally programmed in with later firefox versions. Makes no sense.

"Hi, change the New Tabs from Blank to Default and that should do it. " Gee things must have been changing a lot with Firefox recently. Have been using it since inception. There is no "Gear" on the new tab as there used to be. Where would I set the Tabs to Default ? Its not in my preferences. From the web "The browser.newtab.url pref is no longer supported in Firefox (41+), so it is no longer possible to set the new tab page via a pref. " 41 is way back, and I only got this problem with the last two newest versions, but that seems to be the reason as quoted?. I seemingly have ti use an extension to have my homepage displaying in every new tab...which is seriously nefarious and questionable. From web "You can look at this extension if you use the home page as the new tab page. New Tab Homepage: https://addons.mozilla.org/firefox/addon/new-tab-homepage/ " So this seems to be an issue intentionally programmed in with later firefox versions. Makes no sense.

Athraithe ag zimbodel ar

Shadow110 1072 réiteach 14836 freagra

3 Bar Menu to Options --> Home , same page you had open before.

If you used to use the Menu Bar that was on top with File | Edit | View | History | Bookmarks | Tools | Help You can turn that back on as well as the Bookmarks toolbar if used that also from : Customize and mouse to the bottom Left to Toolbars and turn it on. or mouse to top of the browser and Right Click and turn it/them on.

No, using a Blank Page gives a Blank page as always. Before had to put in the address as about:blank to get a blank page.

3 Bar Menu to Options --> Home , same page you had open before. If you used to use the Menu Bar that was on top with File | Edit | View | History | Bookmarks | Tools | Help You can turn that back on as well as the Bookmarks toolbar if used that also from : Customize and mouse to the bottom Left to Toolbars and turn it on. or mouse to top of the browser and Right Click and turn it/them on. No, using a Blank Page gives a Blank page as always. Before had to put in the address as about:blank to get a blank page.

Úinéir na ceiste

you mean setting the "Homepage and new windows" to Firefox Default. ? That doesnt work (at least not on Linux) I then get the dreaded Firefox page and the search field is NOT the search engine I configured as default search engine. I deleted all the google stuff and yahoo and bing and only have startpage as default.

you mean setting the "Homepage and new windows" to Firefox Default. ? That doesnt work (at least not on Linux) I then get the dreaded Firefox page and the search field is NOT the search engine I configured as default search engine. I deleted all the google stuff and yahoo and bing and only have startpage as default.

Athraithe ag zimbodel ar

Shadow110 1072 réiteach 14836 freagra

Hi, you could have left those or not.

Please look at the picture you posted.

Where it says : Blank Page Change it to Firefox Home (Default)

You can get there as before : Copy/Paste about:preferences#home to the Address Bar and Enter. or 3 Bar Menu --> Options --> Home

if you turned on the Menu Bar, Tools --> Options --> Home

Hi, you could have left those or not. Please look at the picture you posted. ''Where it says'' : Blank Page Change it to Firefox Home (Default) You can get there as before : Copy/Paste about:preferences#home to the Address Bar and Enter. or 3 Bar Menu --> Options --> Home if you turned on the Menu Bar, Tools --> Options --> Home
Shadow110 1072 réiteach 14836 freagra

oops, both Blank and Firefox Default gives a Blank Page. when you open a New Tab.

Can Customize something using : https://addons.mozilla.org/firefox/addon/new-tab-override/

or Copy the URL https://www.startpage.com then put a Vertical Line in below Custom Url's ( this | ) then paste startpage in and can do it a bunch more times if want so that every new tab will open startpage or you can use something else.

oops, both Blank and Firefox Default gives a Blank Page. when you open a New Tab. Can Customize something using : https://addons.mozilla.org/firefox/addon/new-tab-override/ or Copy the URL https://www.startpage.com then put a Vertical Line in below Custom Url's ( this | ) then paste startpage in and can do it a bunch more times if want so that every new tab will open startpage or you can use something else.
Shadow110 1072 réiteach 14836 freagra

But, those will open when you start Firefox

But, those will open when you start Firefox
Shadow110 1072 réiteach 14836 freagra
https://support.mozilla.org/en-US/kb/how-to-set-the-home-page