X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Re-enable multi-E10S when not debugging ServiceWorkers?

Postáilte

When I started experimenting with ServiceWorkers in Firefox Developer Edition recently, I consented to disabling multi-E10S, but now it seems to be stuck on disabled even when I don't have about:debugging open and debugging a ServiceWorker. I've tried changing a few of the prefs in about:config as suggested for accessibility stuff that may disable it, but no luck. I'd love to get my performance back. :|

Bug for reference: https://bugzilla.mozilla.org/show_bug.cgi?id=1345932

When I started experimenting with ServiceWorkers in Firefox Developer Edition recently, I consented to disabling multi-E10S, but now it seems to be stuck on disabled even when I don't have about:debugging open and debugging a ServiceWorker. I've tried changing a few of the prefs in about:config as suggested for accessibility stuff that may disable it, but no luck. I'd love to get my performance back. :| Bug for reference: https://bugzilla.mozilla.org/show_bug.cgi?id=1345932

Tuilleadh mionsonraí faoin chóras

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Tuilleadh Eolais

Wesley Branton
  • Top 10 Contributor
644 réiteach 5239 freagra

Have you tried setting the browser.tabs.remote.autostart preference to true? There may also be some sub-preferences like browser.tabs.remote.autostart.2 that should also be set to true.

NOTE: You will need to restart Firefox in order for the changes to take effect.
Have you tried setting the <code>browser.tabs.remote.autostart</code> preference to <code>true</code>? There may also be some sub-preferences like <code>browser.tabs.remote.autostart.2</code> that should also be set to <code>true</code>. <blockquote>'''NOTE:''' You will need to restart Firefox in order for the changes to take effect.</blockquote>
cor-el
  • Top 10 Contributor
  • Moderator
17575 réiteach 158975 freagra

Only browser.tabs.remote. is used in current Firefox releases. If there are still other bold autostart prefs then you can reset them via the right-click context menu.

Maybe check this pref:

  • dom.ipc.processCount
Only browser.tabs.remote. is used in current Firefox releases. If there are still other bold autostart prefs then you can reset them via the right-click context menu. Maybe check this pref: *dom.ipc.processCount *Options/Preferences -> General -> Performance<br>remove checkmark: [ ] "Use recommended performance settings" *https://support.mozilla.org/en-US/kb/performance-settings

Athraithe ag cor-el ar