Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Home Content options missing after update to 61.0

  • 40 freagra
  • 5 leis an bhfadhb seo
  • 3218 views
  • Freagra is déanaí ó Mardak

more options

After updating to 61.0 (64 bit) my Home Content options disappeared, leaving a blank page when opening new tabs. From research, I see there should be a Firefox Home Content section in about:preferences#home . Mine has no Firefox Home Content options listed, just options for New Windows and Tabs (see screenshot). I have tried disabling all addons and closing/reopening Firefox but it made no difference.

How do I get my Home Content options back?

I would like to be able to have web search in the home page (not the address bar) and my top sites pinnable there, like it was before the 61.0 update, instead of the blank home page I am now seeing when opening new tabs.

Attached screenshots

Réiteach roghnaithe

so one other troubleshooting step that was recommended in the bug report is to clear the indexeddb storage of the affected profile:

  1. open about:support & go to your profile folder
  2. close all running instances of firefox
  3. in your profile rename the "storage" folder to "storage.bak"
  4. then try starting up firefox again

any outcome after that?

Read this answer in context 👍 2

All Replies (20)

more options

thanks, i've forwarded that bit to the developers in a bug report.

more options

Philipp, thanks for your continued help.

Further info: some extensions are now broken: noscript, kaspersky, and camelizer. These survived the update to 61.0, but the meddling with the profile prefs.js and sessionrestore seems to have broken them. I have a second profile, seldom used, where these extensions are still working, though the original issue is present in the second profile. I would like to get my broken main profile working fully again, as I use it extensively for work.

more options

Do you see this section in the Inspector?

more options

Hi cor-el, no, in the page inspector I don't see lines relating to homecontentsgroup or Firefox home content on the about:preferences#home page.

more options

in what way are your addons broken now & are you sure that's due to removing the prefs file and didn't happen immediately after the 61 update? (because the parts of the new tab page that are missing for you are also implemented as a system addon)

more options

The broken extensions have miraculously healed themselves. Camelizer came good after removing it and re-installing it last night (UK time). Kaspersky and noscript simply came back to life without explanation.

more options

perhaps it's possible to narrow down what change has introduced the problem with the new tab page ith the help of the mozregression tool from https://mozilla.github.io/mozregression/ (the page contains a quick video tutorial).

if you have a spare 30mins to debug this issue , you could download & install the gui version of the tool (pick "0.9.22" on github - the current one is broken for me), and go to file > run a new bisection. click next, then at the profile selection field point the tool towards the path of your current & broken profile (it's usually placed under c:\users\<your username>\appdata\roaming\mozilla\firefox\profiles) and then click next & finish. the tool will then start downloading development versions of the browser which you can rate as good or bad until it hopefully ends up with the exact build/changeset that has introduced this problem...

more options

Hi philip, thanks for your continued support. It will be a while before I get time to try that, probably around 9 hours from now, due to pressures of work today. I will try the mozregression tool later.

more options

sure, no worries! thanks for hanging in there & hopefully we will get to the bottom of this problem somehwo :-)

more options

Mozregression seems to have narrowed it down to a particular build. (see screenshot). I ran it with the extensions shown in the 2nd screenshot. Last known good build = 60. Last known bad date 26 June 2018.

Running the regression tool on a second less used profile that also has the issue showed all good before I'd worked out how to add the extensions. Kaspersky extension was found to be running on that test run without me adding it. Maybe that's a clue?

But .. I had already tried running my normal profile with all extensions disabled, and in safe mode, but the issue still manifested. Hopefully the experts now have enough info to solve the puzzle and fix the issue,

more options

thanks a bunch - immediately forwarding this finding to the devs looking into the matter.

more options

Could you open up a new tab and press ctrl+shift+k to open the web console (which I believe you've said is a blank pane). On the right side, there should be a "[ ] Persist Logs" to check. After activating the checkbox, type "about:home" in the address bar and press enter.

Does it show a message like "Navigated to jar:file:///Applications/Firefox%20Beta.app/Contents/Resources/browser/features/activity-stream@mozilla.org.xpi!/chrome/content/prerendered/en-US/activity-stream.html" and anything else?

And then still with the same tab with the web console open with Persist Logs still checked, type "resource://activity-stream/" and press enter.

Does that load anything and any messages appearing in the web console?

I've attached a screenshot of the checkbox highlighted and the resulting page and logs of what you might see.

more options

webconsole with persist logs enabled in home page (when refreshed) shows "Navigated to jar:file:///C:/Program%20Files/Mozilla%20Firefox/browser/features/activity-stream@mozilla.org.xpi!/chrome/content/prerendered/en-GB/activity-stream.html"

Although the home page is blank, there is an element named "onboarding-overlay-button" which is like a silvery firefox logo that opens a "let's get started" tour. Skipping this goes back to the blank page with onboarding button.

Web console for resource://activity-stream/ is shown in the attached screenshot

more options

Thanks for checking that. Looks like at least the activity-stream files are accessible as opposed to missing, so it seems like something is failing to initialize. (A note to devs, the page loaded is the empty prerendered page prerendered/en-GB/activity-stream.html not activity-stream-prerendered.html)

Could you try turning off a bunch of about:config prefs to see if some minimal functionality can load?

1) go to "about:config" 2) search for "activity-stream.feeds" 3) make a note of all the boolean type prefs with non-default values (i.e., which are already false) 4) change all the boolean type prefs to false (double click) *except* "aboutpreferences" and "prefs" (make sure those are true) 5) restart firefox 6) go to "about:preferences#home" 7) see if Firefox Home Content section appears

8) bonus: if step 7 does result in the preference section appearing, open up the browser console (ctrl+shift+j) then restore various prefs turned off in step 4 back to true (without restarting) and see if there's any messages that appear

Here's the full list of prefs to set to false in step 4:

browser.newtabpage.activity-stream.feeds.asrouterfeed browser.newtabpage.activity-stream.feeds.favicon browser.newtabpage.activity-stream.feeds.migration browser.newtabpage.activity-stream.feeds.newtabinit browser.newtabpage.activity-stream.feeds.places browser.newtabpage.activity-stream.feeds.section.highlights browser.newtabpage.activity-stream.feeds.section.topstories browser.newtabpage.activity-stream.feeds.sections browser.newtabpage.activity-stream.feeds.snippets browser.newtabpage.activity-stream.feeds.systemtick browser.newtabpage.activity-stream.feeds.telemetry browser.newtabpage.activity-stream.feeds.theme browser.newtabpage.activity-stream.feeds.topsites

Athraithe ag Mardak ar

more options

Hi Mardak, thank you for your assistance. I tried changing those prefs as instructed, and restarting Firefox. It made no difference to the issue. Home Content is still missing. I then changed the prefs back as they were. Again no difference to the issue.

more options

Réiteach Roghnaithe

so one other troubleshooting step that was recommended in the bug report is to clear the indexeddb storage of the affected profile:

  1. open about:support & go to your profile folder
  2. close all running instances of firefox
  3. in your profile rename the "storage" folder to "storage.bak"
  4. then try starting up firefox again

any outcome after that?

more options

Hi philipp, that seems to have fixed it. Thanks for your help, and to everyone else who chipped in.

I noticed the default folder in storage.bak contains quite a few banking and tax website named subfolders. Before I delete it, might I be deleting anything likely to break any functionality?

more options

mozillification said

I noticed the default folder in storage.bak contains quite a few banking and tax website named subfolders. Before I delete it, might I be deleting anything likely to break any functionality?

When websites ask Firefox to save content for use during or after your session, they go into the storage folder. The contents/data probably are as variable as websites themselves.

You could trying copying the folders for websites that sound important from the storage.bak folder into the new storage folder (into the same subfolders). I don't think they will affect the new tab page, as long as they aren't a folder for the new tab page.

more options

You can try to restore the full storage folder and only remove about+newtab folder to see if that works.

more options

If you could keep your broken-for-61.0 storage.bak, there should be an update for 61 soon if you could then verify that the new version fixes the problem with the original data.

  1. 1
  2. 2