Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

In firefox search, neither enter nor cursor click works

  • 9 bhfreagra
  • 1 leis an bhfadhb seo
  • 82 views
  • Freagra is déanaí ó dlshayne

more options

For at least two days, I have been unable to use the search bar in firefox. I am using the most current version of firefox. When I enter a term, neither hiting the enter (return) key, nor clicking in the green arrow with my cursor will initiate a search. There is no problem using the address bar. I have at least one suggestion enabled in privacy settings. I am using a MAC. Help! Thanks, Debbie

Réiteach roghnaithe

Hi Debbie, you are Welcome. As of version 60 some userChrome does not work any more or is subtle issues now like what you are experiencing , may get worse later.

Some of these am sure you have but useful and as said some do not work any more, might find the last url if not have what you can post in or see if there is new code :

  • Please select the answer that solves the problem*.

This will help other users with similar problems find the solution more easily.

Read this answer in context 👍 1

All Replies (9)

more options

Please see if this Search Site WE is the issue : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

more options

Thanks. Yes, in safe mode, no problem. I have the Adblock Plus and Search Site WE enabled. I had disabled them separately before writing my first problem, and it did not seem to effect the problem, but I had not restarted firefox. Do you think I should disable THEN try?

more options

Yes please, disable Site WE then restart.

more options

Hmmm...I did that, but no luck. I also disabled AdBlock Plus and restarted but still have the problem, even though safe mode was successful. What else could it be tht needs to be disabled?

more options

That blows the sails out. Ya, have you any userChrome that you have made ? ? If do not know prob do not but should know as 235 million ways to customize Firefox :

A theme ? I can not see hardware acceleration as the issue but stranger things have happened.

Check the above and will try to get some help on this, Thanks.

more options

Yeah, I do have a userchrome.css; it allows tabs on bottom. When I start in safe mode, the tabs go to the top, so it must be that. Damn! Now I have to decide which is more important, and search bar or the tabs! Thanks for helping me figure this out. If you have any further info on being able to have tabs on bottom AND the search bar active, let me know.

Debbie

more options

It could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

more options

Réiteach Roghnaithe

Hi Debbie, you are Welcome. As of version 60 some userChrome does not work any more or is subtle issues now like what you are experiencing , may get worse later.

Some of these am sure you have but useful and as said some do not work any more, might find the last url if not have what you can post in or see if there is new code :

  • Please select the answer that solves the problem*.

This will help other users with similar problems find the solution more easily.

more options

Thanks, Pkshadow. Followed this link https://github.com/Aris-t2/CustomCSSforFx/issues/1 and updated the userChrome.css file from 1.28 to 1.89.

Now I have tabs below AND a funtioning search bar.

You made my day! Debbie