Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to stop Firefox from auto refreshing every 10 seconds

  • 13 freagra
  • 1 leis an bhfadhb seo
  • 7338 views
  • Freagra is déanaí ó guigs

more options

I have read and applied all the fixes from previous responses to this problem and nothing works. Scrolling through Facebook is a nightmare with the page re-loading every 10 seconds, and creating a visual disturbance on screen. Please advise a permanent fix. Thanks

All Replies (13)

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

I had already done all of the above. Just cleared cache and cookies again to be sure. Facebook still refreshing madly. I am suspicious that it is only refreshing on the Facebook site, and may have something to do with the copious adverts on FB. Have already updated my ad blocker. Started in safe mode and disabled all add ons and it still refreshes.

more options

Try this; Once the website is loaded, on the address bar press the X to stop the reload. Do Not press the X to close the window.

more options

did that - was OK for a few minutes and then reverted to the blinking.

I installed Chrome and loaded Facebook - works perfectly. What's more, all videos work, no more green lines with sound only. Ran that fix about 10 times in Firefox and it didn't stick.

There are some major issues with Firefox. Is anyone looking at them?

more options

Noone else has reported the reload issue here. At least not this year. Have you checked with Facebook support?

more options

I can do that now. It's just strange that it's only happening with Firefox.

more options

Make sure accessibility.blockautorefresh is set to its default value (false) in about:config.

Then after removing cookies and cache once more, make sure to reload the page using Ctrl+F5.

If that doesn’t help, choose Forget about this site using the method described in Delete browsing, search and download history on Firefox or (for quick access or testing) by adding the "Forget" button using right-click > Customize… on the toolbar. Click the button on the page showing the issue. I *think* it should work for that page only, but you may lose more related to FB, so back up what you want to keep.

Also check your Security and Login Settings on FB for the number of logins - remove any inactive ones.

If nothing helps or even beforehand, check the network requests in either your firewall software if you have any, or open Firefox’s Network pane in the Web Developer menu (Ctrl+Shift+E) and see what is actually causing the refresh requests. The Browser Console (Ctrl+Shift+J) may be of help too.

more options

I already did the first thing. And did the second thing after doing the first thing. Googled this issue and found responses from years ago, and some responses from November 2017, and applied those fixes. So this problem has happened before, just not recently.

Did the network requests and had no idea what I was looking at.

Not willing to risk losing my FB history....

So thanks for your help, but I am now saying goodbye to Firefox. FB works perfectly well in Chrome, so I'm off over there. Shame, as I prefer Firefox.

thanks for your collective help.

cheers Gaynor

more options

If you found info on it you should have cited the info for us to have a understanding of what you found and what the issue was then.

Change the time as suggested here, even double the amount : https://www.servethehome.com/firefox-is-eating-your-ssd-here-is-how-to-fix-it/

more options

hey sorry, but in my OP I did say: I have read and applied all the fixes from previous responses to this problem and nothing works.

No-one has asked me what fixes I have applied. I spent three days trawling through Firefox and Facebook fixes before I came here. Again, sorry, new to asking for help.

I changed the time as suggested. I am closing Firefox now, will come and report back

more options

This seems to have fixed the problem. Thank you. I very much appreciate your help.

more options

Worked for about half an hour, then it all started up again.

more options

Hi Gaynor, I wanted to reach out to ask you about the add-ons that you have installed in your profile.

I think Flash Video Player for Facebook the add on might be contributing to the refreshing of your Facebook page.

Refreshing Firefox or removing Firefox from the cache usually will fix odd or unexpected webpage functionality, however since we don't want to do that, based on previous posts, would you be comfortable trying a new profile: Profile Manager - Create, remove, or switch Firefox profiles