Search Support

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

The animation in the banner does not work correctly

  • 10 bhfreagra
  • 2 leis an bhfadhb seo
  • 17 views
  • Freagra is déanaí ó James

more options

Hello, technical support specialists! I created a banner using HTML5 and javascript, but it does not display correctly ... In previous versions of Firefox, everything works fine, but in the latest version, the banner animation is only done when the cursor moves ... What is it related to and how can I solve this problem?

All Replies (10)

more options

Show the banner? And in FF57+ only way to make Browser changes are through user.chrome css scripts.

more options

Hi fjodor92, can you post a link to a page demonstrating this problem?

(I don't think a screenshot is going to help.)

more options

WestEnd сказал(а)

Show the banner? And in FF57+ only way to make Browser changes are through user.chrome css scripts.


Thanks for the answer. Link to example: http://resource.890m.com/banner/

Athraithe ag fjodor92 ar

more options

jscher2000 сказал(а)

Hi fjodor92, can you post a link to a page demonstrating this problem? (I don't think a screenshot is going to help.)


Thanks for the answer. Link to example: http://resource.890m.com/banner/

Athraithe ag fjodor92 ar

more options

Hmm, it seems as though the animation is happening but the elements are not visible for some reason. If you move the mouse every 5 seconds, you can see several elements already in place are made visible. (Or perhaps they are not in place, but the animation clock has run and you do not see the animation.)

It's very difficult to investigate because if you open the developer tools panel it works normally. I don't know how to figure this out.

more options

jscher2000 said

Hmm, it seems as though the animation is happening but the elements are not visible for some reason. If you move the mouse every 5 seconds, you can see several elements already in place are made visible. (Or perhaps they are not in place, but the animation clock has run and you do not see the animation.) It's very difficult to investigate because if you open the developer tools panel it works normally. I don't know how to figure this out.


The fact is that in previous versions of firefox everything worked fine ... In other browsers, too, everything is fine, but in firefox, for some reason this problem has appeared ... I do not know how to solve it.

more options

Banner works for me on Firefox Nightly.

more options

TyDraniu said

Banner works for me on Firefox Nightly.


Thanks for the response. But I'm still interested in Firefox version 58+

more options

fjodor92 said

TyDraniu said
Banner works for me on Firefox Nightly.

Thanks for the response. But I'm still interested in Firefox version 58+

Nightly is Firefox 60 in alpha testing, so that's promising for the future. Someone probably should check the beta of Firefox 59 to see whether it's fixed there.

Fixes are unlikely to come to Firefox 58 at this point unless a lot of sites are affected.

I note that zooming using Ctrl+ or Ctrl- every 5 seconds also shows the missing elements. Not sure if this provides anyone any further insight on what's going on with the invisible elements.

more options

WestEnd said

Show the banner? And in FF57+ only way to make Browser changes are through user.chrome css scripts.

it is userChrome.css and not user.chrome css

The userChrome.css is only for the browser interface and not what you see in the browser window as userContent.css can be used for this.

http://kb.mozillazine.org/userChrome.css http://kb.mozillazine.org/userContent.css