Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Feb 2018 Firefox is not working properly. It is slow to load, won't open pages, or items in Google search. I have downloaded lastest version 58.0.1, no change

  • 20 freagra
  • 131 leis an bhfadhb seo
  • 28497 views
  • Freagra is déanaí ó granmanh

more options

Hi, I'm hoping someone can advise me as to why the lastest version of Firefox is not working properly and if it can be fixed. I am not tech savvy, sorry. Since the last automatic update Firefox has been incredibly slow loading pages, won't load some at all and has problems showing pictures and video. Trying to type something into Google search is nearly impossible, it just doesn't respond when I click on something or if it does it takes ages to open in the new tab. I have tried to search online for an answer or solution but can't find anything that doesn't refer to problems with Firefox in late 2017. There have been new versions of Firefox since then which claim to have fixed any bugs. I have downloaded the lastest version which I think is 58.0.1 Firefox tells me I'm running the lastest version so what can I do to fix this?

Réiteach roghnaithe

I have uninstalled and reinstalled the newest version of Firefox again and it seems to be working a lot quicker now. Fingers crossed, It might be okay.

Read this answer in context 👍 3

All Replies (20)

more options
more options

Thanks for your responce. I restarted Firefox in safe mode and it opened some tabs quickly but then when I tried Google search it was slow again. When I searched for a Wikipedia page it just stalled for about a minute. The title of the page I had clicked on in Google did not even highlight. While I was waiting In the new tab it said Wikipedia Google search and and at the bottom of the screen it said connecting to www.gooogle.com.au. It took ages and then finally opened the Wiki page I had entered. I've never experienced this with Firefox before, I have the exact same add ons etc that I have been using for ages so I don't think it is those interfering with it.

more options

Réiteach Roghnaithe

I have uninstalled and reinstalled the newest version of Firefox again and it seems to be working a lot quicker now. Fingers crossed, It might be okay.

more options

Keep us posted.

more options

I too had serious problems with high CPU load when going to the Google Search website. I first thought it is due to the doodle. I removed the doodle using uBlock Origin, but the site kept my Firefox slowing down.

I then blocked access to gstatic.com using uBlock Origin (you have to enable the option "I am an advanced user". Then you can easily block specific parts of a web site right from the main menu of uBlock Origin).

For me, this solved the problem.

Athraithe ag Tilack ar

more options

I have win 8.1. 64. bit I updated to firefox 58.02 and immediately nothing was loading properly even my email went had the subjects but nothing inside. Anyways I decide to restore to a earlier time but that didn't work some problems. I ended up uninstalling firefox and deleting the firefox under c:\programs and also deleting mozilla fire fox under my user/data file. I tried older firefox a couple of times but they still didn't work right. I spent the whole day trying to get my machine to work properly and get my mail to work properly. I was just going to reinstall window from image backup for about a year ago. But I tried it one last attempt. This time I uninstall firefox and them deleted what I thought was mostly everything about firefox and did a ccleaner on the registry.

I installed firefox 49.0.2 and everything work great. Don't ask me why it just did. Only is... it wouldn't except the bookmark back file I had made from the 58.02. So... since I spent so much time on this I thought may as well uninstall and delete the 49.02 and reinstall 58.02 and get my bookmarks and use the backup to html format instead of .json file.

Well when I installed the 58.02 again... I don't know why but everything is working perfect. And 58.02 so far is everything they said it was. A lot more faster and smoother then the other firefox programs.

One thing I don't understand is that when I install the new 58.02 it had my old theme picture on the page. Hmm... I thought I had remove all the data from 58.02 before install the others. Where are they hiding all this information on my computer? Obviously they have place it in a different area but where? ??

I just notice my theme picture is not on today. Hmm... I hope doesn't mean trouble...

If anyone know where 58.02 hiding theme information and probably even than that. I would appreciate you telling me so I know for the future.

I hope this might help someone else. Try deleting 58.02 and installing 49.02 and the same thing back to 58.02. All I can figure is that when I installed 49.02 to install drivers or what ever was needed for 58.02. Good luck and may the fox be with you :)

more options

I too am having these issues.

more options

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.


https://support.kaspersky.com/viruses/utility

See also:

more options

It turned out I had to update the drivers for the Radeon Mobile video card in the older Dell laptop I was using (doing the update was an adventure in itself). Once the drivers were updated, and the machine rebooted, the Google Doodle played properly in Firefox with no slowdown.

more options

I've already scanned - nothing. It's not the Google Doodle, it's any page when first opened.

Athraithe ag PeterM ar

more options

silentsky126 said

It turned out I had to update the drivers for the Radeon Mobile video card

That was very good work. Well done.

more options

See https://support.mozilla.org/en-US/questions/1192233 if its older hardware and is a 64-bit machine running windows 10. Running Firefox 58 in a single thread appears faster than the older versions of firefox.

more options

Older machine & 64-bit but running Windows 7 SP1, 2 x Win 10 Pro and 1 x Win 10 Enterprise all updated in a multi-boot scenario, The latest iteration of Firefox which came in today, 59.0.1 seems to have done the trick as far as I can tell. No more blank pages thus far. Time will tell.

Athraithe ag PeterM ar

more options

I was also ready to change browsers, due to slow loading and freezes, and then tabs not loading after restart. Good News: I've just upgraded to 59.0.1 and so far, it's behaving great! Very fast loading, no problems after restarting. Hoping this experience continues. :-)

more options

One of my 3 machines still hung up after an hour with fire fox running 59.0.1. I still find running Firefox 59.0.1 is more stable than multiple threads

more options

One of my 3 machines still hung up after an hour with fire fox running 59.0.1. I still find running Firefox 59.0.1 in a single mode is more stable than multiple threads.

more options

I had a problem with Firefox starting VERY slowly (45+ seconds) with Google as my start page. I started it in Safe mode, tried it with a Blank page, disabled or removed the add-ons and extensions but it was still slow. I also tried removing Firefox and re-installing but it didn't help. I finally wound up removing it, deleting the profile and re-installing, and now it seems okay, even with Google. My questions is, what gets left around in the profile that might cause this problem ?

more options

Firefox starts slow , loads pages slow AND swirls alot and says Mozilla not responding. Been going on for a while Freezes , doesn't respond to comands. Last time I did reset and it removed everything and never got saved info back.

more options

granmanh Please go to the top of any support.mozilla.org web page and use the Ask A Question link; https://support.mozilla.org/en-US/questions/new Select the product for what the problem is (Firefox or whatever).

Now select the category for the problem. At the bottom is Other.

Describe the problem in brief (one line). Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.

more options

Slower than ever this morning.