Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox not saving PW or tabs on 58.0.1

  • 21 freagra
  • 10 leis an bhfadhb seo
  • 4 views
  • Freagra is déanaí ó Jahnke

more options

Running windows 2008R2 serving a published desktop across 4 servers for 65 end users.

Firefox auto updated to 58 then 58.0.1.

Since the 58 update, session restore tab comes up every single time the program is closed then opened. All stored PW's are wiped out. When I save new PW's, they stick for that session, however, on closing and opening Firefox they are lost again.

- I have deleted user profiles and started from scratch - no change in issues

This is replicatable on all my servers and my test server. i even uninstalled and installed from scratch.

Is this a remote desktop Services issue with Firefox? Am I the only one? My support queue is getting flooded. Thanks in advance for any and all feedback.

Matt

All Replies (20)

more options

I started to use process monitor to try and find out what is going on. The launching of Firefox seems to hang when these are being logged. Can anyone let me know what it means?

I have recreated the profile and no luck. Matt

more options

The cert9.db is an SQLite database that has replaced cert8.db and is used to store certificate data and doesn't have anything to do with the passwords. The same has happened with key4.db SQLite database that has replaced key3.db, so there might be a problem with this file.

Do you have a key4.db file and possibly cert9.db in the profile folder?

more options

Thanks so much for your reply.

I do in-fact have a Key4.db and cert9.db in my profile folder. Here is a pic of the profile.

more options

I see a logins.json.tmp file, but not the actual logins.json file, so it looks that at some time things went wrong with the passwords. I'm not seeing the older versions, so I assume that this is a new profile.

Do you have an "Old Firefox Data" folder on the desktop with recent profiles that have logins.json and key3.db?

You can try to rename logins.json.tmp to logins.json to see if that has effect Be sure to keep a copy of the original file.

more options

There is an OLD DATA folder however in the 3 profiles listed there are no key3.db files or logins.json files.

I did rename the login.json.tmp and removed the .tmp. It did work once showing a saved PW, but when I close the browser and go back the saved passwords are not there.

I should have a backup with the key3.db. I will get my cloud provider to restore the appdata folder from 2 weeks ago for the user and I can then access them.

Do you have any other suggestions while I wait for the restore?

more options

I actually had the files in another location. I added the key3.db. Like always, it worked on first opening. But when I close it, and try to open again, I am back to having the same issue. It is like Firefox is not closing properly or writing any info to the profile before it drops. Here is a screen shot of what I get when I reopen the browser.

more options

I see some people saying they have the same issue. Can you guys confirm if you are using Citrix as well, or RDS?

Trying to find some similarities THanks Matt

more options

Same problem here since Firefox 58 (23/01/2018). We use RDS / Windows 2012R2

more options

Could Firefox have a problem with folder redirection? But I didn't see a problem in ProcessExplorer.

more options

I have test accounts without folder redirection, they have the issue as well. Matt

more options

Now using Firefox 58.0.2 and still the same problem.

But I saw a strange behaviour: Firefox creates no json-files, only json.tmp. I removed the *.tmp-extension from every filename, started Firefox and my settings were loaded. As soon as I quit Firefox, it renames and saves the settings in the files extensions.json.tmp, sessionCheckpoints.json.tmp and xulstore.json.tmp. And again: When I remove the *.tmp-extensions from the three filenames, my settings were loaded else overwritten.

Can somebody explain me why this happens, please?

more options

Maybe the image is helpful. firefox.exe -jsconsole

Is there a possibility to enable debugMode in XULStore.js for line 113 (catch-block)? await OS.File.writeAtomic(this._storeFile.path, data, { tmpPath: this._storeFile.path + ".tmp" });

I believe the events on closing firefox are not logged. Is there a way to write these events in a file?

more options

Did you try to boot the computer in Safe Mode?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen or hold down the Shift key) to see if that has effect.

more options

Hi cor-el

thank you for your advise. I've testet it. Unfortunately, safe mode with network support does not solve the problem. Firefox still creates the json.tmp-files instead of json-files and the browser-console says, an other process is using the extensions.json-file.

more options

This is still going on for me, what a PAIN!!!! I do not even know if this is on Mozilla's radar.... that is the worst part

more options

I looked in ProcessExplorer for the file xulstore. You can see the result in the attached picture. Is there a possibility, that firefox can repeat the SetRenameInformationFile-API if it returns a SHARING VIOLATION-error?

more options

We have the same problem, after updating from version 56.0.1 to 58.0.2 all passwords are lost and the session restore tab comes up every time opened. I created a new profile, but at the second time you open firefox the problem ist still there. We are running at MS Server 2008 R2 Std. SP1 Remoteserver-Farm with folder redirection. Any ideas?

more options

Now Firefox 59.0.2 64-Bit - Problem still persists. Are there any solutions except using another browser? Thank you in advance.

more options

Still no solution. We are using Firefox 56.0.1 until any changes by Mozilla.

more options

Our profiles are saved on a NetApp-Filer. After a firmware-upgrade, the sharing-violation-error is gone and firefox saves and renames all files now.

We use currently 60.0.1.

Thank you all for your help and I hope this helps someone else.

  1. 1
  2. 2