Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to turn off javascript in 57.0.2

  • 13 freagra
  • 11 leis an bhfadhb seo
  • 1 view
  • Freagra is déanaí ó cor-el

more options

I need to turn javascript on or off at dozens of websites I visit every day. The new quantum version says my addon to do this won't work. I cannot update to any version of any browser that won't allow this.

What can I do?

All Replies (13)

more options

Java has to ask now to even run. Java is not used much unless go to a java game site. https://support.mozilla.org/en-US/kb/how-to-turn-off-java-applets

All Java on websites now are scripts that run. Not the main java Program. Scripts are read by the Browser. Some can be unsafe. Use the Extension NoScript if worried : https://addons.mozilla.org/en-US/firefox/addon/noscript/

You do know that ver 56 is unsupported, will get no updates or security patches. Update to 57+ or move to the Extended Release Version 52.5.0ESR

Please let us know if this solved your issue or if need further assistance

more options

Pkshadow, thank you for taking the time to answer my question. But I am not asking about Java; I'm asking about javascript. I think they are totally different.

Thank you.

more options

Add-ons like QuickJava that changed the internal setting apparently are not compatible with the new more limited powers allowed to extensions in Firefox 57.

You can flip the setting back and forth manually using the about:config preferences editor -- you can open this address and then bookmark it to more easily access the page:

about:config?filter=javascript.enabled


You also could consider using an extension which blocks scripts on a site-by-site basis. Each works in a different way, but both require frequent adjustments to make sites work normally:

There could be other new extensions I haven't heard of, but they would work differently from QuickJava.

more options
more options

jscher2000 and Scribe, thank you both for your ideas.

I'll start testing today to see what works best. Thanks!

more options

jscher2000 said

You can flip the setting back and forth manually using the about:config preferences editor -- you can open this address and then bookmark it to more easily access the page: about:config?filter=javascript.enabled

This technique works perfectly in Firefox 56. But in 57, I change the boolean value and try a page and it does not work. My example is go to arstechnica.com and click on one of the news items. Near the bottom of the page is a link to comments for that page. Click it. If javascript is on, the page reloads and comments are shown, but if off, then the page reloads and no comments can be seen. On 57, comments are never seen for me regardless of the state of the boolean value.

more options

Pkshadow said

Java has to ask now to even run. Java is not used much unless go to a java game site. https://support.mozilla.org/en-US/kb/how-to-turn-off-java-applets All Java on websites now are scripts that run. Not the main java Program. Scripts are read by the Browser.

http://kb.mozillazine.org/JavaScript_is_not_Java

If only JavaScript kept the original name of LiveScript.

more options

Pkshadow, thank you for your answer.

I am not having problems with Java. I am having problems with javascript. I know javascript is not java. I don't care about java. I only want to know how to enable or disable JAVASCRIPT. Thank you.

more options

tomozilla said

Pkshadow, thank you for your answer. I am not having problems with Java. I am having problems with javascript. I know javascript is not java. I don't care about java. I only want to know how to enable or disable JAVASCRIPT. Thank you.

Yes I got you. Was not need to post 2x;s for that. But thank you for 2x reminder. Notice time posted. Easy enough to confuse and not the 1st time I have missed the word Script.

You use NoScript at all https://addons.mozilla.org/en-US/firefox/addon/noscript/

more options

tomozilla said

But in 57, I change the boolean value and try a page and it does not work. My example is go to arstechnica.com and click on one of the news items. Near the bottom of the page is a link to comments for that page. Click it. If javascript is on, the page reloads and comments are shown, but if off, then the page reloads and no comments can be seen. On 57, comments are never seen for me regardless of the state of the boolean value.

Does it matter if you reload the page by hand (Ctrl+r) before trying to view comments?

If comments do not display even with JavaScript enabled, there probably is a different problem. The most common issues would be:

  • Firefox's Tracking Protection feature blocking third party content. This article describes how to use the "shield" icon to manage exceptions to this feature: What happened to Tracking Protection?.
  • An extension that blocks ads or scripts -- examples include Adblock Plus, uBlock Origin, uMatrix, and NoScript (often there's a toolbar button to adjust how a page displays).
  • An extension that blocks trackers -- examples include Blur, Disconnect, Ghostery, and Privacy Badger (often there's a toolbar button to adjust how a page displays).
more options

Bingo! Earlier I had tried an addon called noscript. It kept javascript from working. Removing that addon, I can now enable or disable javascript and everything works ok.

A few more tests and I will probably be ready to upgrade to 57 everywhere. Right now, I have it installed only on a test machine.

New paradigm and user foolishness on my part cancelled out.

Thanks jscher2000!

more options

In case it isn't clear, I'm using the bookmark for the about:config item that allows me to change enabled to disabled for javascript. Great tip!

more options