Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox update does not work with wordpress dashboard functionality

  • 13 freagra
  • 4 leis an bhfadhb seo
  • 2 views
  • Freagra is déanaí ó starhorsepax

more options

On the backend of various wordpress sites Firefox had done...SOMETHING. I can go into a page to edit but when I click a button the dashboard to navigate out...the page does not switch to the new page. I can click on widgets, see the correct url in the address bar for for the widgets edit area, but it doesn't load the page unless I manually click it hit the bar. This is very specific to Firefox since it updated to 56. I do not have this issue in Chrome. It is not on ONE site but several. I need this fixed or I will have to switch browsers, since working on Wordpress is literally my job.

All Replies (13)

more options

I had to give up Firefox a month or two ago. WordPress updates (plugins, themes, etc.) just don't show progress and completion in real-time. In Chrome and IE they do.

more options

I have a similar problem - I have found that when I try to save changes in the backend of wordpress, the button to save does not work. I have had to switch to Vivaldi

more options

As you know, Firefox changed last month. Many old extensions are permanently disabled, and other have updated (in some cases hurriedly) to the new API. During this time of transition, extension-related bugs may be more common.

If you're interested in troubleshooting further:

Confirm Redirects Are Allowed

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste access and pause while the list is filtered

(3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Try Firefox's Safe Mode

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of Shift.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Are you referring to Firefox 57? Because I have intentionally not updated to that. I see reports that it is even worse with Wordpress than 56. The first suggestion had no affect. I have not noticed any difference with Safe Mode being on (or for that matter with plugins deactivated, and some of those same plugins are on Chrome in any event.)

more options

Hi starhorsepax, I'm not having any issues with WordPress in Firefox 57 on my site (not on wordpress.com hosting), but since WP themes and WP plugins may vary, that doesn't necessary mean yours will work. What problems are you having now with Firefox 56 (or whatever you're using)?

more options

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
more options

cor-el said

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.
  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

This simply is not a valid answer (to refresh the page). Many WordPress pages, typically after updating a page or plugin, just display a blank page. This causes us to have to start over with xxx.com/wp-admin and hunt down the change we just made.

There is something being cached incorrectly or something else that is way above my head and/or paygrade.

I really appreciate any help that can be given on this matter. This is a deal-breaker for us.

more options

jscher2000 said

As you know, Firefox changed last month. Many old extensions are permanently disabled, and other have updated (in some cases hurriedly) to the new API. During this time of transition, extension-related bugs may be more common. If you're interested in troubleshooting further: Confirm Redirects Are Allowed (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste access and pause while the list is filtered (3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false Try Firefox's Safe Mode In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of Shift.) If Firefox is running: You can restart Firefox in Safe Mode using either:
  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled
and OK the restart. Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh). Any improvement?

Hi. I tried both of these options with no change. kennedyacres.com/wp-admin still shows a blank page. Multiple pages in WordPress, especially after page, post, or plugin updates just show a blank page after completion. You have to start over with just the /wp-admin to get back to where you were to ensure the changes took.

WordPress 4.9.4 running Bridge Child theme.

Can you please assist further? Thanks so much!

more options

Hi ToggeryBob, does it make any difference if you use HTTPS with the address instead of HTTP?

Also, when you get the blank page, if you right-click and use the reload arrow along the top line of the context menu, does that retrieve the expected content or does it remain blank?

more options

It remains blank when refreshing. In order to use https, the website has to have an SSL certificate, which many of mine do not.

Update from iPage web hosting provider. They indicate there is a buffer output issue. They have turned on output buffering - not sure what that is - if that's at the server level or what.

That seems to have temporarily corrected the issue. They've done this before and the issue continues eventually.

Thanks everyone for all your help.

more options

for the record I work on many client sites, self hosted not hosted by wordpress.com and this is where the problem is. I can't expect every host to alter things to suit firefox. I know all the sites don't have https (yet).

more options

I see you use Adblock Plus (ABP icon in the screenshot).

Did you check for issues caused by that extension and disable ABP in about:addons?

more options

thats always the first thing I check.