X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

folders on bookmarks toolbar do not open

Postáilte

My bookmarks toolbar contains a mix of links and folders with sets of related links within them. When I first start Firefox these links and the links within the folders are all available and work fine. However, later, the folders are still visible but will not open. This seems to be after I have minimised Firefox and later re-maximised it. To fix this I have to close Firefox and restart it. I am up to date with version 55.0.3 (32-bit) running under Win 7.1 (64 bit).

Some possibly related observations that might help are:

1 - whenever this happens the three-bar menu button has an exclamation mark over it, and it won't open either. I suspect that's a big clue.

2 - when Firefox asks for my master password the dialog is mostly off-screen top left and cannot be dragged onto screen. This is new behavior that seems to be coincident with the advent of the bookmarks problem.

Speculating, I wonder if the window that opens for a bookmarks folder is in fact opening but is being drawn somewhere off screen and thus only appears unresponsive. Could there be something overwriting the screen origin co-ordinates to create this appearance.

I have noted what appears to be a related question that addresses disappearance of folders but in my case the icons are still visible just not active. The bookmarks library clearly shows these bookmarks as present after I have restarted.

Any ideas / solutions will be much appreciated.

Thanks

Al

My bookmarks toolbar contains a mix of links and folders with sets of related links within them. When I first start Firefox these links and the links within the folders are all available and work fine. However, later, the folders are still visible but will not open. This seems to be after I have minimised Firefox and later re-maximised it. To fix this I have to close Firefox and restart it. I am up to date with version 55.0.3 (32-bit) running under Win 7.1 (64 bit). Some possibly related observations that might help are: 1 - whenever this happens the three-bar menu button has an exclamation mark over it, and it won't open either. I suspect that's a big clue. 2 - when Firefox asks for my master password the dialog is mostly off-screen top left and cannot be dragged onto screen. This is new behavior that seems to be coincident with the advent of the bookmarks problem. Speculating, I wonder if the window that opens for a bookmarks folder is in fact opening but is being drawn somewhere off screen and thus only appears unresponsive. Could there be something overwriting the screen origin co-ordinates to create this appearance. I have noted what appears to be a related question that addresses disappearance of folders but in my case the icons are still visible just not active. The bookmarks library clearly shows these bookmarks as present after I have restarted. Any ideas / solutions will be much appreciated. Thanks Al

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 26.0 r0

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

Tuilleadh Eolais

FredMcD
  • Top 10 Contributor
4306 réiteach 60427 freagra

Freagra Cabhrach

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox.

Open the Add-ons Manager. Locate the add-on and press the Options button. Then follow the directions.


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

'''[https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/ Places Maintenance]''' {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox. Open the Add-ons Manager. Locate the add-on and press the '''Options''' button. Then follow the directions. -------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17673 réiteach 159870 freagra

Freagra Cabhrach

Try to rename/remove the xulstore.json and localstore.rdf file in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Try to rename/remove the <b>xulstore.json and localstore.rdf</b> file in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Úinéir na ceiste

cor-el said

Try to rename/remove the xulstore.json and localstore.rdf file in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Thanks for the suggestion. I tried that but without success. I was able to rename xulstore.json to xulstore.old and Firefox creates a new one on startup. There was no localstore.rdf and as I understand it that file has been superseded by xulstore.json.

I restarted and as before had to allow some time to pass before the fault re-appeared. But reappear it did!

I now think the exclamation over the three-bar menu is a red herring. It appears to belong to an add-in called identity safe from Norton. I disabled that add-on and the two others as well. Fault re-appeared despite that.

I tried one other thing which was to drag and drop a link onto one of the folders that wouldn't open. To my surprise the link did in fact go into that folder which suggests that the code that handles drag-drop for that icon is active, alive and well. Of course I needed to restart Firefox to inspect the folder contents as the folder wouldn't open when clicked - and there was the item I had dragged.

Still scratching my head. Time seems to be a factor which annoys me. When I was a programmer way back in the 70's and 80's bugs that took time to materialise were always troubling because it made it harder to connect a causative event to the issue.

Thanks again for the constructive suggestion.

Al

''cor-el [[#answer-1007847|said]]'' <blockquote> Try to rename/remove the <b>xulstore.json and localstore.rdf</b> file in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox </blockquote> Thanks for the suggestion. I tried that but without success. I was able to rename xulstore.json to xulstore.old and Firefox creates a new one on startup. There was no localstore.rdf and as I understand it that file has been superseded by xulstore.json. I restarted and as before had to allow some time to pass before the fault re-appeared. But reappear it did! I now think the exclamation over the three-bar menu is a red herring. It appears to belong to an add-in called identity safe from Norton. I disabled that add-on and the two others as well. Fault re-appeared despite that. I tried one other thing which was to drag and drop a link onto one of the folders that wouldn't open. To my surprise the link did in fact go into that folder which suggests that the code that handles drag-drop for that icon is active, alive and well. Of course I needed to restart Firefox to inspect the folder contents as the folder wouldn't open when clicked - and there was the item I had dragged. Still scratching my head. Time seems to be a factor which annoys me. When I was a programmer way back in the 70's and 80's bugs that took time to materialise were always troubling because it made it harder to connect a causative event to the issue. Thanks again for the constructive suggestion. Al

Úinéir na ceiste

FredMcD said

Places Maintenance {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox. Open the Add-ons Manager. Locate the add-on and press the Options button. Then follow the directions.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Thanks for your input. I followed your suggestion and started in safe mode. The problem recurred. As before I had to allow some time to pass before the fault re-appeared. But reappear it did! I left my laptop for over 2 hours and came back to it. As soon as I maximised Firefox there was the problem.

I now think the exclamation over the three-bar menu is a red herring. It appears to belong to an add-in called identity safe from Norton. I disabled that add-on and the two others as well. Fault re-appeared despite that. However, the three bar menu does not respond and nor do other toolbar icons.

I tried one other thing which was to drag and drop a link onto one of the folders that wouldn't open. To my surprise the link did in fact go into that folder which suggests that the code that handles drag-drop for that icon is active, alive and well. Of course I needed to restart Firefox to inspect the folder contents as the folder wouldn't open when clicked - and there was the item I had dragged.

Still scratching my head. Time seems to be a factor which annoys me. When I was a programmer way back in the 70's and 80's bugs that took time to materialise were always troubling because it made it harder to connect a causative event to the issue.

Thanks again for the constructive suggestion.

''FredMcD [[#answer-1007816|said]]'' <blockquote> '''[https://addons.mozilla.org/en-US/firefox/addon/places-maintenance/ Places Maintenance]''' {web link} Allows to run Maintenance tasks on the database that drives Places, the bookmarks and history module behind Firefox. Open the Add-ons Manager. Locate the add-on and press the '''Options''' button. Then follow the directions. -------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? </blockquote> Thanks for your input. I followed your suggestion and started in safe mode. The problem recurred. As before I had to allow some time to pass before the fault re-appeared. But reappear it did! I left my laptop for over 2 hours and came back to it. As soon as I maximised Firefox there was the problem. I now think the exclamation over the three-bar menu is a red herring. It appears to belong to an add-in called identity safe from Norton. I disabled that add-on and the two others as well. Fault re-appeared despite that. However, the three bar menu does not respond and nor do other toolbar icons. I tried one other thing which was to drag and drop a link onto one of the folders that wouldn't open. To my surprise the link did in fact go into that folder which suggests that the code that handles drag-drop for that icon is active, alive and well. Of course I needed to restart Firefox to inspect the folder contents as the folder wouldn't open when clicked - and there was the item I had dragged. Still scratching my head. Time seems to be a factor which annoys me. When I was a programmer way back in the 70's and 80's bugs that took time to materialise were always troubling because it made it harder to connect a causative event to the issue. Thanks again for the constructive suggestion.
FredMcD
  • Top 10 Contributor
4306 réiteach 60427 freagra

Did you run Places Maintenance?

Did you run '''Places Maintenance?'''
jscher2000
  • Top 10 Contributor
8837 réiteach 72222 freagra

When this problem occurs:

(1) Does it help at all to turn the Bookmarks Toolbar off and on again? To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Show/Hide Toolbars (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

(2) If you access the folders of the Bookmarks Toolbar using one of these others methods, do they work there?

  • Bookmarks Menu button on the main toolbar (to the right of the star, looks a bit like a clipboard)
  • Bookmarks Menu on the classic menu bar (if you don't normally display the menu bar, you can tap the Alt key or F10 to display it temporarily)
  • Bookmarks Sidebar (you can open and close this using Ctrl+b or either of the Bookmarks Menus, or the View menu)

Do you use any add-ons or custom style rules that modify the toolbar area?

When this problem occurs: (1) Does it help at all to turn the Bookmarks Toolbar off and on again? To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there: * right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars<br><em>On Windows, tap the Alt key to activate the menu bar temporarily.</em> * in Customize mode > Show/Hide Toolbars (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list. (2) If you access the folders of the Bookmarks Toolbar using one of these others methods, do they work there? * Bookmarks Menu button on the main toolbar (to the right of the star, looks a bit like a clipboard) * Bookmarks Menu on the classic menu bar (if you don't normally display the menu bar, you can tap the Alt key or F10 to display it temporarily) * Bookmarks Sidebar (you can open and close this using Ctrl+b or either of the Bookmarks Menus, or the View menu) ---- Do you use any add-ons or custom style rules that modify the toolbar area?

Úinéir na ceiste

FredMcD said

Did you run Places Maintenance?

Oh yes! I certainly did.

I'll post a new reply and attach a screenshot highlighting the buttons that don't work and those that do when this happens. It's very odd - especially the way it only comes on after some time.

''FredMcD [[#answer-1008118|said]]'' <blockquote> Did you run '''Places Maintenance?''' </blockquote> Oh yes! I certainly did. I'll post a new reply and attach a screenshot highlighting the buttons that don't work and those that do when this happens. It's very odd - especially the way it only comes on after some time.

Úinéir na ceiste

So here is a screenshot identifying the things that are affected by this problem. I have added red highlighter over the folders and other tools that stop responding, and green highlighter over those that continue to function normally. I've tested each one carefully to be sure. (The image is rendered as a .gif as .jpg was just a tad too large for this forum.)

So here is a screenshot identifying the things that are affected by this problem. I have added red highlighter over the folders and other tools that stop responding, and green highlighter over those that continue to function normally. I've tested each one carefully to be sure. (The image is rendered as a .gif as .jpg was just a tad too large for this forum.)
FredMcD
  • Top 10 Contributor
4306 réiteach 60427 freagra

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Úinéir na ceiste

Tried the suggestion of Safe Mode. I left it for a while and came back to Firefox and the folders etc were still functioning.

Next I returned to normal mode and went to my power options to review them as I regularly close the lid to put it into hibernate. So I changed those to 'sleep'. And then I closed the lid and about ten minutes later re-opened it. After that 'sleep' the folders were no longer responding. Is this a function of something connected with 'sleep' / 'hibernate' modes. So next I tried forcing a hibernate through the power button. Restarting after a minute brought the system back awake and presto the folder buttons were no longer responsive. So it's starting to look like a problem connected to 'sleep' and / or 'hibernate'. What I don't understand is why.

Tried the suggestion of Safe Mode. I left it for a while and came back to Firefox and the folders etc were still functioning. Next I returned to normal mode and went to my power options to review them as I regularly close the lid to put it into hibernate. So I changed those to 'sleep'. And then I closed the lid and about ten minutes later re-opened it. After that 'sleep' the folders were no longer responding. Is this a function of something connected with 'sleep' / 'hibernate' modes. So next I tried forcing a hibernate through the power button. Restarting after a minute brought the system back awake and presto the folder buttons were no longer responsive. So it's starting to look like a problem connected to 'sleep' and / or 'hibernate'. What I don't understand is why.
FredMcD
  • Top 10 Contributor
4306 réiteach 60427 freagra

Many users have reported issues with the computer going to sleep. I don't know if there is a solution to it.

Many users have reported issues with the computer going to sleep. I don't know if there is a solution to it.
cor-el
  • Top 10 Contributor
  • Moderator
17673 réiteach 159870 freagra

You can try to disable hardware acceleration in Firefox.

  • Options/Preferences -> General: Performance
    remove checkmark: [ ] "Use recommended performance settings"
    "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>"Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Úinéir na ceiste

Thanks Cor-el, I have just implemented your suggestion and I'll monitor how it goes. Been comparatively quiet on my computer for a while for a raft of reasons but getting back to work on a couple of things now.

A couple of observations on this oddity however:

I have noticed that it also commonly affects website objects such as a list-box or combo-box of options which don't get drawn on the page when clicked. This re-inforced my theory that the object is attempting to get drawn somewhere but not with location co-ordinates within the screen limits. I reasoned that if that were the case I should be able to use the down arrow key to select the first item in the list and select it. So I tried that with one of my unresponsive bookmarks folders on the bookmarks toolbar and the relevant link opened as it would do if I had taken the same actions with the open folder visible. My conclusion is that something is getting snarled up in whatever Firefox uses to place these objects on screen.

Meantime I'll see how I get on with the suggestions you have kindly made.

All the best

Al

Thanks Cor-el, I have just implemented your suggestion and I'll monitor how it goes. Been comparatively quiet on my computer for a while for a raft of reasons but getting back to work on a couple of things now. A couple of observations on this oddity however: I have noticed that it also commonly affects website objects such as a list-box or combo-box of options which don't get drawn on the page when clicked. This re-inforced my theory that the object is attempting to get drawn somewhere but not with location co-ordinates within the screen limits. I reasoned that if that were the case I should be able to use the down arrow key to select the first item in the list and select it. So I tried that with one of my unresponsive bookmarks folders on the bookmarks toolbar and the relevant link opened as it would do if I had taken the same actions with the open folder visible. My conclusion is that something is getting snarled up in whatever Firefox uses to place these objects on screen. Meantime I'll see how I get on with the suggestions you have kindly made. All the best Al

Úinéir na ceiste

Oh dear! Unfortunately that hasn't worked. I'm getting the same behaviours despite unticking both ...

  • "Use recommended performance settings" and
  • "Use hardware acceleration when available"

in Options/Preferences -> General: Performance

I guess the next port of call is the graphics drivers and hardware acceleration issues you mentioned with the link:

https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Oh dear! Unfortunately that hasn't worked. I'm getting the same behaviours despite unticking both ... * "Use recommended performance settings" and * "Use hardware acceleration when available" in Options/Preferences -> General: Performance I guess the next port of call is the graphics drivers and hardware acceleration issues you mentioned with the link: https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Úinéir na ceiste

Hmmm ... I followed the link for updating drivers but having updated the screen driver before and got some unwanted problems I'm reluctant to update that driver now.

However, two other things I have changed are:

in about:config I set webgl.disabled to true

in options>general,performance I changed 'content process limit' to be 1 whereas it had been 4 previously.

Now waiting to see if any of that does any good.

Al

Hmmm ... I followed the link for updating drivers but having updated the screen driver before and got some unwanted problems I'm reluctant to update that driver now. However, two other things I have changed are: in about:config I set webgl.disabled to true in options>general,performance I changed 'content process limit' to be 1 whereas it had been 4 previously. Now waiting to see if any of that does any good. Al

Úinéir na ceiste

Oh drat! Still happening.

A good way to provoke the problem is to 'sleep' the computer and wake it up again - I do that just by closing / opening the lid. Why does 'sleep' provoke this problem? Other applications come back OK. Is there something unusual about the management of stack or heap in Firefox?

Al

Oh drat! Still happening. A good way to provoke the problem is to 'sleep' the computer and wake it up again - I do that just by closing / opening the lid. Why does 'sleep' provoke this problem? Other applications come back OK. Is there something unusual about the management of stack or heap in Firefox? Al

Úinéir na ceiste

Still investigating this issue. I went to watch a youtube video and maximise it to full screen. The full screen rendition appeared in top left of my screen (1366 x 768) and only the bottom right corner of the full screen rendition appeared at approx coordinates 170, 100 referred from top left of screen and overlaying the parent screen from which I had chosen full screen. Closing and re-opening Firefox got me back to a proper full screen rendition of the youtube video. Further evidence I think that the window origin data is being messed up.

Does this happen in Thunderbird? No it doesn't. Nor in any other application so I'm disinclined to think that it's an issue related to Windows itself or the video driver unless Firefox is using some obscure calls that other applications don't use.

I'm not sure where to go with this now. Anyone out there have any suggestions please?

Thanks

Al

Still investigating this issue. I went to watch a youtube video and maximise it to full screen. The full screen rendition appeared in top left of my screen (1366 x 768) and only the bottom right corner of the full screen rendition appeared at approx coordinates 170, 100 referred from top left of screen and overlaying the parent screen from which I had chosen full screen. Closing and re-opening Firefox got me back to a proper full screen rendition of the youtube video. Further evidence I think that the window origin data is being messed up. Does this happen in Thunderbird? No it doesn't. Nor in any other application so I'm disinclined to think that it's an issue related to Windows itself or the video driver unless Firefox is using some obscure calls that other applications don't use. I'm not sure where to go with this now. Anyone out there have any suggestions please? Thanks Al

Athraithe ag PeruvianBear ar

Úinéir na ceiste

So, another thing I have tried is switching from the 64 bit version of Firefox to the 32 bit version. That didn't help either unfortunately - same problem still recurs. I'll go back to the 64 bit version now.

Still hoping for inspiration from somewhere!

Al

So, another thing I have tried is switching from the 64 bit version of Firefox to the 32 bit version. That didn't help either unfortunately - same problem still recurs. I'll go back to the 64 bit version now. Still hoping for inspiration from somewhere! Al

Úinéir na ceiste

Just accepted the upgrade to Firefox Quantum (32 bit) which looks great. Unfortunately this hasn't solved my problem, so still looking for inspiration.

Just accepted the upgrade to Firefox Quantum (32 bit) which looks great. Unfortunately this hasn't solved my problem, so still looking for inspiration.

Úinéir na ceiste

I'm still plodding away on this. This afternoon I decided to upgrade my video driver to see if that made any difference. The hardware is ATI Mobility Radeon HD5470 and I've accepted a recommended (but optional) upgrade from ATI. I did this (despite misgivings based on previous issues with this driver upgrade) because the troubleshooting info produced by Firefox included this line in the error log (4 times): (#0): CP+[GFX1-]: Mismatched driver versions between the registry 8.771.1.0 and DLL(s) 8.15.10.2189, reported. After driver update there are no entries in the error log. Regrettably the problem is still the same as described above exhibiting all the same symptoms.

My own feelings about this problem are these: 1 - it's particular to Firefox 2 - a small number of others seem to have had similar problems 3 - putting the PC into sleep and re-awakening it seems like a good way to provoke the problem but it's not invariable 4 - given that Firefox has just undergone a radical rebuild the issue is either deep in some code that has been carried forward, OR in some of the settings that are in force on my system. If it was the former then I would be more inclined to think that more people would be experiencing this problem.

Is there anyone out there with enough knowledge to inspect the detail of the troubleshooting log and suggest further ideas? I'll post it next.

I'm still plodding away on this. This afternoon I decided to upgrade my video driver to see if that made any difference. The hardware is ATI Mobility Radeon HD5470 and I've accepted a recommended (but optional) upgrade from ATI. I did this (despite misgivings based on previous issues with this driver upgrade) because the troubleshooting info produced by Firefox included this line in the error log (4 times): (#0): CP+[GFX1-]: Mismatched driver versions between the registry 8.771.1.0 and DLL(s) 8.15.10.2189, reported. After driver update there are no entries in the error log. Regrettably the problem is still the same as described above exhibiting all the same symptoms. My own feelings about this problem are these: 1 - it's particular to Firefox 2 - a small number of others seem to have had similar problems 3 - putting the PC into sleep and re-awakening it seems like a good way to provoke the problem but it's not invariable 4 - given that Firefox has just undergone a radical rebuild the issue is either deep in some code that has been carried forward, OR in some of the settings that are in force on my system. If it was the former then I would be more inclined to think that more people would be experiencing this problem. Is there anyone out there with enough knowledge to inspect the detail of the troubleshooting log and suggest further ideas? I'll post it next.