Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

URL bar auto searching now enabled after being disabled.

  • 4 fhreagra
  • 4 leis an bhfadhb seo
  • 33 views
  • Freagra is déanaí ó FredMcD

more options

I have always had my address bar set to NOT auto search on words typed. it is my contention that the ADDRESS bar is where you type addresses / URLs and the SEARCH bar is where you type searches. I have seen to many problems from users ending up on a search page from suggested words typed in the address bar and then ending up on the wrong site. Users should either type nad address in the address bar or search in the search bar - the security implications of the mix of both those functions in the address bar is horrendous.

My bar was set to not search. the latest update has killed this nad i am getting auto suggests and sent to search engines instead of goin gto the typed URLs every time. If I've typed the URL incorrectly I should get a no site found message - not search engine pages.

How do I kill this auto search from url / address bar again?

Also the fact my location history was toasted in the process is bloody annoying. I'm having rebuild my history again.

All Replies (4)

more options

Type about:preferences#privacy<enter> in the address bar. At the bottom of the page, find Location Bar.


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD zei

Type about:preferences#privacy<enter> in the address bar. At the bottom of the page, find Location Bar.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

  1. 1: It in unclear what to do there. There is a setting 'Provide search suggestions' there, which you can disable. Is that the setting you mean? Then it doesn't work; Firefox keeps searching if you make a typo and have disabled that setting.
  2. 2: If you have to manually start in safe mode, in real life this will not work. People will forget, and rightfully so. And so, typo's in the address bar will still result in an unwanted search.

By _default_, if you make a typo, Firefox should _not_ perform a search but just give a 404. This is a security issue which should already have been tackled many years ago.

more options
more options

1) Type about:preferences#privacy<enter> in the address bar. Check/uncheck the selections

2) https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.