Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Is there a solution to the annoying main page refresh when you have sign-in input with history set to private?

  • 3 fhreagra
  • 8 leis an bhfadhb seo
  • 1232 views
  • Freagra is déanaí ó Seb7

more options

With Firefox (Windows 10) there is annoying screen refresh and loss of data as I log in to a couple financial web sites. Main page loads and after 3-4 seconds the screen refreshes. I usually remember to wait the 3-4 seconds but just curious what is going on. It only refreshes when there is a sign-in input on the main page and history set to 'never remember' or 'custom/private' setting. When I refresh firefox (back to remember history) there is no problem. It's like the web page is loaded from global storage and then because privacy is on another page is loaded from local storage or vice versa. I did check the source code on one site and it appears to be identical regardless of my privacy setting. I found two sites with main page sign in input that are unaffected and two that refresh.

With Firefox (Windows 10) there is annoying screen refresh and loss of data as I log in to a couple financial web sites. Main page loads and after 3-4 seconds the screen refreshes. I usually remember to wait the 3-4 seconds but just curious what is going on. It only refreshes when there is a sign-in input on the main page and history set to 'never remember' or 'custom/private' setting. When I refresh firefox (back to remember history) there is no problem. It's like the web page is loaded from global storage and then because privacy is on another page is loaded from local storage or vice versa. I did check the source code on one site and it appears to be identical regardless of my privacy setting. I found two sites with main page sign in input that are unaffected and two that refresh.

Réiteach roghnaithe

Try : Disable Auto Refresh in Firefox

  • STEP 1: Click the Open menu icon (three horizontal lines), then click Options, and then go to the Advanced tab.
  • STEP 2: Under General, check the box that says Warn me when web sites try to redirect or reload the page.

Also : https://addons.mozilla.org/en-US/firefox/addon/refresh-blocker/

Please let us know if this solved your issue or if need further assistance.

Read this answer in context 👍 1

All Replies (3)

more options

Réiteach Roghnaithe

Try : Disable Auto Refresh in Firefox

  • STEP 1: Click the Open menu icon (three horizontal lines), then click Options, and then go to the Advanced tab.
  • STEP 2: Under General, check the box that says Warn me when web sites try to redirect or reload the page.

Also : https://addons.mozilla.org/en-US/firefox/addon/refresh-blocker/

Please let us know if this solved your issue or if need further assistance.

Athraithe ag Shadow110 ar

more options

This solved the problem of the annoying page refresh, somehow.

more options

I have pages open a lot that automatically refresh and it is super annoying, as it slows down Firefox and causes a memory leak (it seems).

The GUI option above is no longer available as far as I can tell, so I had to change the option via about:config Once there, search for: accessibility.blockautorefresh And set it to True.

That add-on is 'Not compatible with Firefox Quantum' too.

Athraithe ag Seb7 ar