Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Disabling cookies or using exceptions does not stop Google cookies

  • 2 fhreagra
  • 29 leis an bhfadhb seo
  • 1473 views
  • Freagra is déanaí ó Louiscar

more options

I'm having somewhat of a nightmare right now. With exceptions I have blocked all cookies from google but whenever I visit google theres a cookie set.

Even if I click off the accept cookies it makes no difference somehow Firefox is just ignoring these settings yet I'm quite used to it popping up for sites asking to set a cookie of not.

I found I had to put every version of the url eg. https://google.co.uk - This took a long time - it's not sufficient seemingly to tell it that google.com and google.co.uk are domains which can't set a cookie. It's really annoying to have to keep doing this for every possibilty.

Now if I try to go to the settings in google it will tell me that cookies are off, However, get this!:

I go to google.co.uk and do a search . check the cookies and lo and behold there is a cookie for google.com (NID) there. This doesn't happen if I clear it and go to google.com only google.co.uk

Does anyone know what is going on here?

Réiteach roghnaithe

Thanks - no matter I sorted it. The cookie exceptions file had one entry in it that allowed google.co.uk to set a cookie. Why it set a cookie for google.com I don't know.

The problem here and with Firefox is that FF does not allow you to properly search the Cookie exceptions - it's really painful to have to go through tons of entries searching for things.

I ended up getting a sqlite editor to be able to go through the file and search for domains to change. Maddening when they provide a search for the cookies manager but not for the exceptions !

Read this answer in context 👍 4

All Replies (2)

more options

you might try "private browsing" or switching to 100% "bing"

more options

Réiteach Roghnaithe

Thanks - no matter I sorted it. The cookie exceptions file had one entry in it that allowed google.co.uk to set a cookie. Why it set a cookie for google.com I don't know.

The problem here and with Firefox is that FF does not allow you to properly search the Cookie exceptions - it's really painful to have to go through tons of entries searching for things.

I ended up getting a sqlite editor to be able to go through the file and search for domains to change. Maddening when they provide a search for the cookies manager but not for the exceptions !