Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Links from external programs don't open in Firefox 54. It just opens up a window with my home page.

  • 4 fhreagra
  • 18 leis an bhfadhb seo
  • 2356 views
  • Freagra is déanaí ó AnimatedFreak

more options

Hello I recently downloaded the latest version of Firefox 54 for Linux. Everything worked great however even after making it the default browser links from external programs such as Pidgin won't open in a new tab in firefox. Instead a new window will pop-up with my home page. I've tried solving it by uninstalling the other version of firefox I downloaded from the repository (Firefox 45)

I fear it might be because I didn't really install it, instead I just ran the file directly form the download labed just firefox. It seems to be working fine and there was no README file so I assumed that was the way it should've been done.

Réiteach roghnaithe

You can remove ~/.local/share/applications/firefox-esr.desktop

Set Firefox as default in Preferences from the official mozilla binary you're using now. This will create ~/.local/share/applications/userapp-firefox-*.desktop

Read the previous comment again.

Save and run the script but before that make sure the firefox folder you extracted from the tarball is in your ~/Downloads/ directory.

Read this answer in context 👍 3

All Replies (4)

more options

lets see if I understand

you downloaded official binary from firefox.com or the ftp

you don't have any other versions provided from your distribution

you set Firefox as default from Preferences

if all of the above is correct you should have userapp-firefox-*.desktop in ~/.local/share/applications/

the Exec= line should end with firefox %u

you may have to comment out NoDisplay=true or set it to false

you can also add Icon=firefox

you can use this script for the icons to work:

#!/bin/sh
## assuming firefox/ is extracted in ~/Downloads/
## to run do  sh this-script.sh
## Icons
  for i in 16x16 32x32 48x48; do
    mkdir -pv ~/.icons/hicolor/$i/apps/
    cp -v ~/Downloads/firefox/browser/chrome/icons/default/default${i/x*}.png \
             ~/.icons/hicolor/$i/apps/firefox.png
  done
## 128x128
  mkdir -pv ~/.icons/hicolor/128x128/apps/
  cp -v ~/Downloads/firefox/browser/icons/mozicon128.png \
        ~/.icons/hicolor/128x128/apps/firefox.png

also check your ~/.config/mimeapps.list

Athraithe ag bygabyga ar

more options

I did download firefox from there. I got a tarball that I am running it from.

I did have another version of firefox installed. It was label firefox-esr (I think it stands for extended support release however it's firefox45 in the application) however I uninstalled it but there might still be files referring to firefox-esr in my system and that is causing the problem. There is no file ~/.local/share/applications/ called userapp-firefox-*.desktop however there is one called firefox-esr.desktop. I tried editing it in the ways you instructed however I had no luck. The code in the file refers to firefox-esr and not just plain firefox. I wasn't sure what to look for in ~/.config/mimeapps.list and how to use the script.

more options

Réiteach Roghnaithe

You can remove ~/.local/share/applications/firefox-esr.desktop

Set Firefox as default in Preferences from the official mozilla binary you're using now. This will create ~/.local/share/applications/userapp-firefox-*.desktop

Read the previous comment again.

Save and run the script but before that make sure the firefox folder you extracted from the tarball is in your ~/Downloads/ directory.

Athraithe ag bygabyga ar

more options

So I think I was just confused. When I downloaded the tarbal there where two files that launched firefox. One being just called firefox and the other firefox-bin. I assumed that I should be using the firefox one and not the one labed -bin. However I guess when you referred to binary you meant the -bin one. Using that one and setting firefox and default it now works great to open links from external programs. I honestly feel a bit stupid.

I do think a readme file explaining it would have been a welcoming edition to the download.