Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

URL bar drop down length

  • 14 freagra
  • 5 leis an bhfadhb seo
  • 1309 views
  • Freagra is déanaí ó scottish2

more options

Hi

I have noticed that my URL (Address) Bar when I click the drop down arrow it is rather long at the moment. The history only fills up the top half and the bottom half is just blank.

Now I had this awhile back and someone here had suggested using STYLISH to control this and it worked great for a long time meaning the drop down was set to a more appropriate length about half a screen worth of drop down just enough to display the history, but yesterday or the day before I noticed I was back into the longer drop down again and when I checked STYLISH it now says nothing effected for the URL category.

So does anyone know if there is a work around to limit the length of the URL Address bar drop down history box as full page for me at least is very irritating

Thanks

Réiteach roghnaithe

scottish2 said

I think I have it close to where it was before just one issue I noticed when it drops down now it drops down on the left edge of the screen rather then right below the address box. Is there a way to align it under the address box as that is how it use to drop down

Sort of. It depends on whether you care about the bookmark star and switch to tab icons that sometimes appear at the far left:

/* Leave space for "type" icons */
#PopupAutoCompleteRichResult {
  max-width: 1000px !important;
  margin-left: -20px !important;
}
/* Don't care about "type" icons */
#PopupAutoCompleteRichResult {
  max-width: 1000px !important;
  margin-left: 0px !important;
}

With enough study, I probably could move the star somewhere else, maybe between the site title and URL or at the far right, but this layout is a little complicated to work with.

Read this answer in context 👍 0

All Replies (14)

more options

Firefox 48 switched from the narrower two-line display to a full-width one-line display. There is no built-in way to modify the width.

What was the Stylish rule/user style that stopped working? Do you want to try my user style: https://userstyles.org/styles/122394/url-bar-tweaks-remove-visit-search-limit-width

If you use "Style 1" then option (1A) lets you choose a narrower width for the bar.

more options

Well it is listed in the listing as

URLBAR Can affect anything.

And when I go in to edit it the code that was used is below and this worked for along time to rectify this issue

--------------
#PopupAutoCompleteRichResult .autocomplete-richlistbox {
  max-height: 60em !important;
  height: 60em !important;
}
--------------

Now it doesn't change anything and gives the above response saying nothing is effected.

Athraithe ag cor-el ar

more options

Okay, height is the vertical dimension. You need a rule to limit the width, which is the horizontal dimension. For example:

#PopupAutoCompleteRichResult {
  max-width: 1000px !important;
}
more options

Note: If there is a # in the first position the forum creates a numbered list. To avoid that, you can surround your rules with: <pre> and </pre> tags.

more options

I think I have it close to where it was before just one issue I noticed when it drops down now it drops down on the left edge of the screen rather then right below the address box. Is there a way to align it under the address box as that is how it use to drop down

more options

By the way this is the current code that your page spit out at me so this is what I am now working with Plus the line you gave me above

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/* 
    Hello! If you want to change your options, try updating from
    https://userstyles.org/styles/122394/url-bar-tweaks-remove-visit-search-limit-width
    Reload the page to get a green button, then select your drop-down style and
    other features and click Update with Stylish.
*/

/* Firefox 43+ "Visit..." or "Search..." bar in the drop-down */
#PopupAutoCompleteRichResult richlistitem[type*="heuristic"],
#PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="searchengine"],
#PopupAutoCompleteRichResult richlistitem[actiontype="visiturl"],
#PopupAutoCompleteRichResult richlistitem[actiontype="keyword"] {
  display:none !important;
}
/* Restore persistent display of drop-marker */
#urlbar:not(:hover) > .urlbar-textbox-container > .urlbar-history-dropmarker {
  opacity: 1 !important;
}
/* Increase height to avoid scroll bar */
#PopupAutoCompleteRichResult .autocomplete-richlistbox {
  height: auto !important;
  max-height: calc(60px * 10) !important;
  padding-top: 0 !important;
  padding-bottom: 0 !important;
}
/* Default drop-down width */
/* Default font sizes */

#PopupAutoCompleteRichResult {
  max-width: 1000px ;
}

Athraithe ag cor-el ar

more options

Sorry saw your second post after I posted let me try it that way instead

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/* 
    Hello! If you want to change your options, try updating from
    https://userstyles.org/styles/122394/url-bar-tweaks-remove-visit-search-limit-width
    Reload the page to get a green button, then select your drop-down style and
    other features and click Update with Stylish.
*/

/* Firefox 43+ "Visit..." or "Search..." bar in the drop-down */
#PopupAutoCompleteRichResult richlistitem[type*="heuristic"],
#PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="searchengine"],
#PopupAutoCompleteRichResult richlistitem[actiontype="visiturl"],
#PopupAutoCompleteRichResult richlistitem[actiontype="keyword"] {
  display:none !important;
}
/* Restore persistent display of drop-marker */
#urlbar:not(:hover) > .urlbar-textbox-container > .urlbar-history-dropmarker {
  opacity: 1 !important;
}
/* Increase height to avoid scroll bar */
#PopupAutoCompleteRichResult .autocomplete-richlistbox {
  height: auto !important;
  max-height: calc(60px * 10) !important;
  padding-top: 0 !important;
  padding-bottom: 0 !important;
}
/* Default drop-down width */
/* Default font sizes */

#PopupAutoCompleteRichResult {
  max-width: 1000px ;
}

more options

Réiteach Roghnaithe

scottish2 said

I think I have it close to where it was before just one issue I noticed when it drops down now it drops down on the left edge of the screen rather then right below the address box. Is there a way to align it under the address box as that is how it use to drop down

Sort of. It depends on whether you care about the bookmark star and switch to tab icons that sometimes appear at the far left:

/* Leave space for "type" icons */
#PopupAutoCompleteRichResult {
  max-width: 1000px !important;
  margin-left: -20px !important;
}
/* Don't care about "type" icons */
#PopupAutoCompleteRichResult {
  max-width: 1000px !important;
  margin-left: 0px !important;
}

With enough study, I probably could move the star somewhere else, maybe between the site title and URL or at the far right, but this layout is a little complicated to work with.

more options

That's perfect thanks!! :)

more options

Hi Again

Had an issue where my system reset so I lost some things including browser and settings like the ones we did above so I tried coming back here to get the needed stylish code again and I nearly have it where I want it except for some reason the height will not adjust for me. Here is the code I got from your page that you gave me way back at the start of the thread this is what it installed.

I tried to adjust the height elements but all it seemed to adjust when I did that was the height of each double lines box but it seems to refuse to adjust the over all height of the entire drop down box leaving me with a scroll bar. What needs to be adjust to length the drop down box as I tried changing 20 to 30 to even 3000 but the height always remained the same and left me with a scroll bar.




/* 
    Hello! If you want to change your options, try updating from
    https://userstyles.org/styles/122394/url-bar-tweaks-remove-visit-search-limit-width
    Reload the page to get a green button, then select your drop-down style and
    other features and click Update with Stylish.
*/
@-moz-document url(chrome://browser/content/browser.xul) {
  /* Remove " - Visit" or " - Search with" bar in the drop-down */
  #PopupAutoCompleteRichResult richlistitem:first-of-type[type*="heuristic"],
  #PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="searchengine"],
  #PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="visiturl"],
  #PopupAutoCompleteRichResult richlistitem:first-of-type[actiontype="keyword"] {
    display:none !important;
  }
  #PopupAutoCompleteRichResult .autocomplete-richlistbox {
    padding-top: 0 !important;
    padding-bottom: 0 !important;
  }

  /* Restore persistent display of drop-marker */
  #urlbar:not(:hover) > .urlbar-textbox-container > .urlbar-history-dropmarker {
    opacity: 1 !important;
  }
  
/* Set max-height for items visible without scrolling */
  #PopupAutoCompleteRichResult .autocomplete-richlistbox {
    height: auto !important;
    max-height: calc(45.5px * 20) !important;
  }
  
  /* Set drop-down width */
  #PopupAutoCompleteRichResult {
    width: 1117px !important;
    max-width: 1117px !important;
    margin-left: 0 !important;
  }
  
  #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-title-text, 
  #PopupAutoCompleteRichResult .autocomplete-richlistitem .ac-url-text {
    min-width: 810px !important;
  }
  /* Create sufficient height for two lines */
  #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) {
    position: relative !important;
    height: 45.5px !important;
  }
  /* Subtle border between results */
  #PopupAutoCompleteRichResult .autocomplete-richlistitem {
    border-bottom-color: #eee !important;
  }
  /* Position page title, set font-size */
  #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-title {
    position: absolute !important;
    left: 54px;
    top: 1px;
    font-size: 14px;
  }
  /* Position page url / action, set font-size */
  #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-url,
  #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-action {
    position: absolute !important;
    left: 54px;
    top: 20px;
    font-size: 12px;
  }

  /* Position bookmark tags */
  #PopupAutoCompleteRichResult .autocomplete-richlistitem .ac-tags {
    position: absolute !important;
    right: 0px;
    top: 3px;
  }
  /* Hide separator between title and URL */
  #PopupAutoCompleteRichResult .autocomplete-richlistitem:not([actiontype="searchengine"]) .ac-separator {
    display: none !important;
  }
  /* Position special icon (bookmark, switch-to-tab) */
  #PopupAutoCompleteRichResult .autocomplete-richlistitem .ac-type-icon {
    margin-left: 4px !important;
 }

  /* Use default text matching style */
}

Athraithe ag scottish2 ar

more options

This is the line for the number of items you want to be visible without a scrollbar (in yours, 20 results):

max-height: calc(45.5px * 20) !important;

Do you have Firefox set to show more than 20? Or is this rule being ignored?

FWIW, on mine, 20 would be too long with the two-line layout, so I'm using 15.

more options

Perhaps that is why it never changed. Where can I change the setting or code to allow more then 20 lines as right now I have a scroll bar which I hate so reason want the drop down panel to be long so no scroll bar

more options

How many results is Firefox generating? It should be up to this number:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.maxRichResults preference and enter the desired value...

more options

Thanks that got it. It was set to 10 so I changed it to 20 and now the scroll bars gone!

Thanks again!