Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

No longer able to view youtube videos in firefox since updating to v48.0

  • 14 freagra
  • 5 leis an bhfadhb seo
  • 111 views
  • Freagra is déanaí ó tommytiko

more options

Apparently since updating to v48.0 I am unable to view any youtube videos on Firefox. I can view them in Chrome. I have tried uninstalling and installing v43.0.1 by downloading it from the Mozilla website. That did not fix the problem. Nor did subsequently updating to v48.0. The only extensions I have enabled are Internet Download Manager and the Roboform toolbar - neither recently updated. There are lots of Ask to Activate plugins, but only 3 always activated: Open H264 Video Codec by Cisco, Primetime Content Decryption Module by Adobe Systems, and Shockwave Flash. The OS is XP pro SP3. Please don't bother to remind me it is out of date - I am working on moving to a new OS. It is just the video I cannot view - the rest of the youtube page is resolved. See image uploaded herewith.

Attached screenshots

All Replies (14)

more options

Ps I would add that I restored my system to a time before the update to Firefox v48.0, so it would seem to be something other than Firefox that is the problem, except that I can view the youtube videos in Chrome. And I can still view videos with Firefox on other sites, such as newspaper websites.

more options

Pps Could it be something to do with certificates in Firefox? I have been getting lots of messages to the effect that sites are not safe to visit. for example, I will upload here one that is to do with google, who you may think should be able to configure their site correctly.

more options

Try to use a cleaner software after uninstalling mozilla firefox. Be sure you deleted all files that belonged to firefox and install firefox. If it doesn't work, delete all useless plugins and addons.

more options

Thank you for replying.

What software do you have in mind as a "cleaner"? Is there a Firefox cleanup tool? The only guidance I found at Mozilla was to use the add/remove function and then manually delete the Firefox app data folder in my profile and the program files folder.

The matter is now, for the time being at least, academic from my point of view, since I have managed to restore the lost functionality by restoring my system drive from an earlier image (and carried out the reconfiguration needed to restore the development of my system since the image was made.

I think that the only installation that could have caused this problem was the installation, since the making of the ealier image, of the current Tor Browser, which uses an ealier version of Firefox (v45.3, apparently). Tor looks like a portable application, and used to be so, but cannot now merely be unzipped for some reason, and so to what extent it is installed is not clear to me. My guess is that either its installation or running this older version of Firefox in the Tor Browser package, perhaps when the current version of Firefox was also running, caused some sort of conflict.

I can easily reinstate the problem from a recent image on a spare drive if anyone is interested enough to want to investigate this odd occurrence. My interest in understanding it would be to avoid repeating whatever action of mine lead to the problem.

Does anyone have any ideas on whether and how the 2 versions may have conflicted, or on what may have caused this problem?

more options

You could use a cleaner like CCleaner.

more options

Did you sort out your problem ?

Are you generally able to play Flash Player content ? And what do you see using the Adobe test page ?

If you look at YouTube's test page what do you see

Are all the tick-boxes blue or are some red ?

more options

Thanks for your suggestions.

First, I had thought I had fixed the problem by restoring my system, as noted above, but in fact it returned. I seem to have fixed it now by removing Acronis True Image Home 2016 from my system. I had been trialling it, but it developed lots of problems, probably in relation to the sync function, although in the end I could not run Acronis atall, and windows services were crashing. Given the depth of the problem and also that the rescue disk can no longer be used to make an image of a system, apparently as a result of tightening the licensing limitations, I have decided to abandon Acronis altogether, and find another product. Since removing Acronis from my system, the Firefox problems seem largely to have gone away. I occasionally get a message that a webpage is incorrectly configured, instead of viewing the page itself, but whether that is the intended functioning of Firefox I am not able to determine.

Secondly, I followed your suggestions, and found that my adobe flash was up to date, but the youtube test page showed red for the h.264 and mse & h.264. Does this suggest that some reconfiguration of the browser would be desirable? I bit of googling found some videos purporting to show how to do the reconfiguration, but I could not really follow them, there being no explanation of what was going on, and also no explanation of whether the reconfiguration was desirable or not.

If you can offer any advice on how I should respond to the unsupported h.264 and mse & h.264, I should be most grateful.

Athraithe ag tommytiko ar

more options

tommytiko said

I followed your suggestions, and found that my adobe flash was up to date, but the youtube test page showed red for the h.264 and mse & h.264. Does this suggest that some reconfiguration of the browser would be desirable?

You're running Windows XP? Unless something has changed: without the Windows Media Foundation -- which Microsoft only released for Windows Vista and newer -- Firefox cannot decode MP4 video in the HTML5 player.

You can either:

(1) Try enabling WebM VP9, an advanced codec offered on Youtube, or (2) Use an add-on to force YouTube to serve you Flash video.

For #1:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webm and pause while the list is filtered

(3) Double-click the media.mediasource.webm.enabled preference to switch the value from false to true

To test, reload the video page on YouTube so the site redetects your browser's video features.

For #2:

If #1 doesn't work or overloads your CPU, you can try either of these:

more options

For the certificate errors, you might want to start a new thread since this one's getting a little long already. But, since I'm here...

When you get connection errors for many secure sites, the problem usually is one of the following:

(1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem.

(2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, Bullguard, ESET / nod32, and Kaspersky; AVG LinkScanner / SurfShield can cause this error on search sites.

If you have any of these products: This support article will walk you through checking for this problem: How to troubleshoot security error codes on secure websites.

(3) On Windows 10, Firefox not being set up to work with the parental control software Microsoft Family Safety.

To test by turning it off, see: http://windows.microsoft.com/en-us/wi.../turn-off-microsoft-family-settings)

(4) Malware on your system intercepting secure connections.


If #1-#3 don't seem relevant:

If you added exceptions for one or more sites

You could check the certificates for sites where you added an exception to see whether there is a pattern to the "Issued by" information which points to a specific culprit. Here's how:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. Then on the right side, click the Certificates mini-tab along the top. Then click the "View Certificates" button.

This should open the Certificate Manager. Click the "Servers" tab. Ignore the ones for "*" and check for any servers you remember adding an exception for. You can select some of those and click View to check the "Issued by" information.

Any pattern?

If you did not add exceptions

You could inspect a sample certificate to see whether that points to the culprit. Here's how:

Load my test page at: https://jeffersonscher.com/res/jstest.php

If you do not get a connection error, stop. The rest of this isn't applicable.

Expand the "Advanced" button on the error page and look for an Add Exception button.

Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, and the certificate exception dialog should open.

Click the View button. If View is not enabled, try the Get Certificate button first.

This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

more options

Thanks for your last 2 posts.

I tried toggling media.mediasource.webm.enabled to true, but the youtube test page still showed red for the h.264 and mse & h.264. I installed the flash addin, and the effect of turning the addin on was to produce a tick only on the "html video element" on the youtube test page, and black crosses against all of the other entries on that page. I note that the flash plug in does not skip as well as the native player.

I followed your advice on certificates, but it has not led me to identify any reason for the certificate error messages, which I continue to see from time to time, but thankfully not all of the time as before I uninstalled Acronis. I have authorised some exceptions, but strangely I cannot find the certificates therefor. I will follow it through carefully in light of your comments when I next have an "SEC_ERROR_UNKNOWN_ISSUER" report to deal with.

more options

Just to clarify:

I tried toggling media.mediasource.webm.enabled to true, but the youtube test page still showed red for the h.264 and mse & h.264.

That preference toggles the sixth box only.

more options

The non functioning boxes would be numbered 2 and 5 reading from left to right and then down the page. Box 6 was good without toggling media.mediasource.webm.enabled to true, Since it had made no difference to toggle to true, I toggled it back to false again.

So, I remain curious about the red (exclamation marks, I think) for the h.264 and mse & h.264. And am watching for certificate problems, but I am not troubled at present - basically it is all working, thank you. Famous last words.

Thanks for your help, but do let me know if you think further investigation could illuminate the problem.

more options

tommytiko said

So, I remain curious about the red (exclamation marks, I think) for the h.264 and mse & h.264.

I think I mentioned that it is normal for those boxes to be red in Firefox on Windows XP. Firefox cannot decode H.264 media on Windows XP, you need a plugin (e.g., Flash, VLC) and the site needs to call for a plugin-based player (Firefox doesn't try to substitute on its own).

more options

Many thanks for all your help with this.