Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Local .swf files won't open

  • 9 bhfreagra
  • 8 leis an bhfadhb seo
  • 15495 views
  • Freagra is déanaí ó MM6631764

more options

Using Firefox 47.0 on Windows 10

Hi,

I believe since last update, Firefox won't open .swf files stored on the local computer anymore. Whenever I try to open the local .swf file, Firefox asks me if I wish to open the file (see attached screenshot), then when I click Open with Firefox and the OK button it just re-prompts me again with the same question (same as screenshot). Because of this behaviour, I tried to manually set the .swf extension in the Firefox settings to always open .swf without asking, but that gives me flashback nightmares from 15 years ago when popup blockers weren't that common: Firefox loops and creates an infinites number of tabs while not actually opening the .swf file. I also tried to see if deleting the mimeTypes.rdf file from the Firefox profiles folder makes any difference but that doesn't help either.

I tried multiple .swf files but Firefox doesn't want to open them. The files itself are not corrupt and work fine in Edge browser. Also, I do have flash installed and flash sites and videos work perfectly fine.

How do I fix this? Thanks in advance.

edit: uploading screenshots to this site doesn't seem to work so I hosted my screenshot on imgur: http://i.imgur.com/rfXhJiL.png

Réiteach roghnaithe

Thanks for your reply's.

After a lot of troubleshooting, I found the culprit of this problem: Today I tried opening a .pdf file and the exact same issue occurred which made me think that there was something else going on. So I did a reinstall and everything worked fine again. After the reinstall, I did my normal post installation routine: install addons, settings tweaks, about:config tweaks.

After that, .swf and .pdf files stopped working again. Long story short, this problem is caused by the BetterPrivacy addon. Now I can imagine someone might think "duh you could have figured that out easily by starting Firefox in safe mode and/or uninstalling your addons in your troubleshooting process". The problem is, that I already did all that but once you have installed BetterPrivacy one time, it screws up your configuration somehow for good even when you already uninstalled the addon and/or tried Firefox safe mode.

Anyway, the fix for this is uninstall BetterPrivacy, close Firefox AND delete the Firefox prefs.js file. After that, you can restart Firefox and all is working again.

Read this answer in context 👍 4

All Replies (9)

more options

Try using Flie > Open File ... within Firefox and see how that works. Or try it this way from the keyboard when using Firefox { Ctrl + O } that's the letter O, not a zero number

more options

Thanks for your reply the-edmeister. Yeah I forgot to mention that in my startpost but I already tried that and it produces the exact same result which is the prompt for what to do with the file (as show in the screenshot)

more options

I would guess that the .swf file should be opened by a media player, not the FireFox browser.

When I click on my desktop icon of the file/folder I have various things in, and then single click on one of the lines/items (files? I'm from the PICK Multivalue computer world and I dislike what Bill Gates chose as names), an upper line might say 'play' or 'open' and a little arrow next to it.

That pull down menu might have a media player you should be using. Beyond this I can not help

more options

@cliffontheroad: This is not true. Until a couple of weeks ago, Firefox opened these files without a problem and I was doing that for years.

I believe a Firefox update I did a couple of weeks ago broke this (I could be wrong though).

more options

Bump.

Anyone else from Mozilla staff? This issue should be fairly easy to reproduce imo.

more options

I do not think STAFF is on the support forum, only people trying to help other people. And I'll guess that developement is also done for free by well meaning people. It's possible something has changed inside (on Win10?) or something you had on another machine or OS did not make it over or work the same on an OS upgrade.

You specified .swf files. I have the situation that swf files play, but if they are on one certain web site, they will NOT. I have to use (cough cough) IE to view them. I'm living with it. I really only wanted to state the first two sentences.

more options

Réiteach Roghnaithe

Thanks for your reply's.

After a lot of troubleshooting, I found the culprit of this problem: Today I tried opening a .pdf file and the exact same issue occurred which made me think that there was something else going on. So I did a reinstall and everything worked fine again. After the reinstall, I did my normal post installation routine: install addons, settings tweaks, about:config tweaks.

After that, .swf and .pdf files stopped working again. Long story short, this problem is caused by the BetterPrivacy addon. Now I can imagine someone might think "duh you could have figured that out easily by starting Firefox in safe mode and/or uninstalling your addons in your troubleshooting process". The problem is, that I already did all that but once you have installed BetterPrivacy one time, it screws up your configuration somehow for good even when you already uninstalled the addon and/or tried Firefox safe mode.

Anyway, the fix for this is uninstall BetterPrivacy, close Firefox AND delete the Firefox prefs.js file. After that, you can restart Firefox and all is working again.

more options

On behalf of anyone who gives a crap, thank you for posting your findings. (Sentence one is sincere and NOT a dig - just programmer / my humor style.)

One change in my system, which has nothing to do with who knows what, is somehow something got reset. Control panel, security, remote-settings; Allow remote Assistant ...

I swear I had unchecked that box months ago. I went looking because of the phony-update malware and my investigation of jquery.min.js where some code is used by many sites from the ajax.googleapis.com site dynamically, and some user wanting to change files on a machine and an answer was to lower the security settings.

Besides the current bug, I am seeing now why web sites are working as though I was using a 56K dialup modem.

But hurray. Others can hopefully gain from your efforts.

more options

edited away: sorry, totally misinterpreted your post. Yes sometimes you have to dig really deep to fix things :)

Athraithe ag MM6631764 ar