Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox won't open any PDF files

  • 6 fhreagra
  • 9 leis an bhfadhb seo
  • 12168 views
  • Freagra is déanaí ó John99

more options

Firefox has been refusing to open any PDF files with the built-in PDF-viewer from my computer for a few days now, and it's pretty annoying / frustrating. It only offers me to either open or save the file as..., and when I click on opening it, Firefox opens a new blank tab and offers the same thing again, and again, and on and on. :) With online PDF files there's no such problem.

Application settings are set to; Portable Document Format (PDF): Preview in Firefox - PDF file: always ask

I'm using the latest version of Firefox (47.0.1 currently) and Windows 8.1 Pro x64, and no other PDF-viewer application is installed.

Athraithe ag seggbizo ar

Réiteach roghnaithe

Sometimes the file that stores your Application preferences becomes corrupted and needs to be regenerated. Here are the steps for that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again. PDF should be set to "Preview in Firefox" by default. Does it work?

Read this answer in context 👍 3

All Replies (6)

more options

I think it's an issue with file association (.pdf) in your OS. Did you associate pdf to firefox.exe?

more options

Réiteach Roghnaithe

Sometimes the file that stores your Application preferences becomes corrupted and needs to be regenerated. Here are the steps for that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up again. PDF should be set to "Preview in Firefox" by default. Does it work?

more options

Oxylatium said

I think it's an issue with file association (.pdf) in your OS. Did you associate pdf to firefox.exe?

I didn't have to, it was automatically associated to Firefox.

more options

jscher2000 said

Sometimes the file that stores your Application preferences becomes corrupted and needs to be regenerated. Here are the steps for that: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old. Start Firefox back up again. PDF should be set to "Preview in Firefox" by default. Does it work?

It does work! Thank you very much, my friend! :)

more options

I have pretty much the opposite problem (similar to here: https://support.mozilla.org/en-US/questions/1012676). I do not want my pdfs to open firefox. Atm all my pdf files have been converted to Firefox HTML documents and i find that extremely inconvenient. Especially because this just happened without me ever giving permission for this. When i try to open them by simple double click, firefox opens a new window that is empty and asks me if i want to save the pdf i already have saved before. If i click save nothing happens and my pdf is still not open. I just want to delete the Firefox HTML document type from my computer so that all files revert back to pdf. Anyway I can do this easily?

more options

sjds_lkc It would appear to be a Windows issue. As in your question

  • How to disable pdf documents from getting opened and stored as Firefix HTML Documents /questions/1135178