Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

When I search from the address bar I get a "did you mean to go to" bar under address bar, how do I disable this?

  • 15 freagra
  • 8 leis an bhfadhb seo
  • 3641 views
  • Freagra is déanaí ó jscher2000

more options

When I search from the address bar I get a "did you mean to go to" bar under address bar, how do I disable this?

Réiteach roghnaithe

Rebooted my modem, my wireless printer, and antivirus couldn't connect at first but are fine now. Waiting on my cable tv to come back up but this solved the search problem I was having. Thank you very much. If you can think of anything else I should do let me know. Thanks again.

Read this answer in context 👍 0

All Replies (15)

more options

You can set browser.urlbar.unifiedcomplete to false to remove the Visit page suggestion from the location bar drop down list.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

This didn't solve my problem. I toggled it to false and still get the same message.

more options

Does this occur when you do a "one word" search (meaning no spaces)?

When you do a one word search (for example, intranet), Firefox does a DNS query in the background to see whether the query term is a valid server name. This is helpful when you are on an internal network where you have set up a company intranet server or family shared files server.

Unfortunately, some users have either an ISP or an add-on that manages to find a "server" (usually a useless search page) for any word, whether one really exists or not. In that case, the feature is more annoying than helpful.

If you have the second situation, we could suggest how to investigate for a bad add-on and how to opt-out of an ISP service or change your DNS servers. However, I don't remember any way to actually turn off this background check.

The most I know how to do is use a custom style rule to hide the notification:

/* Hide "Did you mean to go to" Infobar */ notification[value="keyword-uri-fixup"]{ display:none !important; }

more options

jscher2000 said

Does this occur when you do a "one word" search (meaning no spaces)? When you do a one word search (for example, intranet), Firefox does a DNS query in the background to see whether the query term is a valid server name. This is helpful when you are on an internal network where you have set up a company intranet server or family shared files server. Unfortunately, some users have either an ISP or an add-on that manages to find a "server" (usually a useless search page) for any word, whether one really exists or not. In that case, the feature is more annoying than helpful. If you have the second situation, we could suggest how to investigate for a bad add-on and how to opt-out of an ISP service or change your DNS servers. However, I don't remember any way to actually turn off this background check. The most I know how to do is use a custom style rule to hide the notification: /* Hide "Did you mean to go to" Infobar */ notification[value="keyword-uri-fixup"]{ display:none !important; }

This happens when I do a search from the address bar. I'm sorry but I don't understand how to use the code you put in the end of your message. Can you walk me through it?

I have been doing numerous things in about:config for security reasons like location off, etc. Thank you.

more options

Something is hijacking your DNS. Should we try to figure that out now, or just hide it under the bed for the time being?

You can apply custom style rule to Firefox's UI using either:

If both of these are new to you, one thing you will need is a namespace above the rule, so:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); /* Hide "Did you mean to go to" Infobar */ notification[value="keyword-uri-fixup"]{ display:none !important; }

If you choose Stylish, after installing the extension and restarting Firefox, there will be a new "S in a square" icon on the main toolbar. To create your rule, click the icon, then Write new style, then Blank style. When the editor opens in a tab, click in the main editing area (new the line number 1) and paste the above rule. Click Preview to apply it and try an address bar search that causes this problem in a new tab. Assuming it works, you can give the rule a name like Hide Did you mean to go Infobar and click the Save button. You're done.

more options

jscher2000 said

Something is hijacking your DNS. Should we try to figure that out now, or just hide it under the bed for the time being?

I JUST re-imaged my computer to a factory state and applied all updates I could find. How can I find what is hijacking my DNS?

I have AVG Free installed and Glary Utilities. Im on Windows 7. Thank you so much.

more options

You could temporarily revert to the "old way" of checking DNS first so that the culprit displays its results page. Often this will have a link in the upper right corner or at the bottom which identifies the source of the problem and/or allows you to "opt out." Once we figure that out, you can switch back to the "new way" of searching first.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste fix and pause while the list is filtered

(3) Double-click the browser.fixup.dns_first_for_single_words preference to switch it from false to true

Then try a one-word search and see what shows up.

Does that lead to any new information?

more options

I also have kidlogger installed to monitor other user account activity on Windows 7. Asides from an installed firefox theme the only add-on I have is Ad-Block Plus.

more options

I toggled what you told me and now I cant search from the address bar at all.

more options

What do you get when you try to search?

more options

Here's an image of a search

more options

On the right side, below the blue Filter Off button, follow the link for "Opt-out".

more options

Okay, I opt out of the ATT service now its telling me to restart my modem. Ill be back then search from the address bar again and see what I get.

more options

Réiteach Roghnaithe

Rebooted my modem, my wireless printer, and antivirus couldn't connect at first but are fine now. Waiting on my cable tv to come back up but this solved the search problem I was having. Thank you very much. If you can think of anything else I should do let me know. Thanks again.

more options

No, I think that's it. You can switch that preference back to its default value of false now, otherwise, you probably will notice a delay before Firefox submits the search to your default search engine.