Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox hogs too much of my CPU

  • 10 bhfreagra
  • 37 leis an bhfadhb seo
  • 20828 views
  • Freagra is déanaí ó FredMcD

more options

Hi- I have researched this extensively and have tried ALL the popular suggested tasks online to combat FF's high CPU usage. My FF system eats up 275k-350k of memory even while I have tried shutting down most processes and programs and FF add-ons and in Safemode, too. Also uninstalled it twice. Nothing works.

I'm using a: Windows 7 Pro, 64 bit Intel-Core i7-4770k Processor 3.50 GHZ 32 GB RAM. Machine is (clone) only 2 years old.

What are solutions that are not listed on your Help Pages here for this issue as all solutions seem to be more or less the same from everyone here?

Thank you, Steven

PS: I have no desire to use MS I.E. or other browsers. I'm otherwise happy and too rooted down with FF to switch.

Réiteach roghnaithe

All Replies (10)

more options

Separate Issue; Your System Details shows;

Installed Plug-ins

Shockwave Flash 22.0 r0 Shockwave Flash 20.0 r0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac

Then reinstall the latest version.

Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version: 22.0.0.192 Flash Player (Linux) Version 11.2.202.626

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download.

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download.

more options
more options

Thanks for your suggestions! I went through the Reinstall of Flash as a possible fix. Nothing. As I mentioned, I did the SafeMode attempt many times and turned off all unnecessary programs. Brought FF CPU use down to 150k from 325k. I did notice A big drop when I shutdown ITunes for some reason (which is also a big CPU hog). I may just have t live with this. It's not really affecting my systems' programs all that much. Probably overheating CPU though. Thank you!

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

You can check for issues caused by plugins.

  • set plugins to "Ask to Activate" on the about:addons page ("3-bar" menu button or Tools -> Add-ons -> Plugins)
  • plugins are not affected by Firefox Safe Mode
more options

Thanks, again, if you read my post I already did the SafeMode thing. It's a fallacy fix that many here have posted and many say that doesn't show anything or fix .problem is still there. Thanks anyway. FireFox has tons of posts for this issue and you'd think by now they'd fix it. Just going to have to live with it as I.E. is a junk and Anything Google (i.e., Chrome traces and follows you everywhere).

I think I just found the Culprit (or one at least) to the issue: a FF Extension (not Add-on) called AdBlock Plus. Disabled it and CPU went down by half but still at 150k usage. Thanks.

Athraithe ag StevenB ar

more options

I think I found the Culprit to the issue: a FF Extension (not Add-on) called AdBlock Plus. Disabled it and CPU went down by half but still at 150k. Thanks.

Athraithe ag StevenB ar

more options

Ask questions here; Forum; Adblock Plus Homepage {web link}

more options

Réiteach Roghnaithe

Thanks!

more options

I solved this problem by disconnecting from Firefox Sync.

I would guess that my sync info on Mozilla severs is corrupt, causing the high CPU usage.

So if you're suffering from this try disconnecting from Sync and see if that solves the issue.

UPDATE: I reconnected the Sync, but unchecked the Bookmarks sync item. Again, problem solved. So it's just the Sync of Bookmarks that caused the high CPU usage for me.

Athraithe ag RobertMW ar

more options

If you change your password on the sync, it will remove all stored data. Then you can start over.