Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Javascript pages load but won't interact [Arch linux x64]

  • 7 bhfreagra
  • 1 leis an bhfadhb seo
  • 33 views
  • Freagra is déanaí ó Nozarashizk

more options

Hello,

I have been facing a problem with certain pages but just with firefox, the specific sites work perfectly with chromium.

First of all I will share some of the pages I am facing this problem: -https://habitica.com/ ("Play Habitica", "Join for free", "Gamify your life today" won't work, I click them and nothing happens. Here is how the button's html looks like(<button id="play-btn" ng-click="playButtonClick()" class="btn btn-primary btn-lg gamifybutton">Join for free</button>) Not sure if that has anything to do with it.))

-I also faced this problem on some pages on pottermore but I can't seem to find them, pages look like the previous one and have similar buttons.

-https://europass.cedefop.europa.eu/editors/en/cv/compose , loads at the beginning and then gives me a blank page

I am pretty much a noob but I think all of the pages with unresponsive buttons,etc use javascript scripts, the things is that Javascript seems to be working properly everywhere else.

My plugins are:

-IcedTea-Web Plugin (using IcedTea-Web 1.6.2)

-Shockwave Flash 11.2.202.569

I am sorry if what I have provided isn't enough but I don't really know what else to include, if there is anything more I am required to send then I will do it as soon as possible. I really love firefox and I don't want to move to another browser just for 2-3 websites.

Thanks in advance -Michael

Athraithe ag cor-el ar

Réiteach roghnaithe

Creating a new profile solved my problem, after creating a new one and realizing that it worked, I moved ( cert8.db, content-prefs.sqlite, cookies.sqlite, formhistory.sqlite, key3db, logins.json, mimeTypes.rdf, permissions.sqlite, places.sqlite, webappsstore.sqlite and bookmarksbackups(folder)) to my new profile and everything still worked. After that I installed all my old add-ons one by one to see if any of them were causing the problem but it just works fine. I think it must have been one of my settings in about:config(if they don't reset when you start in safe mode)

I want to thank both of you for help and I hope this topic helps more people that might face the same problem.

Read this answer in context 👍 0

All Replies (7)

more options

I noticed your extension list includes NoScript. After loading the page, could you check the NoScript menu for additional sites the page may be using for some of its content? It's not always enough to unblock the main site, or perhaps I should say, the off-site content isn't always limited to ads and tracking. But you often need to experiment to unblock all the things that need unblocking. NoScript takes a lot of "training."

If you don't recall installing NoScript, it could have been part of a bundle. You can disable/remove unwanted extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

more options

Hello jscher2000 and thanks for your quick answer.

I forgot to mention that I have disabled almost all of Noscript's protection, it's just there for some basic stuff. Actually this is the first thing that came into my mind when I couldn't make the buttons to respond so I restarted firefox on safe mode(all add-ons disabled) but I still face the same problem.

Any other ideas?

more options

On Habitica, clicking Play for me generates an overlay in the page (first screen shot). I can't think of any built-in feature that could block that.

On Europass, there is a loading animation and then the page is replaced with new content (second screen shot). The script "fades in" the real content by increasing its opacity from completely transparent to completely opaque (third screen shot). I'm not aware of a setting that could block that.

Hmm... did Firefox work normally before a recent update, or has it always had this problem?

more options

This is what I get in Europass if it help you identify what my problem is. https://imgur.com/WTeGrYa

As far as I remember firefox was always like that(at least on linux). Does the safe mode also reset the about:config settings you have changed?

more options

Start Firefox in Safe Mode to check if one of the extensions (3-bar Menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: 3-bar Menu button/Tools > Add-ons > Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Well, hmm, what is blocking the script which fades in the content? You can double-check whether the content is there by clicking the <body... in the HTML area and then on the right side, unchecking the display and opacity properties so that Firefox uses the default values for those style properties.

About Safe Mode: it's just for testing and doesn't reset anything. If you see a choice between Safe Mode and Refresh, stick with Safe Mode for now.

more options

Réiteach Roghnaithe

Creating a new profile solved my problem, after creating a new one and realizing that it worked, I moved ( cert8.db, content-prefs.sqlite, cookies.sqlite, formhistory.sqlite, key3db, logins.json, mimeTypes.rdf, permissions.sqlite, places.sqlite, webappsstore.sqlite and bookmarksbackups(folder)) to my new profile and everything still worked. After that I installed all my old add-ons one by one to see if any of them were causing the problem but it just works fine. I think it must have been one of my settings in about:config(if they don't reset when you start in safe mode)

I want to thank both of you for help and I hope this topic helps more people that might face the same problem.