Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Hide Saved login...

  • 15 freagra
  • 4 leis an bhfadhb seo
  • 280 views
  • Freagra is déanaí ó cor-el

more options

I want to hide "Saved Login " ( Check Screenshot) due to security issue before I am using

userChrome.css

dialog#signonviewer button#togglePasswords { display:none }

but currently it is not working. Help Urgent

Attached screenshots

Athraithe ag Kapil India ar

Réiteach roghnaithe

You can hide the Saved Logins" button with code in userContent.css like I wrote above

@-moz-document url-prefix(about:preferences){
#showPasswords {display:none!important}
}

I don't know how to disable the F12 button.

Maybe keyconfig or another extension that deals with shortcut keys can be used to remap the F12 action to something unharmful.

Read this answer in context 👍 0

All Replies (15)

more options

If you use a master password then you can only view the passwords when you enter the master password when prompted.

The about:preferences page is a normal web page, so you need to place the code in userContent.css and not in userChrome.css.

Add code to the userContent.css file.


@-moz-document url-prefix(about:preferences){
#showPasswords {display:none!important}
}

Athraithe ag cor-el ar

more options

It doesn't seem to be easy to hide the "Show Passwords" button in that dialog. I got it to work after trying a lot of code with the CSS code in a separate file and an @import in userContent.css.

Put this code at the start of the userContent.css file (i.e. before any other CSS rules).

@import url("passwordmgr.css");

Put this code in passwordmgr.css

@namespace xul "http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul";

@-moz-document url(chrome://passwordmgr/content/passwordManager.xul){
#SignonViewerDialog #removeAllSignons {display:none!important}
#SignonViewerDialog #togglePasswords {display:none!important} 
}

Note that you can still right-click a line and use "Copy Password" (you need to enter the MP). The "Edit Password" entry is only enabled when the Password column is visible.

EDIT: To have this also work if you click "View Saved Passwords" in "Tools > Page Info > Security" you also need to add @import url("passwords.css"); at the start of userChrome.css (i.e. before @namespace). So both files can share the same passwordmgr.css file.

Athraithe ag cor-el ar

more options

If you want to hide the password information in "Tools > Page Info > Security" then you can add this code to userChrome.css:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

@-moz-document url(chrome://browser/content/pageinfo/pageInfo.xul){
 #security-privacy-passwords-row {display:none!important}
/* #security-view-password {display:none!important} /* this code only hides the button */
more options

where i can find passwordmgr.css ? Last solution is not working.

more options

You need to create that file yourself and copy/paste the above posted content in that file. You need to use a separate file in this case and import it because of namespace issues.

It is a two step process. The userContent.css and possibly userChrome.css file need to have the @import line at the start of the file to import the passwordmgr.css file.

@import url("passwordmgr.css");

The passwordmgr.css that you need to create needs to contain the actual code. I added code to hide the Remove All button as I don't think that you would normally would use this button and if you click it by accident then I don't know if you need to confirm this or that all passwords are gone.

@namespace xul "http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul";

@-moz-document url(chrome://passwordmgr/content/passwordManager.xul){
 #removeAllSignons {display:none!important}
 #togglePasswords {display:none!important} 
}
more options

Hi,

Thanks or your Reply

But I have 2 Quires 

1.Need to disable Saved password option on Browser also i am attaching screenshot .

2.Need to Disable F12 Option in Firefox.

more options

Réiteach Roghnaithe

You can hide the Saved Logins" button with code in userContent.css like I wrote above

@-moz-document url-prefix(about:preferences){
#showPasswords {display:none!important}
}

I don't know how to disable the F12 button.

Maybe keyconfig or another extension that deals with shortcut keys can be used to remap the F12 action to something unharmful.

more options

Thanks now it's working Thanks for your support

more options

Hello Sir

i am using latest Version of Firefox but it's creasing again again daily

here is screenshot

i am using Window 7 ultimate

more options

kapilindia1982 said

Hello Support i am using latest Version of Firefox but it's creasing again again daily here is screenshot i am using Window 7 ultimate
more options

Are you still using the same profile and do you still have the chrome folder with all the files in it?

What is the content of the userContent.css file?

You can use this button to go to the current Firefox profile folder:


See also:

more options

Here is the Content in userContent.css file

==
/*
 * Edit this file and copy it as userContent.css into your
 * profile-directory/chrome/
 */

/*
 * This file can be used to apply a style to all web pages you view
 * Rules without !important are overruled by author rules if the
 * author sets any.  Rules with !important overrule author rules.
 */

/*
 * example: turn off "blink" element blinking
 *
 * blink { text-decoration: none ! important; }
 *
 */
@-moz-document url-prefix(about:preferences){
#showPasswords {display:none}
}
/*
 * example: give all tables a 2px border
 *
 * table { border: 2px solid; }
 */

/*
 * example: turn off "marquee" element
 *
 * marquee { -moz-binding: none; }
 *
 */
 
/* 
 * For more examples see http://www.mozilla.org/unix/customizing.html
 */

Athraithe ag cor-el ar

more options

That file looks OK and works for me. I notice that it is a very old copy of the userContent-example.css file that came with Firefox versions (3.5/6) from a long time ago.

For easier reading it would be better to only put those few lines in the file.

@-moz-document url-prefix(about:preferences){
#showPasswords {display:none}
}

Make sure that you do not start Firefox in Safe Mode as that disables userChrome.css and userContent.css as well.

more options

i had put this content only userContent CSS file @-moz-document url-prefix(about:preferences){

  1. showPasswords {display:none}

}

but after that password option not disable

more options

Did you confirm in the properties via the right-click context menu of the file that the file is a CSS file?

Windows hides some file extensions by default. Among them .html and .ini and .js and .txt and you may only see a file name without file extension. You can check the file extension (type) in the properties of the file in Windows/File Explorer via the right-click context menu.

Athraithe ag cor-el ar