Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Trouble updating Firefox on an older Mac

  • 10 bhfreagra
  • 1 leis an bhfadhb seo
  • Freagra is déanaí ó cor-el

more options

Trying to get my mom's Mac back online. The Safari browser on her OSX 10.7 machine would not work with Google Mail last year after they made some upgrades. We installed Firefox and she could get her mail. It has been offline for several months due to unrelated issues. Today it accessed Gmail. I then downloaded Avast free edition for Mac. After that Firefox gives an invalid certificate error on every page -, even I have closed Avast but the problem seems to be in Mozilla. I thought it might need updating so I attempted to download the update. Still giving this error. I disabled the Avast add-on to Firefox. Still does it. The current version is 43.0.3 now, after restarting it. It was updated from ver 39.0.

At wit's end. Is this thing just too old?

All Replies (10)

more options

There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate.

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

more options

Thanks for the reply. After posting, I completely uninstalled Avast in case that was causing it, but no dice. I will check the clock, had no idea. And will look at your links.

more options

Date and time are spot on so it's not that. I looked at your linked 'untrusted' error message article, it said to delete the cert8.db file in the Profiles folder while ffox is closed. I can find the Profiles folder but no such file exists in there. In fact there are no .db files at all - even searching for the term '.db'. Still stumped. May be related to my old OS? In fact the instructions on how to find that file did not make sense, but I found the profiles folder using Finder. I'm a bit of a Mac rookie, my own machine is a pc, sorry to say.

more options

File browsers may hide some file extensions. Look for cert8 That should be it.

more options

I think I searched for cert8 as well, will try again. I really appreciate your help!

more options

No luck finding anything with cert8, cert, cer, or db. I did search the whole computer ('this mac'). I find the filing structure confusing - things aren't in neat folders it seems. Anyway I thought about trying to clean up the disk with something like ccleaner, I use it on my PC's. I don't see anything in the Launch Pad that looks like it would delete caches, temporary files, that kind of stuff. Maybe it would delete this file?

more options

I've called the big guys to help you. Good luck.

more options

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.


more options

Did some more reading and found Onyx, downloaded the version for OSX 10.7 from Titanium and ran it. Firefox is allowing some websites to load (obviously) but with others I still get that untrusted connection error. Including Gmail. Anyway I ran through the Disk Utility and then Onyx Cleaning and it didn't fix the problem.

Finally figured out there are hidden files including a whole Library. Found some Firefox folders in there but no cert8.db.

Seems some people recommend upgrading to whatever the latest OS is....10.9? 'Hell, I'd piss on a spark plug if I thought it would do any good.' - SAC General, War Games

more options

Note that there are files in two locations, the main profile and temporary cache files. The cert8.db file is in the main profile (Application Support/Firefox/)

  • ~/Library/Application Support/Firefox/Profiles/<profile>/
  • ~/Library/Caches/Firefox/Profiles/<profile>/