Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox and Display Crash?

  • 4 fhreagra
  • 1 leis an bhfadhb seo
  • 191 views
  • Freagra is déanaí ó QueenLily

more options

bp-fb2246bb-898a-4525-90ef-fd4ac2151005

I stepped away for a bit, and when I came back, both my monitors had stopped for a bit (not sleep or screensaver) and Firefox had crashed. Above is the crash report. I'm not sure what happened.

Réiteach roghnaithe

  • Firefox 41.0.1 Crash Report [@ UMDevice::CreateShaderResourceView(D3D10DDI_HDEVICE, D3D11DDIARG_CREATESHADERRESOURCEVIEW const*, D3D10DDI_HSHADERRESOURCEVIEW, D3D10DDI_HRTSHADERRESOURCEVIEW) ]

Try to disable D3D warp by setting layers.d3d11.disable-warp to true on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Read this answer in context 👍 0

All Replies (4)

more options

Réiteach Roghnaithe

  • Firefox 41.0.1 Crash Report [@ UMDevice::CreateShaderResourceView(D3D10DDI_HDEVICE, D3D11DDIARG_CREATESHADERRESOURCEVIEW const*, D3D10DDI_HSHADERRESOURCEVIEW, D3D10DDI_HRTSHADERRESOURCEVIEW) ]

Try to disable D3D warp by setting layers.d3d11.disable-warp to true on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

cor-el said

Try to disable D3D warp by setting layers.d3d11.disable-warp to true on the about:config page.

May I ask what disable-warp actually means?

more options

See Windows Advanced Rasterization Platform (WARP) Guide (Windows):

more options

Alright, I've turned off warp, set my theme to default and turned off hardware acceleration. My graphics card is fine and up to date. I'll probably end up having to wait a while and see if it occurs again.