Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How can you keep the url displayed in the address bar?

  • 9 bhfreagra
  • 2 leis an bhfadhb seo
  • 447 views
  • Freagra is déanaí ó c180tom

more options

With some (but not all) URL addresses picked from links briefly display but disappear when the page loads. (Example I was able to capture is: << http://www.eaa.org/en/eaa/eaa-news-and-aviation-news/2015-news/08-20-2015-tuskegee-next-teen-flies-with-young-eagles-chairman >> The address bar then goes back to "Search or enter address" (in italics.) There are several who suffer this problem (see forum "Urls are no longer visible in address bar") but no useful answers are given, only advice to "Start in safe mode", which doesn't fix the problem.

Réiteach roghnaithe

Hmm, I haven't seen that before.

Normally I would only expect that placeholder text to appear if the address bar was selected and you pressed Delete or Backspace to clear the URL of the page. In that case, you could press Esc to undelete it. The next time you see this, could you try pressing Esc?

There are a few different keys that can move the focus to the address bar instead of the page, in case this is a keyboard glitch. Those include:

  • F6
  • Ctrl+L
  • Alt+D

If you notice any pattern to it, that might help improve the diagnosis!

Read this answer in context 👍 3

All Replies (9)

more options

Réiteach Roghnaithe

Hmm, I haven't seen that before.

Normally I would only expect that placeholder text to appear if the address bar was selected and you pressed Delete or Backspace to clear the URL of the page. In that case, you could press Esc to undelete it. The next time you see this, could you try pressing Esc?

There are a few different keys that can move the focus to the address bar instead of the page, in case this is a keyboard glitch. Those include:

  • F6
  • Ctrl+L
  • Alt+D

If you notice any pattern to it, that might help improve the diagnosis!

more options

Pressing esc once showed the url briefly, but pressing it twice causes the url to persist. Thanks!

more options

That's a workaround for the moment, but you shouldn't have to do it often. Hopefully it will go away on its own but, if not, we could investigate whether there is an issue with Firefox thinking you have used one of those keyboard shortcuts.

more options

Note that you may not see the URL in the location/address bar during the connection phase (throbber on the Tab bar spinning backwards), but you should see the URL once Firefox has connected to the server and is waiting for content to arrive.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

It turns out that I just needed to hit the Esc key twice to make the URL persist.

more options

To jscher2000, thanks, I'll play with those shortcuts to see if it changes anything. Meanwhile, on the occasions I wish to see the URL, the Esc key will do.

more options

Are you using the default Firefox theme or a custom theme?

more options

cor-el, I'm just using default Firefox. Thanks for your help.