Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How do I get FF back to where a new tab opens muy home page. I HATE that dumb ass splash page with all kinds of thumbnails of pages.

  • 23 freagra
  • 4 leis an bhfadhb seo
  • Freagra is déanaí ó FredMcD

more options

In the 'new and improved' release of FF, when I open a new tab, instead of getting my home page which is which is the obvious starting point for ANY new tab, I get some god awful splash page with all kinds of thumbnails of various pages I have visited. This is 100% totally useless to me. How do I get this fixed so a new tab works the way it is supposed to? I tried installing a plug in but it disabled itself immediately and had an orange bar nest to it in the add on list.

I REALLY do appreciate the hard work that developers put into projects like this. I just wish they would quit fixing things that are not broken just to be able to say they have a 'new nd improved' release!

All Replies (20)

more options

New Tab Override (browser.newtab.url replacement)

With Firefox 41 (and higher), it's no longer possible to customize the page shown in a new tab via changing the preference browser.newtab.url in about.config. Because of the fact that hijackers abused the preference in the past, Mozilla decided to remove it (see bug 1118285). Fortunately, by removing it, Mozilla also introduced a new API to bring this functionality back to life as an add-on. This add-on allows the user to choose a certain page in a new tab.

more options

After installing the extension, you need to use its Options page to set the desired new tab page (instead of using about:config).

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Cmd+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, find New Tab Override and click its Options button. (See first screen shot attached.)

Depending on the height of your screen, you may need to scroll down to enter the desired address into the form. (See second screen shot attached.) For example:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Then tab or click away from that form field and you can test using Ctrl+t.


Once you have it set the way you want, you can close the Add-ons page (or use the Back button to return to the Extensions list from that Options page).

more options

Well that plug in worked about as well as the others I have tried. I installed it and set the new tab parameter. It worked until I closed my browser session and started it back up again. Now it is back to that God awful and totally useless page of tiles. It is totally absurd to NOT have the new tab default to yoru chosen home page. That is what a home page is all about!

more options

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

more options

Hi FrogSteaks, if you check the Add-ons page, is New Tab Override still enabled and configured as you left it? And it still isn't working?

more options

jscher2000 said

Hi FrogSteaks, if you check the Add-ons page, is New Tab Override still enabled and configured as you left it? And it still isn't working?

Yes to both questions. I have thought back to what all transpired between the add on working properly and then no longer working. It is POSSIBLE that FF experienced a crash and restart prior to (and perhaps causing) the add on to stop functioning.

I did a proper shut down of FF and then restarted it, the add on is functioning again. I will keep track of what all is going on to see if I can pinpoint any can identify any causal relationship. Hopefully this will help find any underling issue if such exists.

Thanks you much for your continued input.

more options

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it and select Submit.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

more options

Fred thank you! You taught me about a feature of FF that I did not know of.

As I only have five items listed in the about:crashed section I am sending a copy/paste fp the lot.

Submitted Crash Reports Report ID Date Submitted bp-d2090f11-f55d-4932-a198-fba732150921 9/21/2015 5:08 AM bp-463f8286-5348-49be-8523-ada282150913 9/12/2015 8:03 PM bp-cf2028c8-5770-4628-9ad0-91f332150814 8/13/2015 8:25 PM bp-5e3b0d27-637f-449d-9ef5-01bae2150805 8/4/2015 8:14 PM bp-d60f05f7-be51-42c2-b921-0d34b2150731 7/31/2015 6:38 PM

more options


Signature OOM OutOfMemory

That is odd, because you have plenty.

Total Virtual Memory 4294836224

Available Virtual Memory 1555513344

System Memory Use Percentage 59

Available Page File 11666710528

Available Physical Memory 3429949440

OOM Allocation Size 872415232 +++++++++++++++++++++++ Nvwgf2um.dll = NVIDIA Compatible D3D10 Driver = NVIDIA Corporation

IPSEng32.dll = Symantec Intrusion Detection


Nothing listed


nvoglv32.dll = NVIDIA Compatible OpenGL

Nvwgf2um.dll = NVIDIA Compatible D3D10 Driver = NVIDIA Corporation

msmpeg2vdec.dll = Microsoft DTV-DVD Video Decoder

IPSEng32.dll = Symantec Intrusion Detection

IPSLdr32.dll = Symantec Intrusion Detection

Perform a System File Check to fix corrupted system files Win 7, 8, 10, Vista:

See if there are updates for your graphics drivers

more options

The most recent crash report dies when it can't get this memory allocation:

OOM Allocation Size : 872415232

If I'm reading that correctly, it's 872 megabytes, which seems unusually large to me. Maybe a problem decoding a video?

more options

You can try to clear the thumbnail cache.

You can find this folder in the parent location of the disk cache. See the about:cache page for the location of the disk cache.

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

OK I am in over my head a bot here.

1) I do have 8GB RAM. 2) The add on stopped working again. Nothing of notice occurred proximate to this happening. 3) I have no idea what the thumbnail cache is.

more options

FredMcD said

Perform a System File Check to fix corrupted system files Win 7, 8, 10, Vista:

Ran this and got the message that errors weer found that could not be resolved. It referenced the file C:\Windows\Logs\CBS\CBS.log. I looked the file and I cannot figure out a thing! :(

more options

Hi FrogSteaks, there is a lot going on in this thread...

I don't know what's going wrong with the extension. Did it stop working after an exit/startup or in the middle of a session?

Regarding out-of-memory issues, Firefox is a 32-bit application and can't keep that much data in RAM; I think the limit is closer to 3GB. Still, I find that Firefox gets sluggish and unstable above a "commit size" of 2.5 GB -- that's a separate column you can view on the Processes tab in the Windows 7 Task Manager, which usually is larger than the private working set or other memory use columns. Hopefully you don't get those kinds of crashes often, but the next time Firefox crashes, you could pop open the Task Manager (Ctrl+Shift+Esc) and take a look at Firefox's memory footprint.

Athraithe ag jscher2000 ar

more options

It has stopped and resumed working several times during the day. Most often when I have multiple (but not necessarily several) tabs open.

I have run the built in Windows memory test apps and returned no errors, One of my other applications (PhotoShop CS2) had been acting up with really slow load times and system lock up until the load is complete. I was attempting to eliminate a bad stick of RAM as the culprit. That situation has not presented itself in a while though. Not sure what was going on with that one.

more options

FrogSteaks said

It has stopped and resumed working several times during the day. Most often when I have multiple (but not necessarily several) tabs open.

Well, that's annoying. I don't know how best to go about debugging that, whether it's a problem with the add-on or with Firefox itself.

more options

OK I created a new profile and have set up (almost) all of the FF setting the way I want them. Lets see if this corrects the issue. I will report any progress.

more options

I have additional inf on this issue. First when FF crashes it is not technically a FF crash in that it does not shut down and give me the FF crash reporter warning. It simply locks up 100% and I have to manually close the app. This just happened and when FF was locked, in task manager there was some sort of FF Plug In Manager that was using about 65% of my CPU. Any ideas or thoughts?

more options

Hi FrogSteaks, since Flash is the most commonly used plugin, problems with plugin-container.exe usually are rooted in a Flash issue. I haven't dug into the current Flash 41 + Flash issues to understand what's going on, but I can suggest the following general practices to minimize potential issues with Flash during your troubleshooting:

(1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

(2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

Thank you so much for the rapid response to this and staying with me on it. I just disabled the protected mode and will see what that does. I'll post a follow up in a few days.

  1. 1
  2. 2