X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

"This Connection is Untrusted" error window for youtu.be

Postáilte

And many other URLs, including Mozilla (!), so Firefox 40+ does not work (and I had the same problem on 38.0.1). I am using Yosemite (OS 10.10.5) on a MacBook Pro, but I had this same problem using OS 10.7.5. This is the message I get:

"This Connection is Untrusted

"You have asked Firefox to connect securely to youtu.be, but we can't confirm that your connection is secure.

"Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

"What Should I Do?

"If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

"This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate."

"Technical Details: "youtu.be uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)"

Sometimes I get a page, such as the mozilla.org page, which has no graphics and is in bare outline form.

And many other URLs, including Mozilla (!), so Firefox 40+ does not work (and I had the same problem on 38.0.1). I am using Yosemite (OS 10.10.5) on a MacBook Pro, but I had this same problem using OS 10.7.5. This is the message I get: "This Connection is Untrusted "You have asked Firefox to connect securely to youtu.be, but we can't confirm that your connection is secure. "Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. "What Should I Do? "If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue. "This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate." "Technical Details: "youtu.be uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)" Sometimes I get a page, such as the mozilla.org page, which has no graphics and is in bare outline form.
Sakshi Rajput 1 réiteach 16 freagra

I guess you are trying to open youtube the extension to that is youtube.com As per i can see there is no certificate issue from our side and if you type youtu.be its automatically redirected to youtube.com


I guess this is what your problem is. If not let us know so that we can further help you

Than you

I guess you are trying to open youtube the extension to that is youtube.com As per i can see there is no certificate issue from our side and if you type youtu.be its automatically redirected to youtube.com I guess this is what your problem is. If not let us know so that we can further help you Than you
jscher2000
  • Top 10 Contributor
8775 réiteach 71736 freagra

When you get this for pretty much all secure sites, the problem usually is one of the following:

(1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem.

(2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, ESET, Kaspersky; AVG has a Search Shield feature which can cause this error on search sites.

(3) Malware on your system intercepting secure connections.

So... which is it?

If you have any of those specific security products, that would be the first thing to check. We might be able to assist with specific next steps based on what you have if you tell us.

Alternately, you can examine the certificate to which Firefox is objecting to see whether the issuer information points to the culprit. Take my test page for example:

https://jeffersonscher.com/res/jstest.php

You should see an "I understand the risk" heading in the page. If you expand that section, you should find an Add Exception button. You don't need to complete the process of adding an exception (I suggest not adding one until we know this isn't a malware issue) but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, then View. If View is not enabled, try the Get Certificate button first. Then in the Certificate Viewer, look at the "Issued by" section. What do you find there, and/or under Certificate Hierarchy? I have attached a screen shot for comparison.

When you get this for pretty much all secure sites, the problem usually is one of the following: (1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem. (2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, ESET, Kaspersky; AVG has a Search Shield feature which can cause this error on search sites. (3) Malware on your system intercepting secure connections. So... which is it? If you have any of those specific security products, that would be the first thing to check. We might be able to assist with specific next steps based on what you have if you tell us. Alternately, you can examine the certificate to which Firefox is objecting to see whether the issuer information points to the culprit. Take my test page for example: https://jeffersonscher.com/res/jstest.php You should see an "I understand the risk" heading in the page. If you expand that section, you should find an Add Exception button. You don't need to complete the process of adding an exception (I suggest not adding one until we know this isn't a malware issue) but you can use the dialog to view the information that makes Firefox suspicious. Click Add Exception, then View. If View is not enabled, try the Get Certificate button first. Then in the Certificate Viewer, look at the "Issued by" section. What do you find there, and/or under Certificate Hierarchy? I have attached a screen shot for comparison.

Úinéir na ceiste

I do have Avast, and I disabled it in Extensions to see if that made any difference, It did not. Is there some other thing I need to do, short of removing Avast from my computer?

I do have Avast, and I disabled it in Extensions to see if that made any difference, It did not. Is there some other thing I need to do, short of removing Avast from my computer?
jscher2000
  • Top 10 Contributor
8775 réiteach 71736 freagra

The Avast Web Shield intercepts your browsing to scan for threats. Intercepting secure connections requires presenting "fake" certificates to Firefox, and unless Avast's installer set up Firefox to trust those certificates, you get errors on all secure sites.

You could try switching off scanning HTTPS connections to see whether this is the cause in your case. These steps are for the Windows version, but probably similar on Mac:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok

If that resolves the issue, you can still use the feature if you can get Firefox to trust Avast's signing certificate. You could try reinstalling Avast to trigger that process.

The Avast Web Shield intercepts your browsing to scan for threats. Intercepting secure connections requires presenting "fake" certificates to Firefox, and unless Avast's installer set up Firefox to trust those certificates, you get errors on all secure sites. You could try switching off scanning HTTPS connections to see whether this is the cause in your case. These steps are for the Windows version, but probably similar on Mac: #Open the Avast dashboard on the affected system. #Select Settings from the left sidebar menu. #Switch to Active Protection. #Click on Customize next to Web Shield. #Uncheck the "Enable HTTPS Scanning" option and click ok If that resolves the issue, you can still use the feature if you can get Firefox to trust Avast's signing certificate. You could try reinstalling Avast to trigger that process.

Úinéir na ceiste

Hmmm. I opened the Avast dashboard and there is no "Settings" on the left sidebar menu. The choices are: Status, Scan Reports, Virus Chest, Shields, Account, Tools, and Preferences. I looked through them all and could not find anything labeled "Active Protection."

Hmmm. I opened the Avast dashboard and there is no "Settings" on the left sidebar menu. The choices are: Status, Scan Reports, Virus Chest, Shields, Account, Tools, and Preferences. I looked through them all and could not find anything labeled "Active Protection."
jscher2000
  • Top 10 Contributor
8775 réiteach 71736 freagra

I found a quick start guide! https://files.avast.com/files/documentation/avast-free-antivirus-for-mac-quick-start-guide-en.pdf

It doesn't have complete information on this, but there are clues. Try clicking the "wrench" button toward the upper right of the main dialog. The under Web Shield, the Advanced button.

Does that give access to the HTTPS scan setting?

I found a quick start guide! https://files.avast.com/files/documentation/avast-free-antivirus-for-mac-quick-start-guide-en.pdf It doesn't have complete information on this, but there are clues. Try clicking the "wrench" button toward the upper right of the main dialog. The under Web Shield, the Advanced button. Does that give access to the HTTPS scan setting?

Úinéir na ceiste

Thank you for researching this! I really haven't a clue as to what any of this means, so it really helps to have someone on one's side. OK, I looked at the PDF, and that must be a previous iteration of Avast dashboard, because the one on my computer doesn't look like that, and has different tabs. I wish they'd date these things...

Anyway, there is a "gear" icon at the bottom of my version, labeled "Preferences." When I click on that, I get the following options on the left side: Shields, Popups, Updates, Miscellaneous. If I click on Shield, I get the following: File System Shield with a Disable button and Settings button; Mail Shield Disable button and Settings; and Web Shield with the Disable and Settings buttons. If I click on the Web Shield "Settings" (Oh man, I wish I could just sent you screen shots of this stuff...), I see the following, all with checked boxes: "Report potentially unwanted programs (PUP)"; "Enable IPv6"; "Scan secured connections," with a subhead "Scan secured connections from browsers only." And then there is a list of Excluded servers ("Servers specified in the list below will never be scanned by the Web Shield")

Does any of this make sense?

Thank you for researching this! I really haven't a clue as to what any of this means, so it really helps to have someone on one's side. OK, I looked at the PDF, and that must be a previous iteration of Avast dashboard, because the one on my computer doesn't look like that, and has different tabs. I wish they'd date these things... Anyway, there is a "gear" icon at the bottom of my version, labeled "Preferences." When I click on that, I get the following options on the left side: Shields, Popups, Updates, Miscellaneous. If I click on Shield, I get the following: File System Shield with a Disable button and Settings button; Mail Shield Disable button and Settings; and Web Shield with the Disable and Settings buttons. If I click on the Web Shield "Settings" (Oh man, I wish I could just sent you screen shots of this stuff...), I see the following, all with checked boxes: "Report potentially unwanted programs (PUP)"; "Enable IPv6"; "Scan secured connections," with a subhead "Scan secured connections from browsers only." And then there is a list of Excluded servers ("Servers specified in the list below will never be scanned by the Web Shield") Does any of this make sense?

Úinéir na ceiste

There isn't anything that looks like what is on that PDF. Grrrrrr.

There isn't anything that looks like what is on that PDF. Grrrrrr.

Úinéir na ceiste

If Avast is the problem, maybe I should just uninstall it.

If Avast is the problem, maybe I should just uninstall it.
jscher2000
  • Top 10 Contributor
8775 réiteach 71736 freagra

Freagra Cabhrach

Try turning off "Scan secure connections". That's the same as HTTPS.

Try turning off "Scan secure connections". That's the same as HTTPS.

Úinéir na ceiste

YES!!!! That did it! I reloaded a youtube video, and voilá, there it is. And Mozilla page is complete with graphics. Thank you!

So I reckon I should just leave "Scan secured connections" unchecked?

YES!!!! That did it! I reloaded a youtube video, and voilá, there it is. And Mozilla page is complete with graphics. Thank you! So I reckon I should just leave "Scan secured connections" unchecked?

Úinéir na ceiste

Whew. All that is such a dark and twisted place to go if you don't know what any of it means or does.... Thank you again.

Whew. All that is such a dark and twisted place to go if you don't know what any of it means or does.... Thank you again.
jscher2000
  • Top 10 Contributor
8775 réiteach 71736 freagra

I would leave it unchecked for now. Avast usually sets up Firefox to trust its fake certificates so this problem is not supposed to occur. Unfortunately, that seems to fail fairly often, and I don't know the best way to fix it on Mac.

I would leave it unchecked for now. Avast usually sets up Firefox to trust its fake certificates so this problem is not supposed to occur. Unfortunately, that seems to fail fairly often, and I don't know the best way to fix it on Mac.

Úinéir na ceiste

OK. I'll see if there will be any other problems after a while.

OK. I'll see if there will be any other problems after a while.