Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How do I prevent 32 "do-nothing" background instances remaining open every day?

  • 13 freagra
  • 2 leis an bhfadhb seo
  • 200 views
  • Freagra is déanaí ó tmwellington

more options

Nothing I've tried in the past *year* has been able to prevent this, so it's gone through a few revs without fixing. Even restarting FF every half-hour does nothing to help the problem if a background instance began running 31 minutes ago.

Win 8.1 ... FF 40.0.3

Réiteach roghnaithe

Thank you, Fred McD... but that's a pretty drastic way to begin diagnosis. What I've done instead is to keep ProcessExplorer open and watch to see where the extra instances of FF are coming from.

Turns out, they're all child processes of Outlook. If I click a link in an Outlook email I've received (usually a link to a newspaper article), Outlook will spawn a new FF instance like this: "C:\Program Files (x86)\mozilla firefox\firefox.exe" -osint -url http://..."

If an instance of FF is already running, all of this child window's content gets copied to a new tab in the running instance of FF... but the child window isn't closed after that: it remains open in the background, sometimes uselessly taking up more than 4MB of RAM.

The workaround I've found (100% effective) is to begin my browser-day by opening FF indirectly instead of from its desktop icon: I open an email with a link in it, click on that link, and from then on, the only instance of FF I'll have running is the Outlook child: all email links will be opened directly into a new tab in this child process without opening anything else.

I don't know whether the blame Outlook, FF or Windows for this behaviour... but I don't care much about that, now that I know how to avoid it without wasting any of my time.  :-)

Read this answer in context 👍 0

All Replies (13)

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

OK FredMcD... screenshot: part of my Task Manager window. I've only had FF running for 3 hours, so it's not overwhelmed yet... but already there are 5 background instances running that I didn't open.

Some nights I shut down before bed and find I have way over 30 of them... and if there's an FF patch/update to install, I have to individually shut them down before the install will start (this is the same for any other software update that requires a browser shutdown).

more options

Download Firefox Full Version For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.

• Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory.


Look for, and rename any Mozilla or Firefox folders by adding .old to them.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.

more options

Réiteach Roghnaithe

Thank you, Fred McD... but that's a pretty drastic way to begin diagnosis. What I've done instead is to keep ProcessExplorer open and watch to see where the extra instances of FF are coming from.

Turns out, they're all child processes of Outlook. If I click a link in an Outlook email I've received (usually a link to a newspaper article), Outlook will spawn a new FF instance like this: "C:\Program Files (x86)\mozilla firefox\firefox.exe" -osint -url http://..."

If an instance of FF is already running, all of this child window's content gets copied to a new tab in the running instance of FF... but the child window isn't closed after that: it remains open in the background, sometimes uselessly taking up more than 4MB of RAM.

The workaround I've found (100% effective) is to begin my browser-day by opening FF indirectly instead of from its desktop icon: I open an email with a link in it, click on that link, and from then on, the only instance of FF I'll have running is the Outlook child: all email links will be opened directly into a new tab in this child process without opening anything else.

I don't know whether the blame Outlook, FF or Windows for this behaviour... but I don't care much about that, now that I know how to avoid it without wasting any of my time.  :-)

more options

On your system, do you run any kind of sandboxing or process isolation software that might account for this extra layer of separation/extra hand-off? It just sounds unusually dysfunctional.

more options

jscher2000 said

On your system, do you run any kind of sandboxing or process isolation software that might account for this extra layer of separation/extra hand-off? It just sounds unusually dysfunctional.

No sir. This is plain-vanilla Windows 8.1 on a nearly-new laptop here... but this problem was also evident on my previous machine (a big desktop running on Win 7, also previously on XP).

I've done some web-searching homework over the past couple of days and found out that people have complained occasionally about these multiple orphaned browser windows (usually as a source of system sluggishness) since at least as far back as 2007... and it also happens if FF *or* Chrome is opened through an email link in Thunderbird.

more options

I am on Windows 7. I normally use Windows Live Mail program. When a link is selected, it opens a new window (because of Firefox user options). Once I am done with that window, I close it. And it's gone.

more options

FredMcD said

I am on Windows 7. I normally use Windows Live Mail program. When a link is selected, it opens a new window (because of Firefox user options). Once I am done with that window, I close it. And it's gone.

Hmm. I refuse to use "LiveMail"... or "cloud" software of any kind... but if you're up for an experiment:

Perhaps you can run Process Explorer, open a web link from LiveMail, and see about two things 1) does firefox open as a child process of LiveMail? 2) if it does, open its Properties (right-click menu in ProcExp) and see if the command that opened it looks like "C:\Program Files (x86)\mozilla firefox\firefox.exe" -osint -url http://..."

BTW... here's a question about this stuff from 2006.  :-) http://forums.mozillazine.org/viewtopic.php?t=448060

more options

I do not have Process Explorer on my system.

Live Mail is not a cloud I believe. It's just a browser for web-mail.

more options

FredMcD said

Live Mail is not a cloud I believe. It's just a browser for web-mail.

Technically, LiveMail is just what you say: an interface for webmail servers. That said, if you use it to access your email at a @live.com or @hotmail address, your mail lives on Microsoft's cloud servers.

more options

Well, cloud or not, all e-mail is on the providers servers. Your browsers are used to display what the servers have in your accounts.

more options

Agreed... and we're off topic here. Sorry.  :-)

Thanks for your help!

more options

Have had same problem, although not so extreme. Looked like when I click on a link from Thunderbird I get a phantom process running.

I had hoped that subsequent updates would have fixed. I have every add on in Tbird turned off.

Is there a setting somewhere to force Thunderbird to open an actual new window ?