Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox keeps searching for updates when new tab opened.

  • 7 bhfreagra
  • 2 leis an bhfadhb seo
  • 90 views
  • Freagra is déanaí ó briantodd1

more options

I am running the latest version of Firefox (40.0.3) with ad blocker plus as my only addon. However every time I attempt to open a new tab it take ages to open because Firefox is constantly searching for an update. This takes 2-3 minutes every time. Have tried refreshing Firefox, uninstalling and reinstalling without success. My system is Win 8.1 on a i7 Lenovo PC. All worked well until the latest FF upgrade. I have no problems with the same version installed on my laptop. Any help/suggestions would be much apprciated. Thanks.

Réiteach roghnaithe

As long as it works. Well Done. Please flag your last post as Solved Problem so others will know.

Read this answer in context 👍 1

All Replies (7)

more options

Download Firefox Full Version For All languages And Systems {web link} Save the file. Then;

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Mac: Open the "Applications" folder. Linux: Check your user manual.

• Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory.


Look for, and rename any Mozilla or Firefox folders by adding .old to them.

After rebooting the computer, run a registry scanner. Then run the installer. If all goes well, remove the OLD folders when you are done.

more options

Regret this solution does not work for me. Tried it twice without any success.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles Create a new, blank profile and use it. Make no changes to it. Any problems?

more options

Fred, Many thanks for your assistance with my recent problems running Firefox with Win 8. Tried the safe mode option without success, still had problems.

However have just installed the Windows 10 'upgrade' on my system and reinstalled Firefox again - it's now working perfectly! Your assistance much appreciated. Brian

more options

Réiteach Roghnaithe

As long as it works. Well Done. Please flag your last post as Solved Problem so others will know.

more options

You can look at the browser.newtab.url pref on the about:config page and set that pref to the URL of your preferred new tab page. You can use these special pages or set the pref to the URL of your preferred new tab page.

  • the default new tab page with the tiles is about:newtab
  • the default home page is about:home
  • for a blank page you can use about:blank

The browser.newtabpage.enabled pref should be set to true to use the page set via browser.newtab.url as the new tab page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

more options

Upgraded to Win10 so problem has now gone away. Thanks for response.