Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

A few days ago, Firefox started shutting down whenever I deleted or tried to respond to a webmail. Anyone else seeing this problem? FF 40.0.2

  • 17 freagra
  • 2 leis an bhfadhb seo
  • Freagra is déanaí ó bdherrick

more options

Firefox launches ok. Webmail launches ok but slowly. Reading email is no problem, but if I try to delete or reply to a single message, FF shuts down. It launches ok again. To further confuse matters, it doesn't always do this; just most of the time. Deleting multiple messages simultaneously works ok.

All Replies (17)

more options

I don't think I've seen this reported (but it's impossible to keep up with every post here...)

Three questions:

(1) Are you getting the Mozilla Crash Reporter dialog, or the Windows crash dialog? If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the last section of the support article "Troubleshoot Firefox crashes (closing or quitting unexpectedly)" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here.

(2) If there's no crash, it could be that the last tab in the last open Firefox window is closing, thereby exiting the program. Perhaps a script in the page or some add-on is sending a close tab command. Could you get having a second second open (Ctrl+n) and see whether only the webmail window closes? Not that it should be happening at all, but it would provide some clues about what might be going on.

(3) What webmail site is it (e.g., Yahoo, Outlook, Gmail, something else)?

more options

Also, this general advice...

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page, logging back into mail, and testing the problem features. Any improvement?

more options

OK - let's see if I can answer these.

1. No crash report dialog.

2. Yes, it seems only the webmail tab is closing. When I have multiple tabs open, the rest remain open normally.

3. Earthlink webmail

4. No cache clearing button in the 3 bar menu, but there is under Options/Advanced. Clearing the cache seemed to help; I could then delete mail files. I always close cookies on shutdown, and can manually delete them as well but I'm not sure if that helped.

Now I'm not so sure. Clearing the cache normally on a freshly opened tab, and then opening webmsil and deleting a message, FF closes. Opening webmail first, then clearing the cache, FF closes.

To answer these questions, I have one tab open to a weather site, one opened to webmail where I am responding here, and I open a 3rd tab to experiment, and that's the one that closes.

Bypassing the cache by using ctrl/shift opens a completely new instance of FF rather than a new tab. I have closed those.

I have to leave right now but will be back shortly to read your response. Thanks!

more options

I don't have an Earthlink account, so I'm speculating here: It sounds as though the site may be designed for a style of use where the individual message you are reading opened in a new window or tab, separate from the Inbox, so when you delete it, the site closes that window/tab, returning you to your Inbox. If the message is opening in the same tab your Inbox was in, then when the script closes the message, it is closing mail completely.

Does that sounds like it could be the issue? Firefox does have a setting to force new windows/tabs back into the tab they opened from. Most people would not have that turned on, but if you do, it could be something to undo for testing. You can check it here:

(1) In a new tab, type or paste about:config and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste link.o and pause while the list is filtered.

(3) There are three similarly named preferences for different scenarios:


3 = divert new window to a new tab (default) 2 = allow link to open a new window 1 = force new window into same tab — do you have this set?

(B) - for links in Firefox tabs

0 = apply the setting under (A) to ALL new windows (even script windows) 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default) 1 = override the setting under (A) and always use new windows

(C) - for links in other programs

-1 = apply the setting under (A) to external links (default) 3 = open external links in a new tab in the last active window 2 = open external links in a new window 1 = open external links in the last active tab replacing the current page

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

I finally had time to get back to this. I followed your suggestions and started FF in Safe Mode. My problem went away. I switched to the default theme, although the theme I was using has been there for years without problems. Then I disabled my extensions. I only had 2 add-ons - AdBlock Plus and AdBlock plus Pop-Up Add-on. I then restarted FF in normal mode. The problem was still gone. I tried shutting down the computer as I wondered if it was stucsk in safe mode. It came up normally. Then I added back my theme, but it didn't come back. Then I enabled my add-ons, one at a time, but neither came back. The add-ons window says they are enabled, but they are not and I am getting lots of ads. My problem is still gone. This is frustrating. Frankly, I would rather deal with the original problem than have the ads return.

Any new suggestions? Thanks - bdh

more options

I don't understand this part:

bdherrick said

Then I enabled my add-ons, one at a time, but neither came back. The add-ons window says they are enabled, but they are not and I am getting lots of ads.

The Add-ons page says that Adblock Plus is enabled, but web pages are full of ads that Adblock Plus normally blocks?

Does the ABP "stop sign" icon appear on the toolbar and, if so, does it have any information about what might be going wrong with ABP?

Also, if your ads say something like "ads by name" then you may have program folder infection. For that, please:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 40.0.2 from to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox


C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox


C:\Program Files\OldFirefox

(D) Run the installer you downloaded in (A). It should automatically connect to your existing settings.

Does that flush it?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

The Add-ons page says that Adblock Plus is enabled, but web pages are full of ads that Adblock Plus normally blocks?

That is correct.

Does the ABP "stop sign" icon appear on the toolbar and, if so, does it have any information about what might be going wrong with ABP?

No, it does not. That was the first thing I noticed.

Also, if your ads say something like "ads by name" then you may have program folder infection. For that, please:

No, nothing like that.

I did not try your suggestion right now. Dinner time. Perhaps later.

Thanks for trying to help.

Just as an aside, my local PC Support guy told me that several problems have cropped up with FF 40.0.2 But I did not discuss this one with him.

more options

bdherrick said

Just as an aside, my local PC Support guy told me that several problems have cropped up with FF 40.0.2

He could say that about every release of Firefox... But Adblock Plus not working is not a known problem, or at least I haven't seen it in another thread (I probably read about a third of them).

If you check your extensions list on the support information page, does anything additional/unexpected show up there? You can open that using any of these:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Extensions heading, and check the table that follows it.

more options

No - it shows both Adblock extensions as true, and the others I have disabled as false, which is correct

more options

Happy Labor Day!

Once again, I've been delayed in following up, but I have some new information. Very strange information ;)

I noticed that the ads that were appearing did not seem to be "legitimate" ads, but rather graphic versions of the typical SPAM that I receive. Lots of stuff about "Obama wants to lower your mortgage payments"; stuff like that. Occasionally I would get some real right-wing conspiracy thing involving (always) Obama and many others including the Pope, Putin, etc. Strange stuff. I don't usually have my speakers on, but when I did I got an endlessly repeating message about "the reason you are receiving these pop-ups is because you have a virus. You must call this number to find out how to remove this virus." I never took the number down nor called it' I've heard of that one before.

Next, I ran Malwarebytes, which found nothing. Then I ran Spybot Search and Destroy, which found a bunch of low threat level stuff and removed it. Then AdBlock Plus started working - the stop sign was back; all the ads were gone, and everything was back to normal, except that I had the same initial problem of FF closing when I tried to delete an email. I also noticed that it closed if I tried to reply to a message.

Today I have time to try your method of a clean reinstall. Everything went as expected, and I now have a clean version of FF 40.0.3 running - and it still has the same original problem.

One other thing that may or not be related. When you had me try Safe Mode, without the extensions enabled, everything appeared to work, as I stated at the time.

I only have 2 add-ons - AdBlock Plus and AdBlock Plus Pop-Up Add-on. Both are currently enabled and appear to be working properly.

Under appearance, I had Vintage Stratocaster enabled. It's been there for a few years without problems. It was disabled when I went to safe mode. When I turned it back on, the menu bar turned black, but the image of the Strat never returned. Checking the Appearance page says that it is enabled.

I do not know where to turn now. On the troubleshooting index page there is a button titled (Give FF a tune-up.) Should I try that?



more options

An additional note: I cannot download or unattach any attachments sent to me. This is a big problem in my work.


more options

What if you turn off just the "pop-up" blocker extension?

more options

I've tried it both ways - no difference.

It's been years, and never on this computer, since I've used IE, but once I got it set up properly, I can now detach my attachments.

I still much prefer Firefox.


more options

Firefox's Safe Mode also disables hardware acceleration of graphics and the JavaScript compilers which improve the performance of website scripts. It's hard to see how those could be related to a tab closing itself.

Earlier you mentioned some (temporary) improvement after clearing the cache. Maybe this is a problem of ongoing cache corruption?

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that has effect.

more options

I'm a little busy to stop and experiment with this problem, so I apologize for the slowness in trying suggestions. To summarize what I have found so far:

While in Earthlink Webmail, any attempt to perform an action from within Firefox - delete the current email, move the current email, reply to the current email - closes Firefox. Attempting to detach an attachment has no effect. It does not give me the option to open or save the attachment.

Opening FF in FF safe mode, I tried to delete the current email and it worked correctly. I did not try the other actions.

Starting Windows in safe mode has no effect. FF still closes when I try to delete or perform some other action.

Turning off the pop-up blocker extension had no effect.

Clearing the cache doesn't seem to have any effect.

After turning off my "Vintage Stratocaster" theme, turning it back on turned the menu bar black but the photo of the Strat did not reappear.

The stop sign is present and there are no ads.

And - one thing I had not mentioned before - this all started when I installed a solid state hard drive. Everything else on the computer appears to be functioning normally.

I have not yet tried the "Give Firefox a tune-up" option. What happens when I do this?

Something else I have noticed, before this problem started - when I clear browser history, the history is no longer visible (ctrl-h), but it's apparently still there. Autocomplete will complete any prior website when I start to type it. How do you clear all previous history?

Is uninstalling and reinstalling FF a good option'? Is this what "Give FF a tune-up does?

That's all I can think of at the moment. I'd really like to get this working again. Thanks for all your help.