Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dúnadh an snáithe seo agus cuireadh sa chartlann é. Cuir ceist nua má tá cabhair uait.

How do I change the program that opens folders?

  • 6 fhreagra
  • 2 leis an bhfadhb seo
  • Freagra is déanaí ó MartinT

more options

When I download files, I then want to open them. If I click on the Downloads arrow and see my file, I click on the file and want to open the folder where it is. If I do this, my default file manager does not open. I get one named Files. I have searched and found several posts that tell how. None of them work for me.

I am running Fedora 21 64 bit mode.

How can I change the name of the program that opens the folder?

How can I add an entry into Firefoxes Applications tab?

Thank you.

All Replies (6)

more options

Is this with all type files?

I've called the big guys to help you. Good luck.

more options

I want to change the program that opens up when I clink "Open Containing Folder" after I have downloaded something. I have tried everything that I could find.

Is the program name kept in about:config?

more options

That isn't a setting in Firefox, but is set on the OS level (Linux).

I get:

  • /usr/share/applications/nautilus-folder-handler.desktop
[Desktop Entry]
Name=Open Folder
Exec=nautilus --no-desktop %U

Athraithe ag cor-el ar

more options

It does not look like Firefox is honoring the xdg-mine value.

[vince@Vincepc ~]$ xdg-mime query default inode/directory dolphin.desktop

xdg-open /etc opens the /etc directory in Dolphin like I want. However, in Firefox if I try to open the containing folder of a downloaded file, it opens in a program called Files. Where does Files come from? I do not have a program with that name installed according to YUMEX.

How do I find out where Firefox is getting the name of the program to use?

more options

Did you search the .desktop files to see if there is one with that Files item?

  • /usr/share/applications/
  • ~/.local/share/applications
more options

I have the same problem with Debian 8.

I used the Gnome System Monitor and found that 'Files' is actually /usr/bin/nautilus the Gnome file manager.

I renamed nautilus to stop it running. Firefox launched /usr/bin/pcmanfm, the LXDE file manager, instead.

I then renamed pcmanfm and Firefox then launched konqueror.

In fact, it now launches the default KDE program for handling directories which can easily be edited. In either konqueror or dolphin right-click on a directory, select 'properties', and then 'File Type Options'. You can move whatever you want to the top of the list.

So I solved the problem for my system - though it is a bit of a Kludge and I am still not sure what Firefox is doing.