Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Facebook photos don't show up

  • 2 fhreagra
  • 1 leis an bhfadhb seo
  • 5 views
  • Freagra is déanaí ó LJones

more options

Facebook photos don't show up in Firefox (version 39.0) but they appear in Safari. I've tried clearing my cookies and cache and clearing my history. I've restarted my computer, too. Still not working. It does not seem to be a Facebook problem since the images appear when I use a different browser. Everything worked fine yesterday and nothing changed in the meantime.

All Replies (2)

more options

Right click on the facebook page and select "Page Info" and under the permissions tab, make sure that "Block images ..." is not checked.

Next I would try a refresh: The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

more options

I have done as advised in FB (copied below), but there is NO 'Block Images' entry under 'Page Info'. There is a 'Load Images' entry, which is set to Default and 'Allow'. So how do I get FB to display my photos via Firefox, when FB does display my photos via Google Chrome ?

Right click on the facebook page and select "Page Info" and under the permissions tab, make sure that "Block images ..." is not checked.

Athraithe ag LJones ar