Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

No Youtube taskbar (play, pause, sound/volume control, etc.)

  • 18 freagra
  • 2 leis an bhfadhb seo
  • 14544 views
  • Freagra is déanaí ó JerseyJay

more options

Get no YouTube task bar or control bar (play pause, sound level, etc.). . just a black screen, no audio and no control bar at the bottom of the black screen.

All comments and responses to postings appear, but no way to click or start the video.

Also, on Youtube Home screen, provides the following: Hello, you seem to have JavaScript turned off. Please enable it to see search results properly.

As a result, I've updated Javascript, Flash and have made certain Javascript is ENABLED. Still no taskbar. that will enable me to play YouTube videos.

PS: HAVE TO USE Firefox 34 as ALL subsequent updateS result in the following JavaScript Application error:

'Top' getter called on an object that does not implement interface Windows

HELP & THANKS!!

Réiteach roghnaithe

Well, if you do not get the messages in Firefox's Safe Mode, it must be one of your extensions. Unfortunately, I don't have a way to know which one it is, so more trial and error will be needed, I think.

Read this answer in context 👍 0

All Replies (18)

more options

That JavaScript error may indicate that one of your extensions needs to be updated. You can check for Extension updates on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, above the list on the right side, look for a "gear" button and use "Check for Updates".

YouTube has switched Firefox users to an HTML5 player instead of Flash for the most part, so to determine which video player is not working correctly, you need to know which is being used. Normally you can determine that by right-clicking the player and looking at the bottom menu item on the context menu. You also can check this page:

https://www.youtube.com/html5

But I notice you have several extensions targeted at YouTube. What if you temporarily disable extensions by testing in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

Thanks so much for your prompt assistance. Followed your instructions, checked for updates, (none available), determined that video player was HTML5, disabled add-ons and restarted in SAFE MODE.

Eureka!! YouTube has a control bar & works great!!!

Now. . . .how do I get out of SAFE MODE (and hopefully) keep YouTube working?

PS: Any thoughts on the JAVASCRIPT error I receive when I update to any newer version of Firefox than Firefox 34?

Thanks again

more options

While in SAFE MODE with all add-ons disabled, I enabled each add-on individually and tested to see if YouTube opened with control bar. With all add-ons enabled, YouTube opened with a control bar each time.

Closed SAFE MODE but back to YouTube not working. (no control bar).

Did I exit SAFE MODE incorrectly or not do something else I should have done?

more options

In Safe Mode, all extensions are disabled, and I don't think Enable/Disable can actually enable them in Safe Mode.

Could you try disabling all the YouTube specific extensions in normal mode and see what happens? You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions as usual, then you can disable extensions on the right.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that make any difference?

more options

Another "Thanks" for getting back to me. Problem solved!!!

After a series of Disable/Enable/Restart Firefox tests, it appear that YesScript was the culprit. Removed the add-on and YouTube continues to to display the control bar permitting it to be functional.

Now, if I could only find out how to eliminate the JavaScript Application error (see below) when I try upgrading to Firefox 38.0.1. Currently, can only use Firefox 34.0.5

Error: 'top' getter called on an object that does not implement interface Windows.

Any suggestions?

more options

Does the error message identify the source? For example, a web URL or chrome:// script URL?

more options

It's presented like a rectangle pop-up window in the center of the screen with JAVASCRIPT APPLICATION in a shaded border at the top and the error message below.

It reloads approximately 20 times (on top of each other) once the new Firefox version has been installed and is opened. Clicking OK or X on each of the multiple windows will FINALLY deleted all of the error windows but once a new tab is opened, the process begins all over again.

more options

Oh, that's terrible. In past threads, at least 3 different extensions triggered a very similar message: Updated to Firefox 35 and now I get a Javascript error message. My guess would be that they all used a common component that was no longer compatible with Firefox 35 and needed to be updated by the developer. Problem is, what is an efficient way to track it down? Hmm...

more options

No....nothing more than what I communicated in my previous post

more options

FYI. . . the screenshot in the a very similar message: "Updated to Firefox 35 and now I get a Javascript error message" is identical to error I receive except my error reads 'top' getter rather than 'navigator' getter.

Does this mean there's no solution?

more options

Réiteach Roghnaithe

Well, if you do not get the messages in Firefox's Safe Mode, it must be one of your extensions. Unfortunately, I don't have a way to know which one it is, so more trial and error will be needed, I think.

more options

Thanks for all your assistance and suggestions in solving my YOUTUBE issue.

Unfortunately, I'm unable open the latest version of FIREFOX in SAFE MODE as long as I'm getting the JAVASCRIPT APPLICATION error I've described.

Guess I'll just have to continue using FIREFOX 34.0.5 and hope that eventually one of the upcoming FIREFOX updates will correct the problem.I'm experiencing.

Again, many thanks for your help.

more options

JerseyJay said

Unfortunately, I'm unable open the latest version of FIREFOX in SAFE MODE as long as I'm getting the JAVASCRIPT APPLICATION error I've described.

Do you mean you can't use the Help menu method, or you can't use the holding down the Shift key method, or even in Safe Mode you get the same error?

If you get the same error in Safe Mode, please try this:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 38.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

After all of our communications, I think herein may lie the problem.

There is a C:\Program File (x86) folder that contains a Mozilla Firefox program folder. . . BUT in the C:\Program File folder there is no Mozilla Firefox program folder.

Seems I may be missing the 32-bit Windows folder containing Mozilla Firefox program folder? ? ?

more options

FINALLY was able to open SAFE MODE after installing & launching FIREFOX 38.0.1. Went through testing all add-ons and found the culprit to be YouTube Video Downloader 1.0.0.6 without having to do a CLEAN REINSTALL.

Removed the add-on and now the latest FIREFOX is working fine & I'm able to view YOUTUBE. . . .a very happy camper here!!

Thanks again for all your persistence and help with my FIREFOX issues.

more options

Check that add-on for an update, or contact their support.

more options

Hi JerseyJay, glad to hear it is sorted out.

It's confusing but on 64-bit systems C:\Program Files contains the 64-bit programs and C:\Program Files (x86) contains the 32-bit programs. No idea why they did it that way.

more options

Thanks again for all you help.