Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

firefox crashes on certain sites at random

  • 36 freagra
  • 1 leis an bhfadhb seo
  • 168 views
  • Freagra is déanaí ó Mashico

more options

on certain image hosting sites like pintrest firefox will randomly crash this didnt happen until i had to update, i tried removing and reinstalling flash, i tried making a new profile i am not sure what else to do

All Replies (20)

more options

If you have submitted crash reports then please post the IDs of one or more recent crash reports that have a "bp-" prefix:

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the Report ID of recent crash reports on the "Help > Troubleshooting Information" page (about:support).

  • Click the "All Crash Reports" button on this page to open the about:crashes page and see all crash reports.

If necessary then you can open about: pages via the location/address bar.

See:

more options
more options

I'm not familiar with the Windows functions being called at the time of the crash...

Could you try disabling Firefox from using hardware acceleration? New capabilities enabled in Firefox 37 might be incompatible with your graphic driver software.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit Firefox and start it up again. Any difference?

Since hardware acceleration improves the appearance of fonts and animations, you may want to check your computer manufacturer's website to see whether any graphics card/chipset driver updates are available for your system.

more options

i already had that turned off

more options

Some users also had to make this change when Firefox 37.0 was released, although 37.0.1 and later are better in this regard:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste d11 and pause while the list is filtered

(3) Double-click the layers.d3d11.disable-warp preference to switch it from false to true

more options
more options

I can't tell what is causing it.

If you wouldn't mind, would you remove the "Updated Ad Blocker" extension and replace it with Adblock Plus? That older extension actually has not been updated for over three years.

https://addons.mozilla.org/firefox/addon/adblock-plus/

more options

ok i removed that one and got the one you suggested and it still crashes should i put up the new crash report?

more options
more options

Looks like the identical problem continuing. In case there is a problem with your Firefox programs folder, could you try this:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 38.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

Try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

more options

well i did the clean install thing....but now i have another problem i made sure to make a copy of my profile so i can switch the bookmarks n such however when i transferred the files to the new profile i got everything back......except my bookmarks

more options

and it didnt stop the crashes

more options

i tried seeing if the same thing would happen on internet explorer and everything worked fine.......

more options

At what point did you create a new profile? That is not part of the Clean Reinstall procedure.

If you copied over the bookmarkbackups folder, you can try restoring a backup. This article has the steps: Restore bookmarks from backup or move them to another computer.

more options

ok i got my bookmarks back but it still crashes to make extra sure nothing was wrong i deleted all mozilla files then reinstalled it. should i put up the most recent crash?

more options

Sure, it might be the same, but it's worth checking whether it's the same crash signature.

more options
more options

so since no one can solve this what do i do? switch browsers? this only happened after the update

more options

Do you want to try Firefox 38.0.1, an emergency bug fix version released on Thursday? https://www.mozilla.org/firefox/all/

  1. 1
  2. 2