Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Website does not render correctly

  • 25 freagra
  • 3 leis an bhfadhb seo
  • 1413 views
  • Freagra is déanaí ó jorb

more options

When I go to this website,

http://www.eaa.org/en/airventure

It displays like this,

http://eaaforums.org/attachment.php?attachmentid=3825&d=1398908191

Does it display the same way for you when using FF 37.0.2 ?

IE and Chrome display it differently.

The horizontal menu should be displaying to the right of the EAA Oshkosh AirVenture logo.

Athraithe ag jorb ar

Réiteach roghnaithe

Could you check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste refer and pause while the list is filtered

(3) If the network.http.sendRefererHeader preference is bolded and "user set" to a value other than 2, right-click > Reset the preference so that Firefox sends the Referer header in all relevant cases

If you changed that, does it allow Firefox to get the font for that site?

Read this answer in context 👍 0

All Replies (20)

more options

Can you attach an image as how you see this in Google Chrome?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see what content is blocked and has a zero file size.

more options

The combined width of the logo plus menu exceeds the space available, so Firefox wraps the menu down. In my case, this is because Firefox is using Times New Roman for the menu instead of your intended font, which is a narrow face that "fits" at 14px.

Firefox is successfully retrieving the style sheet from fast.fonts.net but is failing to download the actual font files. The Browser Console shows:

downloadable font: download not allowed (... ) content blocked source: ...

Since there are no requests in the Network section of the Inspector, I can't see whether Firefox is sending a different request than Chrome.

more options

Whoops, sorry, in my case, the font was blocked by the NoScript extension. Your explanation may be different. Do downloadable fonts normally work for you in Firefox?

more options

Works here.

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

Athraithe ag cor-el ar

more options

After unblocking the font, it works for me except the R's look strange.

more options

I jscher2000 said

After unblocking the font, it works for me except the R's look strange.

I tried cor-el's suggestions with no change.

The only solution that make sense is jscher2000's. But I cannot figure out how unblocking the font is accomplished.

jscher2000 I think you are on to something with this statement "logo plus menu exceeds the space available" If you click on EAA Museum at the top of the page. That page has a shorter horizontal menu, it does not exceed the space available, and displays correctly.

Q. Do downloadable fonts normally work for you in Firefox? A. I do not know how to test this.

Or do you think that this is just a poorly designed webpage/site? About a year ago they completely redid the website. One of the reasons, I think was to be able to display over multiple devices. EAA AirVenture App https://www.eaa.org/en/airventure/eaa-airventure-news-and-multimedia/eaa-airventure-app

1st image is FF 2nd image is Chrome.

more options

Do you see any font related error messages in the Web Console (Firefox/Tools > Web Developer)?

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if CSS or other content is blocked and has a zero file size.

more options

cor-el said

Do you see any font related error messages in the Web Console (Firefox/Tools > Web Developer)? You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see if CSS or other content is blocked and has a zero file size.

These are the errors below.

Error in parsing value for 'height'. Declaration dropped. Error in parsing value for 'top'. Declaration dropped.

more options

downloadable font: download failed (font-family: "LinotypeUniversW01-Bold 723691" style:normal weight:normal stretch:normal src index:0): status=2147746065

downloadable font: download failed (font-family: "Minion W01 Cap Regular" style:normal weight:normal stretch:normal src index:0): status=2147746065

downloadable font: download failed (font-family: "LinotypeUniversW01-Bold 723691" style:normal weight:normal stretch:normal src index:1): status=2147746065

downloadable font: download failed (font-family: "Minion W01 Cap Regular" style:normal weight:normal stretch:normal src index:1): status=2147746065

more options

Hi jorb, I was accidentally blocking the font download using the NoScript extension.

I don't recognize the message you're getting:

downloadable font: download failed (font-family: "LinotypeUniversW01-Bold 723691" style:normal weight:normal stretch:normal src index:0): status=2147746065

When I search around for that status, I don't see a clear reason for it.

Could you check to make sure Firefox is set to download fonts? You can check here:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the search box above the list, type or paste gfx and pause while the list is filtered

(C) If the gfx.downloadable_fonts.enabled preference is bolded and user set to false, double-click it to restore the default value of true

more options

jscher2000,

The below 1st image is the CSS errors. With the http://www.eaa.org/en/airventure page open. I went to Firefox/Tools > Web Developer > web console > CSS , There is a source link at the end of the errors, that I did not include in the previous post.

The gfx.downloadable_fonts.enabled was set at default value of true. check 2nd image. I did not change any preference.

more options

I'm not sure why it's failing.

Do downloadable fonts generally work on other sites? For example, FontAwesome: http://fortawesome.github.io/Font-Awesome/icons/

Do you use any add-ons or external security software that might modify requests to websites, for example, by removing referring page (HTTP_REFERER) information?

more options

Does the Net log show any more specific errors?

more options

jscher2000 said

I'm not sure why it's failing. Do downloadable fonts generally work on other sites? For example, FontAwesome: http://fortawesome.github.io/Font-Awesome/icons/

When I go to the page that you mentioned, how do I know if the downloadable fonts are working? When I click on any of the icons, the icons display multiple font sizes.


jscher2000 said

Do you use any add-ons or external security software that might modify requests to websites, for example, by removing referring page (HTTP_REFERER) information?

The only add on I have enabled is Classic Theme Restorer. When disabled there is no change. The only security software Is MSE and whatever At&t Uverse uses for the 2wire router. And Malwarebytes

I do not understand (HTTP_REFERER)

Athraithe ag jorb ar

more options

Hi jorb, if you see the images on FontAwesome then your Firefox is downloading their font as needed.

HTTP_REFERER is the address of the referring page. Some sites use this to check whether your request is from an appropriate page, or whether some unrelated site might be embedding their font (in which case, it will be blocked).

Could you try cor-el's suggestion of using the Network Monitor to see what status code is returned for the font request? For example, 404 not found, 403 forbidden, etc.

Added a screenshot of the Network Monitor after a reload bypassing the cache (Ctrl+Shift+r), and clicking the Domain column heading to sort by site.

Athraithe ag jscher2000 ar

more options

cor-el said

Does the Net log show any more specific errors?

Is this what you are looking for. (image below)

more options

Actually those do show "403 Forbidden". So the question would be why the site is refusing to serve the files.

more options

To finish my thought!

If you click the first entry (WOFF file) and look at the Request headers, are they similar to the attached?

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0 Referer: http://fast.fonts.net/cssapi/ad3570d8-118a-4bee-a220-1ece2a4313e6.css Pragma: no-cache Origin: http://www.eaa.org Host: fast.fonts.net DNT: 1 Connection: keep-alive Cache-Control: no-cache Accept-Language: en-US,en;q=0.5 Accept-Encoding: identity Accept: application/font-woff;q=0.9,*/*;q=0.8

Athraithe ag jscher2000 ar

more options

jscher2000 said

Actually those do show "403 Forbidden". So the question would be why the site is refusing to serve the files.
Are you having the same menu (Drop down) problem with FF as I'm having?

Is it my FF browser?

more options

The site is working for me.

Sorry our posts crossed, can you try clicking the first entry in the console (in your screen shot) and compare the Request headers with mine: https://support.mozilla.org/questions/1061272#answer-727167

  1. 1
  2. 2