Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

YouTube videos constantly showing loading circle and not playing.

more options

So I'm trying to watch videos on YouTube and all I'm getting is the spinning loading circle and nothing more.

I'm running version 37.0.2 (Most current) and the most basic add-ons that are up to date. I've tried uninstalling and then re-installing Flash, I've uninstalled and then reinstalled FireFox and am still getting the same problem!

Réiteach roghnaithe

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

Read this answer in context 👍 0

All Replies (2)

more options

Réiteach Roghnaithe

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

Actually, before doing any of that, YouTube randomly started working again! LiveLeak and Vimeo were working for me but YouTube wasn't at first.

Thanks for the help anyway!

Athraithe ag Johnnybravo60025 ar