Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

i can't select, copy or past from a website

  • 7 bhfreagra
  • 5 leis an bhfadhb seo
  • 20876 views
  • Freagra is déanaí ó regba123

more options

Hello This folowing website: http://www.studytonight.com/dbms/database-normalization.php won't let me select, nor copy or paste under firefox. I have the 37.0.1 version. I went to the configuration: about:config and I did a search for dom.event.clipboardevents.enabled. I double clicked on it and the value changed to default. I then restarted my firefox browser, and it still didn't work. Would you please help. Thank you.

Réiteach roghnaithe

That site won't let you copy and paste in any browser. They have disabled this functionality to keep people from taking their content.

There's a great Firefox add-on that gets around this called RightToClick. You can install it here: https://addons.mozilla.org/en-us/firefox/addon/righttoclick/

Edit: I just tried using RightToClick to select and copy text on this page. It worked great!

Read this answer in context 👍 2

All Replies (7)

more options

Réiteach Roghnaithe

That site won't let you copy and paste in any browser. They have disabled this functionality to keep people from taking their content.

There's a great Firefox add-on that gets around this called RightToClick. You can install it here: https://addons.mozilla.org/en-us/firefox/addon/righttoclick/

Edit: I just tried using RightToClick to select and copy text on this page. It worked great!

Athraithe ag Mark Schmidt ar

more options

Is the dom.event.clipboardevents.enabled pref set to true (i.e. default) on the about:config page?

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

To Mark Schmidt, This add-on worked perfectly. Thanks a lot I was able to copy, paste and print for study purpose. Thank you. To cor-el, by default dom.event.clipboardevents.enabled pref was set to true. and I changed to false by double clicking on it, but it did make no changes. It was indeed supposed to work but it didn't, and don't know why.

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thanks again!

more options

regba123 said

To Mark Schmidt, This add-on worked perfectly. Thanks a lot I was able to copy, paste and print for study purpose. Thank you.

I selected this answer posted 4/13/15 (yesterday) by Mark Schmidt as solving the problem

more options

Note that you can use a bookmarklet like this in a lot of cased to disble the blocking.

javascript:void(document.onmousedown=null);void(document.onmouseup=null);void(document.onclick=null);void(document.oncontextmenu=null);void(document.onselectstart=null);

function disableText(e){return false;}
function reEnable(){return true;}
//For browser IE4+
document.onselectstart = new Function ("return false");
 //For browser NS6
if (window.sidebar){document.onmousedown = disableText;document.onclick = reEnable;}
window.onkeydown = function(e){if(e.ctrlKey == true){return false;}};
more options

Cor-el, By any chance how can I embedded this boormarklet you mentioned to my Firefox browser. I kinda need a step by step, since I'm not really familiar with this approach. But it is a really good information. Thanks