Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Why won't website navigation links/images/buttons load properly when I set my own font & font size options?

  • 6 fhreagra
  • 4 leis an bhfadhb seo
  • 149 views
  • Freagra is déanaí ó cor-el

more options

I've just noticed a glitch in Firefox when I go to Tools >> Options >> Content >> Fonts & Colors >> Advanced, and set my own font and font size, and force websites to use them. For some reason, this makes websites' navigation buttons fail to show properly.

For example, a website's search bar will show, but the magnifying glass icon will be a box-with-tiny-code. The boxes-with-tiny-code will also replace things like heart icons for Like buttons, arrow icons for Reply and Page Up/Down, things like that.

The link itself is still there, but with all the buttons replaced by identical-looking boxes-with-tiny-code, it's impossible to see what to click without mousing over and hoping a pop-up label will tell me what to use.

Is there a way around this, because I'd like to be able to set a larger font size without making webpages unusable?

ETA: Images of my Tumblr dash, which shows the prblem most clearly, and the font & size options I picked.

Attached screenshots

Athraithe ag zellieh ar

All Replies (6)

more options

It could be there is no room for the icons to show properly. What is the web address, and . . . .

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Missing icons are usually supplied by a font that is downloaded from the server (@font-face) as you might see by little boxes that show the hex code of the characters instead. Firefox will only use such a downloaded font when you allow pages to use their own fonts and not when you disable website fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced:
    [X] "Allow pages to choose their own fonts, instead of my selections above"
more options

But that's not a usable solution for me, because the only way to force websites to respect minimum font size is to prevent them setting their own. Is there any way to split up the font size and font face options? Because I don't mind websites using their own font faces but I just can't read tiny text any more.

And why bother having options, if using them breaks common website features? That just doesn't make sense.

more options

FredMcD said

attach the saved screenshot file to your forum post
Done! Thanks :)
more options

Wow ! Nice background.

Can you post a clip with, and without?

more options

You can use the NoSquint extension to set font size (text/page zoom) and text color on web pages.