Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Since March 5th Firefox will not load pages except for Homepage.

  • 4 fhreagra
  • 4 leis an bhfadhb seo
  • 142 views
  • Freagra is déanaí ó Reecho

more options

Firefox just says "connecting" on the tab and after thirty minutes the page doesn't load. I have tried restarting my computer a few times, and have uninstalled then reinstalled Firefox. It is not a problem with the connection and does not appear to be a problem with my security. I've been using Firefox for over a year on this computer, then suddenly this. What do I do?

Réiteach roghnaithe

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. Check the settings.


Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Read this answer in context 👍 0

All Replies (4)

more options

Réiteach Roghnaithe

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. Check the settings.


Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

How do I know if the settings are right? Also now whenever I close out of Firefox, two minutes later a popup tells me that it crashed and wants to send a crash report. It has the same problem as the browser and never actually does anything.

Athraithe ag Reecho ar

more options

Open the Proxy settings. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use No Proxy. If there is a problem, then try System Proxy.

more options

Thank you for your help.