Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

why are my pages opening in italian instead of english

  • 6 fhreagra
  • 12 leis an bhfadhb seo
  • 437 views
  • Freagra is déanaí ó cor-el

more options

opening pages especially youtube and even translate open in italian instead of english how can I make english default

Réiteach roghnaithe

  1. Press ALt or F10 to see the menu bar
  2. Click on Tools >> Options >> Content
  3. In session Language, click on Choose.. buttons
Read this answer in context 👍 0

All Replies (6)

more options
more options

silly question where do i find the Settings

more options

Réiteach Roghnaithe

  1. Press ALt or F10 to see the menu bar
  2. Click on Tools >> Options >> Content
  3. In session Language, click on Choose.. buttons
more options

done it thank you easy when you know how :-)

more options

maargaret said

opening pages especially youtube and even translate open in italian instead of english how can I make english default

I tried the solution that was offered by going to the Firefox menu, then "options", "content", and I clicked on "choose" for session language and picked English, and then I clicked okay and I am returned to the options screen. But for session language, it still says "choose".

Christian London

more options

You can use websites like these to see how your location is reported via a reverse DNS look up of your IP: