Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Embedded video shows black screen with audio. EDIT: Issue is with HTML5 video.

  • 6 fhreagra
  • 73 leis an bhfadhb seo
  • 49874 views
  • Freagra is déanaí ó messala

more options

I was having this issue with various internet videos, but managed to fix it by enabling and then disabling hardware acceleration.

Unfortunately, embedded video is still broken. The controls still pop up, as well as any annotations and pop ups, but the video itself remains black with only audio.

I've tried every fix I could find. Deleting cookies and history, restarting, disabling plugins, and nothing worked. As I said, I managed to fix the problem on the main sites video by adjusting hardware acceleration, but it apparently didn't take on the embedded videos, and there is no option to enable or disable it by left clicking on an embedded video. I still get the menu popup, but it doesn't have a settings tab at all. I've restarted the browser, made sure it was off in the processes tab, and even restarted my PC. Nothing works and embedded video is still a blank screen with audio.

No idea what to do from here. I'm guessing hardware acceleration is the issue, but I don't know how to set that on an embedded video. No option comes up on the left click menu at all. It seems internet video on Firefox is broken and I can't do anything about it in the player menu.

Video plays fine on other browsers without issue, so it's something to do with Firefox for sure. I've got Chrome and IE on my PC and I've tested both and had success with both regular and embedded video. Firefox continues to have the issue though.

Athraithe ag Contrabardus ar

Réiteach roghnaithe

the issue sure sounds like being related to hardware acceleration - since you already have the latest graphics drivers available installed, maybe the only way around that is to generally disable hardware acceleration for the moment in the firefox menu ≡ > options > advanced > general (that setting will take a restart of the browser to take effect).

Read this answer in context 👍 7

All Replies (6)

more options

Happening again on non-Youtube video sites. Oddly, it stops if I run Firefox in safe-mode, but if I manually disable all of my plugins the issue remains. Regardless of what I turn off it still has the problem. However, even though Safe Mode fixes the issue on non-youtube sites, the problem persists in embedded youtube video even in Safe Mode, which is strange.

It's not consistent though. Some sites have issues and others do not. I have no idea why. It's also only happening on my PC. My laptop isn't having this issue and it's running the same versions of flash, and Firefox.

It's happening on too many different sites for it to be the site itself causing the problem. However, when it does occur, it's consistent, reloading or restarting doesn't make it go away on that particular site.

Also, various other Firefox builds have the problem, including Waterfox and the Nightly build.

Not sure what the deal is exactly. Something is glitching out, but I have no idea exactly what it is. I'm not certain it's Flash either, as Youtube is running HTML5. I'm not certain if some of these other problem sites are also HTML5.

I think that might be where the problem lies, there might be an issue with Firefox and HTML5.

Edit: Confirmed, this issue seems exclusive to HTML5 players. Something is preventing them from playing back properly and they don't always have an option in the left click menu to disable hardware acceleration.

Any ideas about what to do?

Athraithe ag Contrabardus ar

more options

hello, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

more options

Here you go.

It's worth noting that I've had every one of the plugins disabled with the same results. Using safe mode fixes the issue for the video source, but it still persists with embedded video.

I've also tried refreshing Firefox and the problem still persisted even with the various plugins uninstalled. I've since put them back.

Application Basics


Name: Firefox Version: 35.0.1 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 Multiprocess Windows: 0/1

Crash Reports for the Last 3 Days


All Crash Reports (including 1 pending crash in the given time range)

Extensions


Name: Adblock Plus Version: 2.6.7 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Ant Video Downloader Version: 2.4.7.27 Enabled: true ID: anttoolbar@ant.com

Name: Hola Better Internet Version: 1.6.222 Enabled: true ID: jid1-4P0kohSJxU1qGg@jetpack

Name: MEGA Version: 2.0.214 Enabled: true ID: firefox@mega.co.nz

Name: YouTube High Definition Version: 35.3 Enabled: true ID: {7b1bf0b6-a1b9-42b0-b75d-252036438bdc}

Name: Avast Online Security Version: 10.0.2502.149 Enabled: false ID: wrc@avast.com

Graphics


Adapter Description: AMD Radeon HD 7900 Series Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64 Adapter RAM: 4095 ClearType Parameters: D [ Gamma: 2200 Pixel Structure: B ClearType Level: 0 Enhanced Contrast: 400 ] D [ Gamma: 2200 Pixel Structure: B ClearType Level: 0 Enhanced Contrast: 400 ] Device ID: 0x6798 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16571) Driver Date: 11-20-2014 Driver Version: 14.501.1003.0 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC) Subsys ID: 30001002 Vendor ID: 0x1002 WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 7900 Series Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: true AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 2 browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20150122214805 browser.startup.homepage_override.buildID: 20150122214805 browser.startup.homepage_override.mstone: 35.0.1 dom.mozApps.used: true extensions.lastAppVersion: 35.0.1 gfx.direct3d.last_used_feature_level_idx: 0 media.gmp-gmpopenh264.lastUpdate: 1422366737 media.gmp-gmpopenh264.version: 1.1 media.gmp-manager.lastCheck: 1422627769 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1422712367 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npamazonmp3downloaderplugin: 1 plugin.state.npctrl: 2 plugin.state.npesnlaunch: 1 plugin.state.npesnsonar: 2 plugin.state.npvlc: 2 privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.timeSpan: 0 storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1422371544

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: true Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.7 Version in use: 4.10.7

NSS Expected minimum version: 3.17.2 Basic ECC Version in use: 3.17.2 Basic ECC

NSSSMIME Expected minimum version: 3.17.2 Basic ECC Version in use: 3.17.2 Basic ECC

NSSSSL Expected minimum version: 3.17.2 Basic ECC Version in use: 3.17.2 Basic ECC

NSSUTIL Expected minimum version: 3.17.2 Version in use: 3.17.2

Experimental Features


Athraithe ag Contrabardus ar

more options

Réiteach Roghnaithe

the issue sure sounds like being related to hardware acceleration - since you already have the latest graphics drivers available installed, maybe the only way around that is to generally disable hardware acceleration for the moment in the firefox menu ≡ > options > advanced > general (that setting will take a restart of the browser to take effect).

more options

That did it. Thanks a lot!

All videos work now. Apparently Firefox and hardware acceleration don't like HTML5 on my system. No idea why, but the issue is gone once I disable it. Didn't even know that setting was there, I'm used to doing it by left clicking the video player and using the menu there.

Athraithe ag Contrabardus ar

more options

To me, the only think that seems to solve "palliatively" is to disable the hardware acceleration, what indicates some video driver issue.

If you use ATI video card, I suggest you to install the lastest BETA version of AMD drivers. This solved completely this issue to me.

It's important to make clear that a BETA version is a test version, what may bring more problems than solutions, although that it doesn't occur with frequency. I, for one, always install the lastest version, being BETA or not.

AMD drivers can be downloaded here: http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx

Now, if you're using NVidia video card, you can give a try to this (but I can't guarantee success in this case): http://www.nvidia.com.br/Download/Find.aspx?lang=br

Hope it can help. =]