Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

One solution to Flash Plugin hanging or crashing issues.

  • 1 freagra
  • 4 leis an bhfadhb seo
  • 1109 views
  • Freagra is déanaí ó FredMcD

more options

hey guys, i wasnt sure where i could put this info, i have discovered some info regarding the "FLASH PLAYER PLUGIN." that doesnt seem to be documented on any kb article or support thread, so hopefully one of you will be able to help getting this submitted. obviously this wont fix everyone's problem, but it should be included.

THE PROBLEM::

Flash Player Hanging or Crashing (unable to watch flash/video content) Script has become unresponsive error message when trying to view flash/video content

THE SOLUTION:

a possible cause to this problem is that you have lost permissions to the file directory where flash is actually stored. without these permissions you will be unable to properly utilize the flash plugin on firefox.

to fix the problem we will need to update the security settings on the flash directory.

for 32 bit machines: C:\Windows\system32\Macromed\Flash

for 64 bit machines: C:\Windows\SysWOW64\Macromed\Flash

navigate to the \Macromed\ folder and right click on the flash folder and select properties. click on the security tab at the top of this box then on the advanced button at the bottom of this box. after navigating to this screen, you will need to click change permissions. first make sure there is no deny statement which is denying access to this folder, if one exists, remove it. second make sure that the name "Everyone" has the abilty to read and execute, to do this: click on everyone, then edit. next, select: apply any changes to: "This folder, subfolders, and files." this is at the top of the edit box. after you click ok to the changes you made, you will need to enable the option: "Replace all child object permissions with inheritable permissions from this object." now click the apply button, then ok button. now check to see if firefox is working.


if you find that you are unable to change these permissions, then you lost access to the parent folders as well and they are replacing child object permissions. you will need to apply the solution above to the parent folder that is overriding the permissions. this will either be: \system32\ or \SysWOW64\ depending on your machine or possibly even the \Windows\ folder.

If you find that these parent folders indeed had their permissions lost, then you have likely acquired some malware. You should download Malwarebytes Anti-Malware and do an update and full scan.

Athraithe ag Obscvred ar

Réiteach roghnaithe

That was very hard, and very good work. Well Done !

Read this answer in context 👍 0

All Replies (1)

more options

Réiteach Roghnaithe

That was very hard, and very good work. Well Done !